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Processing & Analyzing nmon Graphically
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nmon is a tool for viewing & collection system data

AIX
● Built in as part of topas
● Closed source

Linux
● Open source
● Download and install from 

http://nmon.sourceforge.net/pmwiki.php?n=Site.Download
– Make sure you get the right one for your distribution

●

http://nmon.sourceforge.net/pmwiki.php?n=Site.Download
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nmon has a graphical mode

Just run from the command 
line.

● nmon 
● Then hit letters to show 

data
– c(pu), d(isk), n(etwork) is 

a good start but it may not 
fit on the screen

– h(elp) for more

– q(uit) to exit

This is live data.
It does not write to a file.
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Write nmon data to a file

Command line switch
● -f  create a file named ⇒ <hostname>_<yyMMdd>_<HHmm>.nmon in the 

current directory
● -F  specify the file name⇒

Also need to specify
● -c – number of samples, default 3000
● -s – time between samples in seconds, default 30
● Samples * count = time nmon will run

If you need to stop nmon, do not just kill it!
● Use user signal 2 to have nmon stop after writing the next record

– Prevents corruption of the last sample

● Linux – kill -s USR2 <pid>
● AIX – kill -s SIGUSR2 <pid>
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I have nmon Data, now what?

NMONAnalyzer
● Excel spreadsheet macro

– Do you have Excel?
– Slower

●

● Only a single file at a time
●

● Time ranges only specified in 
terms of samples

NMONVisualizer
● Java GUI (Swing)

– Runs anywhere
– Faster

●

● Multiple files at once
– Either from a single server or 

multiple servers

●

● Absolute and relative time 
ranges

– Handles time zones too
●

● Also processes IOStat, 
Verbose GC & ESXTop files
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Getting NMONVisualizer

NMONVisualizer can be downloaded from the link on 
http://nmonvisualizer.github.io/nmonvisualizer/

NMONVisualizer is an open source project
● GitHub Project Page – 

https://github.com/nmonvisualizer/nmonvisualizer
● GitHub Releases –

https://github.com/nmonvisualizer/nmonvisualizer/releases

http://nmonvisualizer.github.io/nmonvisualizer/
https://github.com/nmonvisualizer/nmonvisualizer
https://github.com/nmonvisualizer/nmonvisualizer/releases
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Running NMONVisualizer

Windows & Mac
● Can just double click if a 

JRE is installed

Linux or AIX
● Command line (java -jar)
● XWindows works too

Make sure you have max heap
(-Xmx) set high enough

● May need 1 or 2 GB for a 
'large number' of files

– Depends on the amount of 
data per file
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Parsing nmon data

Multiple ways to get files into 
the program

● File → Load or CTRL-O
– Opens file dialog

● Multi-selection supported
● Directories supported; fully 

recursive

● Drag and Drop
– Drag from file viewer (Explorer, 

Finder, etc) into left hand pane 
of UI
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NMONVisualizer displays reports at multiple levels

Top Level – All Systems
● For each system, show either

– Average data for the interval
– Average data (as a single point) for all intervals

System Level
● For each system show data across time

Metric Level
● For each metric show data across time for all fields

Field Level
● For each field show data across time

All reports & charts can be filtered by time using Intervals
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Creating Intervals

Open the Interval Manager dialog
● Click on Manage (the clock)
● CTRL-I

Supports multiple methods
● Absolute
● Relative to the earliest time in all 

files
● Bulk

– Add multiple intervals over a given 
range

– Supports separation between 
intervals (i.e. rampup)

– Easy to add intervals that cover an 
hour or day via the 1 Hour / 1 Day 
buttons
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Interval Manager Tips & Tricks

Charts are 'live'
● When an interval is added, the charts will update
● In the Interval Manager, right clicking on the interval will allow you to make the selected one 

the current
● Useful if you move the Interval Manager so it is not over the main window

System Times section of the Interval Manager graphically indicates which systems have 
data for the current interval

● Strikethrough – no data
● Bold Italics – interval exactly matches start and / or stop
● Bold – interval is before start or after stop
● This data updates as you change the start / stop in the interval dialog or click on an existing 

interval

Right clicking on a system will allow either
● Setting the start and stop to the system time
● Creating a new interval directly



© 2013 IBM Corporation

Changing the Current Interval

Once intervals are created, you can switch between them with
● The Intervals menus
● The Interval drop down at the top of the UI
● CTRL-ALT-1 through CTRL-ATL-9 switch between the first 9 intervals

There is always a default, All Data interval that will display all the 
parsed data

● Unique entry in menu and drop down
● CTRL-ALT-0

Charts are 'live' and update as the interval changes
● Application title also changes
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Where to start the analysis

All Systems report shows average, summary data
● Does one system stand out with higher CPU, memory disk or 

network?
– Is it what you expected?
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Digging into a specific system

Individual System reports show data over time
● CPU – spikes in the middle of the run / plateau?
● Memory & Swap – expected memory usage and no swap?
● Disk Reads / Writes – IOs on the expected disks?
● Disk Busy / Disk Transfers – IO rate is not too high?
● Network Reads / Writes – traffic on the expected interfaces?
● CPU by Process – expected processes are using CPU?
● CPU Balance – CPU utilization is balanced across cores?

Hyperthreads / SMT threads use is lower at low overall CPU?
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Raw nmon Data

All nmon data is available in the Metric & Field level 
charts

● Some disk data is duplicated (dm-x  vs associated 
sdy's)

● Some disk data is additive (sdx = sdx1+sdx2+…
+sdxn) 

The most useful data is probably the per process 
data, TOP

● Different organization that other data
– Entry per process when there is a single 

instance of the process
– Folder per process when there are multiple 

instances
● Aggregated data is in the process without 

a pid
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TOP Data Tips & Tricks

Hover over a process in the tree
● A tool tip will display a shortened 

version of the command line

Right click on a process
● Process Info option opens a dialog 

with the full command line
– Each command line option is on a 

separate line
– Data is selectable for copy & 

paste
● Note process start and stop time may 

not be accurate
– Start time may be when nmon was 

started
– Stop time may be when nmon was 

stopped

● Link with Tree option can be 
unchecked

– Open a second process info dialog to 
compare two processes
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Chart Tips & Tricks

Click on a line / bar and it will highlight the row in the table
● … and vice-versa
● Multi-selection is supported
● Clicking on the legend item also works

– This may be easier since lines actually have to be clicked on the data point

Mouse over is also supported
● Line charts show series name, time and value
●  Bar charts show series name, value and percentage of total
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Chart Tips & Tricks

Right click on the table or CTRL-SHIFT-C to change columns
● CTRL-A for all; CTRL-D for defaults; CTRL-X for none
● This sets for all charts at the same 'level', e.g. only System charts

Line charts have an option to show / hide selected lines
● Click the checkbox
● Right click on table

– Show selected, show none or show all
● These are saved per-metric (i.e. CPU001 != CPU002)

Tables are sortable by column
● This sets for all charts at the same 'level'
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Granularity

All charts as displayed with a globally set 'granularity'
● How granular are the data points on the chart?
● Sets how much data is averaged to compute a single point on a 

line chart
● Measured in seconds
● Concept similar to Load Runner analysis

Automatically calculated by default
● Fit ~100 points on a chart
● Updates as intervals change

Manually set via View → Set Granularity or CTRL-G



© 2013 IBM Corporation

Data Tables

Data tables as a way to create summary, spread sheet like views of data
● Click on the Table radio button, View → Summary Table, or CTRL-T

Drag metrics or fields from the tree onto the data table
● Metric will include all fields
● Automatically analyzes data for all systems

Remove data with right click option or Clear button
● Remove option removes field for all hosts
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Data Tables, continued

Two views supported
● Default shows a row per 

host / data type / metric 
combo with statistics for 
columns

●

● Transposed shows a row 
per data type / metric 
combo with hosts for 
columns

– Single displayed statistic is 
selectable via a drop down

●

● Change via Transpose 
button or CTRL-SHIFT-T
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Saving & Exporting Charts

Save to PNG
● Right click on a chart & select Save Chart

– Prompts for a file name, suggests a sensible default

● Right click on the tree
– Asks for a folder and uses the default file name
– All Systems and individual systems save all charts in the report

● Fixed resolution of ½ of 1920x1080

Copy to clipboard
● Right click on a chart & select Copy

Export to CSV
● Right click on a chart & select Copy Chart Data
● Paste into a file, Excel Etc
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Saving & Exporting Raw Data as CSV

Save to file
● Right click on system, metric or field in the tree, select Save to CSV

Copy to clipboard
● Right click on system, metric or field in the tree, select Copy

Data tables can also be copied by right clicking
● Copy  ⇒ currently selected row
● Copy All  ⇒ all rows
● Copy button  ⇒ all rows
●



© 2013 IBM Corporation

Running nmon as a Service
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Running nmon as a service in RHEL 6

Copy nmon initd script to /etc/init.d/nmon
Copy nmon logrotate script to /etc/logrotate.d/nmon
Create symbolic link from nmon executable to /usr/bin/nmon

Setup permissions & start nmon service

chown root:root /etc/init.d/nmon
chmod 755 /etc/init.d/nmon
chown root:root /etc/logrotate.d/nmon
chcon --reference /etc/init.d/network /etc/init.d/nmon
chmod 644 /etc/logrotate.d/nmon
chown root:root /usr/bin/nmon_x86_64_rhel6
chcon --reference /etc/logrotate.d/yum /etc/logrotate.d/nmon
chmod 755 /usr/bin/nmon_x86_64_rhel6
ln -s -f /usr/bin/nmon_x86_64_rhel6 /usr/bin/nmon
chkconfig --add nmon
service nmon start

nmon collects every 30 seconds; 15 days of logs are retained in /var/log/nmon/old
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Linux nmon Scripts

See http://nmonvisualizer.github.io/nmonvisualizer/startup.html

http://nmonvisualizer.github.io/nmonvisualizer/startup.html
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Running nmon as a service in AIX

AIX supports daily nmon collection out of the box.

Run smit topas to start smit.
● Select Start New Recording →  Start Persistent local recording
● Select nmon as type
● Set the following options

Recording interval in seconds: 30
Number of Days to retain: 15
Include Fiber Channel Section: yes (on VIOS)
Include Shared Ethernet Section: yes (on VIOS)
Include Large Page Section: yes
Include Asynchronus IO: yes

● Hit enter to run the command
● Esc 0 to exit smit

There should now be an nmon file in /etc/perf/daily.

To stop nmon section, run smit topas. Then select Stop Recording → Stop Persistent Recording 
→ Stop Persistent local nmon Record
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