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Progetto

Scrittura Codice R Support Features Pro RStudio

Modalità Debug Version Control con Git o SVN

Scrittura Package

Trasforma il tuo progetto in un package, 
abilita la documentazione roxygen con

Tools > Project Options > Build 
Tools

Guida Roxigen su

Help > Roxygen Quick Reference

File > New Project > 

New Directory > R Package

ulteriori informazioni su www.rstudio.com

L’IDE di RStudio è un ambiente di sviluppo integrato in R distribuito in tre versioni

Desktop IDE

Una versione locale 
dell’IDE per il vostro 
desktop

Server Open Source

per grandi sistemi di 
elaborazione e ad accesso 
remoto

Server Professionale

per team che condividono grandi 
sistemi di elaborazione, grandi 
quantità di dati, e un ambiente di 
collaborazione uniforme

Tutte le versioni sono disponibili su www.rstudio.com. Ogni versione fornisce la stessa interfaccia:

Condividi progetto 
con collaboratori

Collaboratori 
attivi

Seleziona 
la versione 
R

Inizia una nuova 
Session per questo 
progetto
Concludi la 
Session di 
questo progetto

JHT

RStudio salva lo storico, 
workspace, e la directory di 
lavoro associata con il 
progetto. Il tutto viene 
ricaricato ogni volta si riapre il 
progetto. 

Nome del 
progetto

La funzione View(<dati>) apre una visualizzazione simile 
ad un foglio di calcolo

Ordina 
per 
valori

Filtra righe per 
valore o range di 
valori

Ricerca 
per valori

Il pannello Viewer mostra contenuto HTML, come 
applicazioni Shiny, report RMarkdown, e visualizzazioni 

interattive

Termina 
applicazione
Shiny

Pubblica su shinyapps.io, 
rpubs, RSConnect, …

Aggiorna

RStudio apre la documentazione (Help) in un pannello 
dedicato 

Home page 
di help

Ricerca 
all’interno del 
file di help

Ricerca 
file di help

Il gestore dei pacchetti lista ogni package installato

Clicca per caricare un 
package con library().
Deseleziona per disattivare 
il package con detach()

Rimuovi 
dalla 
libreria

Installa
Package

Aggiorna
Package

Crea package riproducibile
per il vostro progetto

RStudio apre i grafici nell’apposito pannello dei Plot

Naviga plot 
Apri in 
una 
finestra

Esporta
plot

Cancella
plot

Cancella 
tutti i 
plot

Versione 
del 
package 
installata

Esaminare variabili 
nell’attuale 
ambiene

Si apre con debug(), browse(), o un breakpoint. RStudio entrera 
in fase di debug quando incontra un breakpoint durante 
l’esecuczione del codice.

Apri il traceback per 
mostrare la funzione che R 
ha chiamato prima del 
verificarsi dell’errore

Esegui il 
debugger da dove 
si è generato 
l’errore

Clicca accanto 
al numero di 
riga per 
aggiungere/ 
rimuovere
breakpoint.

Selezionare le 
funzioni nel 
traceback da 
debuggare

La riga 
evidenziata 
mostra dove 
l’esecuzione 
si è fermata

Si possono eseguire 
comandi nell’ambiente 
quando l’esecuzione è 
in pausa

Avanzamento 
nel code, una 
linea alla 
volta

Entra ed esci
dalle funzioni 
da eseguire

Riprendi 
esecuzione

Termina 
modalità di 
debug

Nel panello Source si 
possono aprire file Shiny, 
R Markdown, knitr, 
Sweave, LaTeX, .Rd e 
molti altri

Controllo 
ortorafico

Renderizza 
output

Scegli 
formato 
di 
output

Scegli 
percorso 
destinazi
one

Inserisci 
blocco di 
codice

Vai al 
blocco 
precede
nte

Vai al 
blocco 
success
ivo

Esegui 
codice 
selezion
ato

Pubblica 
sul server Visualizza 

file

Imposta le 
opzioni del 
bocco knitr

Esegui 
questo e tutti 
i blocchi di 
codice 
precedenti

Esegui 
questo 
blocco di 
codice

Vai al 
blocco

RStudio riconosce tutti i file nominati app.R, 
server.R, ui.R, e global.R belong to a shiny 
app

Esegui 
applicazione

Scegli 
percorso 
per vedere 
l’app

Pubblica su 
shinyapps.io 
o sul server

Gestisci gli 
account di 
pubblicazi
one

Accedi alla guida R Markdown

Help > Markdown Quick Reference

RStudio IDE 
Scheda di Riferimento

File 
indicizati:

Mostra
file diff

Commit dei 
file 
indicizati

Push/Pull  
da remoto

Visualiz
za 
storico

current 
branch

• Aggiunto
• Eliminato
• Modificato
• Rinominato
• Non 

tracciato

Attivalo con Tools > Project Options > 
Git/SVN

Open shell to 
type 
commands

A

D

M

R

?

Cerca 
all’interno 
dell’ambiente

Colorazione sintattica 
basata sull’estensione del 
file

Diagnostica del codice che appare ai 
margini. Passa con il mouse sopra per 
ulteriori dettagli.

Completamento con 
(Tab)per nomi di funzioni,
percorsi di file, argomenti, e 
molto altro.

Snippet di codice multi-
lingua per usare blocchi di 
codice comuni più 
velocemente.

Apri in un 
nuova finestra

Salva Trova e 
sostituisci

Compila 
come 
blocconote

Esegui 
codice 
selezionato

Sorgente con o 
senza echo

Visualizza 
file

Salta ad una funzione nel file Cambia il tipo di file

Naviga
tabs

Un navigatore di file associato alla tua directory di 
lavoro. Clicca su un file o sun una directory per 
aprire.

Percorso della directory mostrata

Carica 
file

Crea 
cartella

Cancella 
file Rinomina 

file

Cambia 
directory

Mostra gli oggetti salvati per 
tipo con una breve 
descrizione

Visualizza 
codice 
sorgente della 
funzione

Visualizza 
nel data 
viewer

Carica
workspace

Salva
workspace

Importa dati 
usando il wizard

Cancella tutti 
gli oggetti 
salvati

Mostra oggetti 
come lista o 
griglia

Scegli ambiente da mostrare partendo 
dalla lista di macro ambienti

Storico dei 
comandi

Mostra presentazione
.RPres

File > New  File > R 
Presentation

Directory di 
lavoro

Massimizza, 
minimizza 
pannelli

Trascina bordi

JHT

Cursore 
condiviso 
degli utenti

File > New Project

Premi ↑ per 
vedere lo storico 
dei comandi

Selezione di cursori/colonne multiple 
con Alt + trascina mouse.

Documenti e Applicazioni

Riesegui il 
codice 
precedente
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1 LAYOUT Windows/Linux Mac

Focalizza su Source Editor Ctrl+1 Ctrl+1

Focalizza su Console Ctrl+2 Ctrl+2

Focalizza su Help Ctrl+3 Ctrl+3

Mostra lo storico Ctrl+4 Ctrl+4

Mostra Files Ctrl+5 Ctrl+5

Mostra Plots Ctrl+6 Ctrl+6

Mostra Packages Ctrl+7 Ctrl+7

Mostra Environment Ctrl+8 Ctrl+8

Mostra Git/SVN Ctrl+9 Ctrl+9

Mostra Build Ctrl+0 Ctrl+0

4 SCRIVI CODICE Windows /Linux Mac
Autocompletamento Tab o Ctrl+Spazio Tab o Cmd+Spazio

Naviga tra i candidati ↑/↓ ↑/↓

Accetta candidato Invio, Tab, o → Invio, Tab, o →

Scarta candidato Esc Esc

Annulla Ctrl+Z Cmd+Z

Rifai Ctrl+Shift+Z Cmd+Shift+Z

Taglia Ctrl+X Cmd+X

Copia Ctrl+C Cmd+C

Incolla Ctrl+V Cmd+V

Seleziona Tutto Ctrl+A Cmd+A

Cancella entry Ctrl+D Cmd+D

Seleziona Shift+[Arrow] Shift+[Arrow]

Seleziona parola Ctrl+Shift+ ←/→ Option+Shift+ ←/→

Seleziona sino a inizio riga Alt+Shift+← Cmd+Shift+←

Seleziona sino a fine riga Alt+Shift+→ Cmd+Shift+→

Seleziona pagina su/giù Shift+Pag Su/Giù Shift+Pag Su/Giù

Duplica riga su/giu Shift+Alt+↑/↓ Cmd+Shift+↑/↓

Cancella parola a sinistra Ctrl+Backspace Ctrl+Opt+Backspace

Cancella parola a destra Ctrl+Canc Option+Canc

Cancella sino a fine riga Ctrl+K

Cancella sino a inizio riga Option+Backspace

Indenta Tab (a inizio riga) Tab (a inizio riga)

Elimina indentazione Shift+Tab Shift+Tab

Taglia riga fino al cursore Ctrl+U Ctrl+U

Taglia riga dopo il cursore Ctrl+K Ctrl+K

Inserisce testo tagliato Ctrl+Y Ctrl+Y

Inserisci <- Alt+- Option+-

Inserisci %>% Ctrl+Shift+M Cmd+Shift+M

Mostra help per funzione F1 F1

Mostra codice sorgente fun. F2 F2

Nuovo documento Ctrl+Shift+N Cmd+Shift+N

Nuovo documento (Chrome)Ctrl+Alt+Shift+N Cmd+Shift+Alt+N

Apri documento Ctrl+O Cmd+O

Salva documento Ctrl+S Cmd+S

Chiudi documento Ctrl+W Cmd+W

Chiudi documento (Chrome)Ctrl+Alt+W Cmd+Option+W

Chiudi tutti i documenti Ctrl+Shift+W Cmd+Shift+W

Estrai funzioni Ctrl+Alt+X Cmd+Option+X

Estrai una variabile Ctrl+Alt+V Cmd+Option+V

Reindenta codice Ctrl+I Cmd+I

(De)Commenta codice Ctrl+Shift+C Cmd+Shift+C

Formatta i commenti Ctrl+Shift+/ Cmd+Shift+/

Ri-format selezione Ctrl+Shift+A Cmd+Shift+A

Mostra diagnostica Ctrl+Shift+Alt+P Cmd+Shift+Alt+P

Transpose Letters Ctrl+T

Muovi codice su/giu Alt+↑/↓ Option+↑/↓

Copy Lines su/giu Shift+Alt+↑/↓ Cmd+Option+↑/↓

Aggiungi nuovo cursore su Ctrl+Alt+Su Ctrl+Alt+Su

Aggiungi nuovo cursore giù Ctrl+Alt+Giù Ctrl+Alt+Giù

Muovi cursore attivo su Ctrl+Alt+Shift+Su Ctrl+Alt+Shift+Su

Muovi cursore attivo giù Ctrl+Alt+Shift+Giù Ctrl+Alt+Shift+Giù

Trova e Sostituisci Ctrl+F Cmd+F

Ricerca per Selezione Ctrl+F3 Cmd+E

Sostituisci e ricerca Ctrl+Shift+J Cmd+Shift+J

2 ESEGUI CODICE Windows/Linux Mac

Cerca nel command histrory Ctrl+↑ Cmd+↑

Naviga il command history ↑/↓ ↑/↓

Muovi il cursore a inizio riga Home Cmd+←

Muovi il cursore a fine riga End Cmd+ →

Cambia directory di lavoro Ctrl+Shift+H Ctrl+Shift+H

Interrompi attuale esecuzione Esc Esc

Pulisci console Ctrl+L Ctrl+L

Termina sessione (desktop) Ctrl+Q Cmd+Q

Riavvia Sessione R Ctrl+Shift+F10 Cmd+Shift+F10

Esegui riga/selezione correnteCtrl+Invio Cmd+Invio

Esegui riga (mantieni cursore) Alt+Invio Option+Invio

Esegui da qui fino alla fine Ctrl+Alt+E Cmd+Option+E

Esegui la definizione della 

funzione attuale Ctrl+Alt+F Cmd+Option+F

Includi file Ctrl+Shift+O Cmd+Shift+O

Includi file corrente Ctrl+Shift+S Cmd+Shift+S

Includi con echo Ctrl+Shift+Invio Cmd+Shift+Invio

3 NAVIGA CODICE Windows /Linux Mac

Vai a File/Function Ctrl+. Ctrl+.

Raccogli selezione Alt+L Cmd+Option+L

Distendi selezione Shift+Alt+L Cmd+Shift+Option+L

Raccogli tutto Alt+O Cmd+Option+O

Distendi tutto Shift+Alt+O Cmd+Shift+Option+O

Vai a linea Shift+Alt+G Cmd+Shift+Option+G

Salta a Shift+Alt+J Cmd+Shift+Option+J

Cambia Tab Ctrl+Shift+. Ctrl+Shift+.

Tab precedente Ctrl+F11 Ctrl+F11

Tab successiva Ctrl+F12 Ctrl+F12

Prima Tab Ctrl+Shift+F11 Ctrl+Shift+F11

Ultima Tab Ctrl+Shift+F12 Ctrl+Shift+F12

Naviga all’indietro Ctrl+F9 Cmd+F9

Naviga in avanti Ctrl+F10 Cmd+F10

Jump to Brace Ctrl+P Ctrl+P

Selez. nelle parentesi Ctrl+Shift+Alt+E Ctrl+Shift+Alt+E

Usa la selez. come ricercaCtrl+F3 Cmd+E

Cerca in File Ctrl+Shift+F Cmd+Shift+F

Trova successivo Win: F3, Linux: Ctrl+G Cmd+G

Trova precedente W:Shift+F3, L:Ctrl+Shift+G Cmd+Shift+G

Salta parola Ctrl+ ←/→ Option+ ←/→

Salta all’inizio/fine Ctrl+↑/↓ Cmd+↑/↓

5 DEBUG Windows/Linux Mac

Aziona Breakpoint Shift+F9 Shift+F9

Esegui nuova riga F10 F10

Entra nella Funzione Shift+F4 Shift+F4

Termina Funzione/Loop Shift+F6 Shift+F6

Continua Shift+F5 Shift+F5

Concludi Debugging Shift+F8 Shift+F8

6 VERSION CONTROL Windows/Linux Mac

Mostra diff Ctrl+Alt+D Ctrl+Option+D

Convalida modifiche (commit) Ctrl+Alt+M Ctrl+Option+M

Scorri la vista diff Ctrl+↑/↓ Ctrl+↑/↓

Indicizza/Deindicizza (Git) Spazio Spazio

Indic./Deindic. e vai al success. Invio Invio

7 CREA PACKAGES Windows/Linux Mac

Build e Ricarica Ctrl+Shift+B Cmd+Shift+B

Carica tutto (devtools) Ctrl+Shift+L Cmd+Shift+L

Testa Package (Desktop) Ctrl+Shift+T Cmd+Shift+T

Testa Package (Web) Ctrl+Alt+F7 Cmd+Alt+F7

Controlla Package Ctrl+Shift+E Cmd+Shift+E

Documenta Package Ctrl+Shift+D Cmd+Shift+D

8 DOCUMENTI E APPLICAZ. Windows/Linux Mac

Anteprima HTML (Markdown, etc.) Ctrl+Shift+K Cmd+Shift+K

Documento Knit (knitr) Ctrl+Shift+K Cmd+Shift+K

Compila Notebook Ctrl+Shift+K Cmd+Shift+K

Compila PDF (TeX and Sweave) Ctrl+Shift+K Cmd+Shift+K

Inserisci blocco (Sweave and Knitr) Ctrl+Alt+I Cmd+Option+I

Inserisci sezione di codice Ctrl+Shift+R Cmd+Shift+R

Ri-esegui regione precedente Ctrl+Shift+P Cmd+Shift+P

Esegui documento corrente Ctrl+Alt+R Cmd+Option+R

Esegui dall’inizio sino a linea corrente Ctrl+Alt+B Cmd+Option+B

Esegui la sezione di codice corrente Ctrl+Alt+T Cmd+Option+T

Run previous Sweave/Rmd code Ctrl+Alt+P Cmd+Option+P

Esegui il blocco corrente Ctrl+Alt+C Cmd+Option+C

Esegui il prossimo blocco Ctrl+Alt+N Cmd+Option+N

Sincronizza Editor & anteprima PDF Ctrl+F8 Cmd+F8

Plot precedente Ctrl+Alt+F11 Cmd+Option+F11

Plot successivo Ctrl+Alt+F12 Cmd+Option+F12

Mostra scorciatoie Alt+Shift+K Option+Shift+K

Puoi fare tutto quello che potresti fare con un server open 
source, con una licenza commerciale, supporto, e molto più.

• Modifica lo stesso progetto allo stesso tempo degli altri

• Cambiare facilmente da una versione di R ad un’altra

• Aprire ed eseguire sessioni multiple di R simultaneamente

• Osservare cosa tu e gli altri state eseguendo sul vostro server

• Tarare le tue risorse per migliorare le performance

• Integrato con l’autenticazione, autorizzazione, e controllo

Scarica una versione di prova per 45 giorni da

www.rstudio.com/products/rstudio-server-pro/
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