Location via proxy:   [ UP ]  
[Report a bug]   [Manage cookies]                

Rip Protocol Configuration Guide With Examples

Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 13

RIP is the simplest and one of the oldest Distance Vector routing protocol.

It is very easy to
setup and troubleshoot. In this tutorial we will explain how to configure RIP Routing protocol
with example. For demonstration we will use packet tracer network simulator software. You
can use real Cisco devices or any other network simulator software for following this guide.

This tutorial is last part of our article RIP Routing protocol explained with example. You
can read other parts of this article here.

http://computernetworkingnotes.com/ccna-study-guide/rip-tutorial-basic-operation-of-rip-
protocol.html

This is the first part of this article. In this part we explained basic concept of RIP protocol
such as what RIP protocol is and how it shares routing information. Later we summarized
RIP routing update process in step by step guide.

http://computernetworkingnotes.com/ccna-study-guide/rip-routing-information-protocol-
explained.html

This is the second part of this article. In this part we explained fundamental topics of RIP
routing like Routing metric, Split horizon, Hop counts, Route poison, RIP timer and
difference between RIPv1 and RIPv2.

Create a topology as illustrate in following figure or download pre-created topology from our
server.

Device Interface IP Configuration Connected with


PC0 Fast Ethernet 10.0.0.2/8 Router0s Fa0/1
Router0 Fa0/1 10.0.0.1/8 PC0s Fast Ethernet
Router0 S0/0/1 192.168.1.254/30 Router2s S0/0/1
Router0 S0/0/0 192.168.1.249/30 Router1s S0/0/0
Router1 S0/0/0 192.168.1.250/30 Router0s S0/0/0
Router1 S0/0/1 192.168.1.246/30 Router2s S0/0/0
Router2 S0/0/0 192.168.1.245/30 Router1s S0/0/1
Router2 S0/0/1 192.168.1.253/30 Router0s S0/0/1
Router2 Fa0/1 20.0.0.1/30 PC1s Fast Ethernet
PC1 Fast Ethernet 20.0.0.2/30 Router2s Fa0/1

Assign IP address to PCs


Double click PC0 and click Desktop menu item and click IP Configuration. Assign IP
address 10.0.0.2/8 to PC0.

Repeat same process for PC1 and assign IP address 20.0.0.2/8.

Assign IP address to interfaces of routers


Double click Router0 and click CLI and press Enter key to access the command prompt of
Router0.

Three interfaces FastEthernet0/0, Serial0/0/0 and Serial0/0/1 of Router0 are used


in this topology. By default interfaces on router are remain administratively down during the
start up.
We need to configure IP address and other parameters on interfaces before we could actually
use them for routing. Interface mode is used to assign IP address and other parameters.
Interface mode can be accessed from global configuration mode. Following commands are
used to access the global configuration mode.

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
From global configuration mode we can enter in interface mode. From there we can configure
the interface. Following commands will assign IP address on FastEthernet0/0.

Router(config)#interface fastEthernet 0/0


Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#

interface fastEthernet 0/0 command is used to enter in interface mode.

ip address 10.0.0.1 255.0.0.0 command will assign IP address to interface.

no shutdown command will bring the interface up.

exit command is used to return in global configuration mode.


Serial interface needs two additional parameters clock rate and bandwidth. Every serial cable
has two ends DTE and DCE. These parameters are always configured at DCE end.

We can use show controllers interface command from privilege mode to check the
cables end.

Router#show controllers serial 0/0/0


Interface Serial0/0/0
Hardware is PowerQUICC MPC860
DCE V.35, clock rate 2000000
[Output omitted]

Fourth line of output confirms that DCE end of serial cable is attached. If you see DTE here
instead of DCE skip these parameters.

Now we have necessary information lets assign IP address to serial interface.


Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 192.168.1.249 255.255.255.252
Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 64
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial 0/0/1
Router(config-if)#ip address 192.168.1.254 255.255.255.252
Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 64
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#

Router#configure terminal Command is used to enter in global configuration


mode.

Router(config)#interface serial 0/0/0 Command is used to enter in interface


mode.

Router(config-if)#ip address 192.168.1.249 255.255.255.252


Command assigns IP address to interface. For serial link we usually use IP address from /30
subnet.

Router(config-if)#clock rate 64000 And Router(config-


if)#bandwidth 64 In real life environment these parameters control the data flow
between serial links and need to be set at service providers end. In lab environment we need
not to worry about these values. We can use these values.

Router(config-if)#no shutdown Command brings interface up.

Router(config-if)#exit Command is used to return in global configuration mode.

We will use same commands to assign IP addresses on interfaces of remaining routers. We


need to provided clock rate and bandwidth only on DCE side of serial interface. Following
command will assign IP addresses on interface of Router1.

Router1
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 192.168.1.250 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial 0/0/1
Router(config-if)#ip address 192.168.1.246 255.255.255.252
Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 64
Router(config-if)#no shutdown
Router(config-if)#exit

Use same commands to assign IP addresses on interfaces of Router2.

Router2

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 20.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 192.168.1.245 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial 0/0/1
Router(config-if)#ip address 192.168.1.253 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
Great job we have finished our half journey. Now routers have information about the
networks that they have on their own interfaces. Routers will not exchange this information
between them on their own. We need to implement RIP routing protocol that will insist them
to share this information.

Configure RIP routing protocol

Configuration of RIP protocol is much easier than you think. It requires only two steps to
configure the RIP routing.

Enable RIP routing protocol from global configuration mode.


Tell RIP routing protocol which networks you want to advertise.

Lets configure it in Router0

Router0

Router0(config)#router rip
Router0(config-router)# network 10.0.0.0
Router0(config-router)# network 192.168.1.252
Router0(config-router)# network 192.168.1.248

router rip command tell router to enable the RIP routing protocol.

network command allows us to specify the networks which we want to advertise. We only
need to specify the networks which are directly connected with the router.

Thats all we need to configure the RIP. Follow same steps on remaining routers.

Router1

Router1(config)#router rip
Router1(config-router)# network 192.168.1.244
Router1(config-router)# network 192.168.1.248

Router2

Router2(config)#router rip
Router2(config-router)# network 20.0.0.0
Router2(config-router)# network 192.168.1.252
Router2(config-router)# network 192.168.1.244

Thats it. Our network is ready to take the advantage of RIP routing. To verify the setup we
will use ping command. ping command is used to test the connectivity between two devices.
Access the command prompt of PC1 and use ping command to test the connectivity from
PC0.

Good going we have successfully implemented RIP routing in our network. For cross check
we have uploaded a configured topology on our server. You can use that if not getting same
output.

RIP protocol automatically manage all routes for us. If one route goes down, it automatically
switches to another available. To explain this process more clearly we have added one more
route in our network.

Currently there are two routes between PC0 and PC1.

Route 1

PC0 [Source / destination 10.0.0.2] Router0 [FastEthernet0/1 10.0.0.1] Router0


[Serial0/0/1 192.168.1.254] Router2 [Serial 0/0/1 192.168.1.253] Router2
[FastEthernet0/0 20.0.0.1] PC1 [Destination /source 20.0.0.2]

Route 2
PC0 [Source / destination 10.0.0.2] Router0 [FastEthernet0/1 10.0.0.1] Router0
[Serial0/0/0 192.168.1.249] Router1 [Serial 0/0/0 192.168.1.250] Router1 [Serial
0/0/1 192.168.1.246] Router2 [Serial 0/0/0 192.168.1.245] Router2
[FastEthernet0/0 20.0.0.1] PC1 [Destination /source 20.0.0.2]

By default RIP will use the route that has low hops counts between source and destination. In
our network route1 has low hops counts, so it will be selected. We can use tracert command
to verify it.

Now suppose route1 is down. We can simulate this situation by removing the cable attached
between Router0 [s0/0/1] and Router2 [s0/0/1].
Okay our primary route went down. What will be happen now?

So far we are running RIP routing protocol and have another route to destination, there is no
need to worry. RIP will automatically reroute the traffic. Use tracert command again to see
the magic of dynamic routing.
Thats all for this article. In next article we will explain another routing protocol with
examples.
RIP Routing protocol configuration commands summary

Command Description

Router(config)#router rip Enable RIP routing protocol

Add a.b.c.d network in RIP routing


Router(config-router)#network a.b.c.d
advertisement

Remove a.b.c.d network from RIP routing


Router(config-router)#no network a.b.c.d
advertisement

Enable RIP routing protocol version one


Router(config-router)#version 1
( default)

Router(config-router)#version 2 Enable RIP routing protocol version two

By default RIPv2 automatically summarize


Router(config-router)#no auto-summary networks in their default classful boundary.
This command will turn it off.

Router(config-router)#passive-interface RIP will not broadcast routing update from


s0/0/0 this interface

Router(config-router)#no ip split-horizon Disable split horizon ( Enable by default )

Router(config-router)#ip split-horizon Enable spilt horizon

Allow us to set RIP timer in seconds. 30


Router(config-router)#timers basic 30 90 (routing update), 90 (invalid timer), 180
180 270 360 ( Hold timer), 270 (Flush timer), 360 (sleep
timer)
Router(config)#no router rip Disable RIP routing protocol

Used for troubleshooting. Allow us to view all


Router#debug ip rip
RIP related activity in real time.

Router#show ip rip database Display RIP database including routes

For more articles please visit our site

Computernetworkingnotes.com

You might also like