Location via proxy:   [ UP ]  
[Report a bug]   [Manage cookies]                

CCN-Lab 9

Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 13

FATIMA JINNAH WOMEN UNIVERSITY

Department Of Software Engineering

LAB#09
Summary:
Items Description
Course Title Computer Communication and Networks
Lab Title Routing (RIP)
Duration 3 Hours
Operating System Windows 10
/Tool/Language Cisco Packet Tracer Software
Objective Dynamic Routing & RIP

Dynamic Routing & RIPv1 & 2


A dynamic routing table is created, maintained, and updated by a routing protocol running on
the router. Examples of routing protocols include RIP (Routing Information Protocol), EIGRP
(Enhanced Interior Gateway Routing Protocol), and OSPF (Open Shortest Path First). Specific
dynamic routing protocols are covered in great detail in other guides.

Routers do share dynamic routing information with each other, which increases CPU, RAM, and
bandwidth usage. However, routing protocols are capable of dynamically choosing a different
(or better) path when there is a change to the routing infrastructure.

Do not confuse routing protocols with routed protocols:


 A routed protocol is a Layer 3 protocol that applies logical addresses to devices and
routes data between networks (such as IP)
 A routing protocol dynamically builds the network, topology, and next hop information
in routing tables (such as RIP, EIGRP, etc.) Static vs. Dynamic Routing v1.21 – Aaron
Balchunas

The following briefly outlines the advantages and disadvantages of dynamic routing:

Advantages of Dynamic Routing


 Simpler to configure on larger networks
 Will dynamically choose a different (or better) route if a link goes down
 Ability to load balance between multiple links

Disadvantages of Dynamic Routing


 Updates are shared between routers, thus consuming bandwidth
 Routing protocols put additional load on router CPU/RAM
FATIMA JINNAH WOMEN UNIVERSITY
Department Of Software Engineering

 The choice of the “best route” is in the hands of the routing protocol, and not the
network administrator

Dynamic Routing Categories

There are two distinct categories of dynamic routing protocols:


 Distance-vector protocols
 Link-state protocols

Examples of distance-vector protocols include RIP and IGRP. Examples of link-state protocols
include OSPF and IS-IS.

EIGRP exhibits both distance-vector and link-state characteristics, and is considered a hybrid
protocol.

Distance-vector Routing Protocols

All distance-vector routing protocols share several key characteristics:


 Periodic updates of the full routing table are sent to routing neighbors.
 Distance-vector protocols suffer from slow convergence, and are highly susceptible to
loops.
 Some form of distance is used to calculate a route’s metric.
 The Bellman-Ford algorithm is used to determine the shortest path.

A distance-vector routing protocol begins by advertising directly-connected networks to its


neighbors. These updates are sent regularly (RIP – every 30 seconds; IGRP – every 90 seconds).

Neighbors will add the routes from these updates to their own routing tables. Each neighbor
trusts this information completely, and will forward their full routing table (connected and
learned routes) to every other neighbor. Thus, routers fully (and blindly) rely on neighbors for
route information, a concept known as routing by rumor.

There are several disadvantages to this behavior. Because routing information is propagated
from neighbor to neighbor via periodic updates, distance-vector protocols suffer from slow
convergence. This, in addition to blind faith of neighbor updates, results in distance-vector
protocols being highly susceptible to routing loops.
Distance-vector protocols utilize some form of distance to calculate a route’s metric. RIP uses
hopcount as its distance metric, and IGRP uses a composite of bandwidth and delay.
FATIMA JINNAH WOMEN UNIVERSITY
Department Of Software Engineering

Link-State Routing Protocols


Link-state routing protocols were developed to alleviate the convergence and loop issues of
distance-vector protocols. Link-state protocols maintain three separate tables:
 Neighbor table – contains a list of all neighbors, and the interface each neighbor is
connected off of. Neighbors are formed by sending Hello packets.
 Topology table – otherwise known as the “link-state” table, contains a map of all links
within an area, including each link’s status.
 Shortest-Path table – contains the best routes to each particular destination (otherwise
known as the “routing” table”)

Link-state protocols do not “route by rumor.” Instead, routers send updates advertising the
state of their links (a link is a directly-connected network).
All routers know the state of all existing links within their area, and store this information in a
topology table. All routers within an area have identical topology tables.

The best route to each link (network) is stored in the routing (or shortest-path) table. If the
state of a link changes, such as a router interface failing, an advertisement containing only this
link-state change will be sent to all routers within that area. Each router will adjust its topology
table accordingly, and will calculate a new best route if required.

By maintaining a consistent topology table among all routers within an area, link-state
protocols can converge very quickly and are immune to routing loops.

Additionally, because updates are sent only during a link-state change, and contain only the
change (and not the full table), link-state protocols are less bandwidth intensive than distance-
vector protocols. However, the three link-state tables utilize more RAM and CPU on the router
itself.

Link-state protocols utilize some form of cost, usually based on bandwidth, to calculate a
route’s metric. The Dijkstra formula is used to determine the shortest path.
FATIMA JINNAH WOMEN UNIVERSITY
Department Of Software Engineering

RIP version 1:
In Rip Version 1 use Broadcast and it is Class Full Routing protocol. No
Authentication Required in Rip Version 1
RIP version 2:
In Rip version 2 use Multicast (244.0.0.9) and it is class less routing protocol.
Authentication Required in Rip Version 2

Differences between Rip V1 and Rip V2

 Broadcast  Multicast 244.0.0.9

 Class Full Routing protocol (support  Class Less Routing Protocol (support
FLSM) VLSM)

 No Authentication  Authentication

Significant differences 

Task1:Implement RIPv1 on last lab topology.


FATIMA JINNAH WOMEN UNIVERSITY
Department Of Software Engineering

Router 1
Router>ena
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

Router#
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial2/0
Router(config-if)#no shutdown
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#exit
Router(config)#interface Serial2/0
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#no shutdown

Router(config-if)#
FATIMA JINNAH WOMEN UNIVERSITY
Department Of Software Engineering

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up


ip address 11.0.0.1 255.0.0.0
Router(config-if)#exit

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 10.0.0.0
Router(config-router)#network 11.0.0.0
Router(config-router)#^Z
Router# show ip route

Router 2
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial2/0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
ip address 10.0.0.2 255.0.0.0
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up


ip address 12.0.0.1 255.0.0.0
Router(config-if)#exit
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router r
Router(config)#router rip
Router(config-router)#network 10.0.0.0
Router(config-router)#network 12.0.0.0
Router(config-router)#^Z
FATIMA JINNAH WOMEN UNIVERSITY
Department Of Software Engineering

Router#
%SYS-5-CONFIG_I: Configured from console by console

Router(config-router)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#config t
Router(config)#interface se3/0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up

Router(config-if)#ip address
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

% Incomplete command.
Router(config-if)#ip address 13.0.0.1 255.0.0.0
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial2/0
Router(config-if)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#
Router#
Router#show ip rou
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, Serial2/0


R 11.0.0.0/8 [120/1] via 10.0.0.1, 00:00:21, Serial2/0
FATIMA JINNAH WOMEN UNIVERSITY
Department Of Software Engineering

C 12.0.0.0/8 is directly connected, FastEthernet0/0


C 13.0.0.0/8 is directly connected, Serial3/0
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ri
Router(config)#router rip
Router(config-router)#add net
Router(config-router)#add neto
Router(config-router)#add netw
Router(config-router)#net
Router(config-router)#network 13.0.0.0
Router(config-router)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#
Router#
Router#
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, Serial2/0


R 11.0.0.0/8 [120/1] via 10.0.0.1, 00:00:03, Serial2/0
C 12.0.0.0/8 is directly connected, FastEthernet0/0
C 13.0.0.0/8 is directly connected, Serial3/0

Router 3
Router>ena
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface se2/0
Router(config-if)#ip address 13.0.0.2 255.0.0.0
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
FATIMA JINNAH WOMEN UNIVERSITY
Department Of Software Engineering

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config)#interface fastEthernet 0/0


Router(config-if)#ip address 14.0.0.1 255.0.0.0
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#show ip rout
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 13.0.0.0/8 is directly connected, Serial2/0


Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 13.0.0.0/8 is directly connected, Serial2/0


Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#
Router(config-router)#
Router(config-router)#net
Router(config-router)#network 13.0.0.0
Router(config-router)#network 14.0.0.0
Router(config-router)#^Z
FATIMA JINNAH WOMEN UNIVERSITY
Department Of Software Engineering

Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

R 10.0.0.0/8 [120/1] via 13.0.0.1, 00:00:08, Serial2/0


R 11.0.0.0/8 [120/2] via 13.0.0.1, 00:00:08, Serial2/0
R 12.0.0.0/8 [120/1] via 13.0.0.1, 00:00:08, Serial2/0
C 13.0.0.0/8 is directly connected, Serial2/0
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface fa0/0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#ip address 14.0.0.1 255.0.0.0


Router(config-if)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

R 10.0.0.0/8 [120/1] via 13.0.0.1, 00:00:05, Serial2/0


R 11.0.0.0/8 [120/2] via 13.0.0.1, 00:00:05, Serial2/0
FATIMA JINNAH WOMEN UNIVERSITY
Department Of Software Engineering

R 12.0.0.0/8 [120/1] via 13.0.0.1, 00:00:05, Serial2/0


C 13.0.0.0/8 is directly connected, Serial2/0
C 14.0.0.0/8 is directly connected, FastEthernet0/0

Task 2: Apply RIP V2 on the following topology. Add the third HOP in the below network and configure
with RIP V2.

Router 1
Router>ena
Router#config t
Router(config)#interface serial 2/0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to down


Router(config-if)#ip address 10.0.0.1 255.255.255.252
Router(config-if)#clock rate 128000
Router(config)#interface fastEthernet 0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.10.1 255.255.255.192
Router(config-if)#exit

Router#copy running-config startup-config


Destination filename [startup-config]?
Building configuration...
[OK]
Router#
FATIMA JINNAH WOMEN UNIVERSITY
Department Of Software Engineering

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#?
auto-summary Enter Address Family command mode
default-information Control distribution of default information
distance Define an administrative distance
exit Exit from routing protocol configuration mode
network Enable routing on an IP network
no Negate a command or set its defaults
passive-interface Suppress routing updates on an interface
redistribute Redistribute information from another routing protocol
timers Adjust routing timers
version Set routing protocol version
Router(config-router)#ver
Router(config-router)#version ?
<1-2> version
Router(config-router)#version 2
Router(config-router)#no auto-summary
Router(config-router)#network 10.0.0.0
Router(config-router)#network 192.168.10.0
Router(config-router)#exit
Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#no auto-summary
Router(config-router)#network 10.0.0.0
Router(config-router)#network 192.168.10.0
Router(config-router)#exit
Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Router#
Router#

Router 2
FATIMA JINNAH WOMEN UNIVERSITY
Department Of Software Engineering

Router>
Router>en
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface serial 2/0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

Router(config-if)#ip address 10.0.0.2 255.255.255.252


Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/0
Router(config-if)#no shutdown

Router(config-if)#ip address 172.50.1.1 255.255.240.0


Router(config-if)#exit
Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#no auto-summary
Router(config-router)#network 10.0.0.0
Router(config-router)#network 172.50.0.0
Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Router#

You might also like