MSC (Cyber Security) Program Structure & Syllabus
MSC (Cyber Security) Program Structure & Syllabus
MSC (Cyber Security) Program Structure & Syllabus
PROGRAMME STRUCTURE
FIRST SEMESTER
S. No. Course Title Lecture Tutorial Practical Total
(L) (T) (P) Credits
CORE COURSE (CC)
MCS101 Mathematical Foundation to Computer 2 1 - 3
Science
MCS102 Network Security and Cryptography 2 1 - 3
MCS103 Cyber Security -I 2 1 - 3
MCS122 Network Security and Cryptography - - 2 1
Lab
MCS123 Cyber Security - I Lab - - 2 1
DOMAIN ELECTIVES (DE)
Elective-I Select any ONE
(Without Lab)
MCS131 Information Security Risk Assessment 2 1 - 3
and Assurance
MCS132 Internet Technology
MCS133 Digital Hardware Modeling
Elective-II Select any ONE
(WithLab)
MCS134 Internet of Things 2 1 - 3
MCS135 Secure Protocol Design
MCS136 Probability and Statistical Structure
MCS144 Internet of Things LAB
MCS145 Secure Protocol Design lab - - 2 1
MCS146 Probability and Statistical Structure Lab
Non Teaching Credit Course (NTCC)
MCS151 Report on Workshop / Social Work - - - 1
VALUE ADDED COURSES (VAC)
BCS111 Communication Skills 1 - - 1
BSS111 Behavioural Science-I (Self 1 - - 1
Development and Interpersonal Skills)
Foreign Language 2 - - 2
FLT111 French
FLG111 German
FLS111 Spanish
FLC111 Chinese
TOTAL 23
SECOND SEMESTER
S. No. Course Title Lecture Tutorial Practical Total
(L) (T) (P) Credits
CORE COURSE (CC)
MCS201 Cyber Forensic 2 1 - 3
MCS202 Cyber Security - II 2 1 - 3
MCS203 Intrusion Detection Systems 2 1 - 3
MCS222 Cyber Security - II Lab - - 2 1
MCS223 Intrusion Detection Systems Lab - - 2 1
MCS250 Minor Project - - - 6
DOMAIN ELECTIVES (DE)
Elective-I Select any ONE
(Without Lab)
MCS231 Cyber Laws & Security Policies
MCS232 Social Media Security 2 1 - 3
MCS233 Biometric Security
Elective-II Select any ONE
(With Lab)
MCS234 MATLAB
2 1 - 3
MCS235 Wireless Networks
MCS244 MATLAB Lab
- - 2 1
MCS245 Wireless Networks Lab
OPEN ELECTIVES (OE)
Open Elective 2 1 - 3
VALUE ADDED COURSES (VAC)
BCS211 Communication Skills 1 - - 1
BSS211 Behavioural Science (Behavioural 1 - - 1
Communication and Relationship
Management)
Foreign Language 2 - - 2
FLT211 French
FLG211 German
FLS211 Spanish
FLC211 Chinese
TOTAL 31
THIRD SEMESTER
S. No. Course Title Lecture Tutorial Practical Total
(L) (T) (P) Credits
CORE COURSE (CC)
MCS301 Database and Application Security 2 1 - 3
MCS302 Secure Software Engineering 2 1 - 3
MCS303 Ethical hacking and Digital Forensic 2 1 - 3
Tools
MCS323 Ethical hacking and Digital Forensic - - 2 1
Tools Lab
MCS350 Minor Project - - - 6
MCS352 Summer Internship Project - - - 3
DOMAIN ELECTIVES (DE)
Elective-I Select any ONE
(Without Lab)
MCS331 Artificial Intelligence and Neural Network
MCS332 Human Computer Interaction 2 1 - 3
MCS333 Design and Analysis of Algorithms
Elective-II Select any ONE
(With Lab)
MCS334 Principles of Virtualization
2 1 - 3
MCS335 Python
MCS344 Principles of Virtualization Lab
- - 2 1
MCS345 Python Lab
Non Teaching Credit Course (NTCC)
MCS351 Report on Paper Presentation in - - - 1
Conference
OPEN ELECTIVES (OE)
Open Elective 2 1 - 3
VALUE ADDED COURSES (VAC)
BCS311 Communication Skills 1 - - 1
BSS311 Behavioural Science (Leading Through 1 - - 1
Teams)
Foreign Language 2 - - 2
FLT311 French
FLG311 German
FLS311 Spanish
FLC311 Chinese
TOTAL 34
FOURTH SEMESTER
S. No. Course Title Lecture Tutorial Practical Total
(L) (T) (P) Credits
CORE COURSE (CC)
MCS401 Security Threats & Vulnerabilities 2 1 - 3
MCS402 Information & Network Security 2 1 - 3
Elective Select any ONE
MCS460 Internship
- - - 19
MCS461 Project Work
TOTAL 25
MATHEMATICAL FOUNDATION TO COMPUTER SCIENCE
Course Objective:
The goal of this course is to introduce the fundamental networking concepts, technologies as
well as the understanding of encryption and decryption algorithm.. This course will assist you
in developing the skills necessary to plan implement and secure the small networks across a
range of applications.
Network Layer Networks-dividing host into groups, Routing –How our data packets are
handled, Routing process. LANs, WANs and Internetworks Network Addressing. Transport
Layer : The TCP protocol –communicating with reliability, Managing TCP sessions, The
UDP protocol communicating with low overheads
Application Layer Functionality and Protocols : Provision for applications and services,
Application layer protocols and services. Overview of Ethernet, Ethernet –Communication
through the LAN, The Ethernet Frame ,Ethernet Media Access Control, Ethernet Physical
Layer, Hubs and Switches, Address Resolution Protocol(ARP)
Modern Techniques: Simplified DES, Block Cipher Principles, Data Encryption standard,
Strength of DES, Differential and Linear Cryptanalysis, Block Cipher Design Principles and
Modes of operations. Algorithms: Triple DES,
Text:
Cisco Networking Academy Programme CCNA 1 & 2 Companion Guide, 3rd Edn by
Pearson Education
Cisco Networking Academy Programme CCNA 1 & 2 Lab Companion, 3rd Edn by
Pearson Education
William Stallings, Cryptography and Network Security Principles and Practices, 5th
Edition, PHI/Pearson, 2011.
William Stallings, Network Security Essentials Applications and Standards, 4thEdition,
Pearson Education, 2011.
Christof Paar and Jan Pelzl , Understanding Cryptography – A Textbook for Students and
Practitioners Christof Paar and Jan Pelzl, Springer, 2010
References:
Types of Security, Information Classification and their levels, Process for managing
classified information, Access Control, Types of Access Control - Preventative access
control, Deterrent access control, Detective access control, Corrective access control,
Recovery access control, Compensation access control, Directive access control,
Administrative access controls, Logical/technical access controls, Physical access controls.
Cyber Security Goals, Tools for Confidentiality - Encryption, Access control, Authentication,
Authorization, Physical Security, Tools for Integrity - Backups, Checksums, Data Correcting
Codes, Tools for Availability - Physical Protections, Computational redundancies.
Types of Cyber Security Attacks, Web-based Attacks (Injection Attack, DNS Spoofing,
Session Hijacking, Phishing, Brute Force, Denial of Service, Distributed Denial of Service,
Dictionary Attack, URL Interpretation, File Inclusion Attack, Man in the Middle Attack),
System-based Attack (Virus, Worm, Trojan Horse, Backdoors, Bots), Types of Cyber
Attackers.
Data, Information, and Knowledge, Database (DB), Database Management System (DBMS),
DB Characteristics, DB Users, DBMS Architecture, DBMS Models, DB Relationships, SQL
Overview, DML, DDL, and DCL commands, Security in Database and its Design
Consideration.
Examination Scheme:
Text Books:
Charles J. Brooks, Christopher Grow, Philip Craig, "Cybersecurity Essentials", John Wiley
and Sons, 2018.
References:
William Stallings, "Operating Systems: Internals and Design Principles", Prentice Hall, 2009.
John Purcell, Robert Kiesling, "Linux: The Complete Reference", Linux System Labs, 1998.
The Lab Manual is designed for the implementation of protocols in lab. The exercises in the
Lab Manual correspond to course and are for use in a classroom setting supervised by an
instructor. The Lab Manual presents a rich, hands-on learning experience that encourages
practical solutions and strengthens critical problem-solving skills:
List of Experiments
When given an IP address, network mask, and subnetwork mask, you will be able to
determine other information about the IP address such as:
Caesar cipher
Shift cipher
Affine cipher
Substitution with symbols
Vigen`ere cipher
Hill cipher
One-way functions
The Diffie-Hellman key exchange protocol
The RSA procedure
Examination Scheme:
IA EE
A PR LR V PR V
5 10 10 5 35 35
Note: IA –Internal Assessment, EE- External Exam, PR- Performance, LR – Lab Record, V –
Viva.
CYBER SECURITY - I LAB
Experiments
IA EE
A PR LR V PR V
5 10 10 5 35 35
Note: IA –Internal Assessment, EE- External Exam, PR- Performance, LR – Lab Record, V – Viva.
INFORMATION SECURITY RISK ASSESSMENT AND ASSURANCE
MODULE I
MYTHS OF INFORMATION SECURITY MANAGEMENT: The big picture-Learning
from experience-Weaknesses in Information Security-The extent of crime in cyberspace- The
cyberspace crimoid syndrome-Policies and technologies- A new framework for information
security.
MODULE II
INFORMATION SECURITY ASSESSMENTS: Risk assessment-Richard Baskerville‘s risk
assessment methodology- Generations of risk assessment techniques- Quantitative approach
to risk assessment-Problems with Quantitative approach – NIST ALE- Baseline approach.
MODULE III
SECURITY MANAGEMENT CONCEPTS AND PRINCIPLES: Measuring ROI on
security- Security patch management- Purposes of Information Security management- The
building blocks of information security- Human side of information security-Security
management- Securing new information technology.
MODULE IV
RISK ASSESSMENT: What is Risk? –Information Security Risk Assessment Overview-
Drivers, Laws and Regulations- Risk Assessment Frame work – Practical Approach. System
Risk Analysis- Risk Prioritization- System Specific Risk Treatment- Issue Registers-
Methodology- Result- Risk Registers- Post Mortem.
MODULE V
SECURITY AUDIT PROCESS: Pre-planning audit- Audit Risk Assessment- Performing
Audit- Internal Controls- Audit Evidence- Audit Testing- Audit Finding- Follow-up
activities.
Examination Scheme:
Components CT1 A/C/Q ATTD. EE
Weightage (%) 15 10 5 70
Text Books:
MODULE I
Introduction to digital circuit design flow, Design Representation, VLSI Design Styles,
Verilog variables, operators and language constructs, verilog modeling examples.
MODULE II
Modeling combinational circuits using Verilog, verilog description styles, Modeling
sequential circuits using Verilog, procedural assignment, user defined primitives.
MODULE III
Verilog test benches and design simulation, modeling finite state machines, Behavioral
versus structural design modeling, datapath and controller design, synthesizable verilog.
MODULE IV
Modeling memory, modeling register banks, modeling issues: pipelining, memory, switch
level modeling
MODULE V:
Processor design using verilog, pipeline implementation of a processor, verilog modeling of
the processor
Examination Scheme:
Text Books:
1. J. Bhasker, ―Verilog HDL Synthesis: A Practical Primer‖, B. S. Publications, 1998.
2. M. D. Ciletti, ―Advanced VLSI Design with the Verilog HDL‖, Prentice-Hall of India,
2005.
INTERNET OF THINGS
MODULE I
Introduction to IoT- Internet of Things & their characteristics, Design- Physical & Logical
design, IoT Reference Model- Domain Model, Information Mode, Functional Model, and
Communication Model. M2M and IoT technology fundamentals.
MODULE II
Sensor Technology- Introduction to wireless sensor networks, Sensor nodes- Sensing and
sensors, Challenges and Constraints, Communication Interfaces- Protocols, Application of
Wireless sensors.
MODULE III
Embedded System- Introduction to embedded systems, Application Areas, Categories of
embedded systems, Overview of embedded system, Architecture of embedded systems,
Hardware architecture, Software architecture, Application Software, Communication
Software.
MODULE IV
Domain Specific Application Categories- Big Data Analytics for IoT, Privacy and Security in
IoT, Smart City, Cloud Storage & Computing.
MODULE V
Programming & Interfacing- Open Source Platforms: PIC, Arduino, Sketch and Raspberry Pi.
Getting used to Arduino, Sensor Characterization- Safety, Basic Electronics (circuit theory,
measurements, parts identification). Sensors and Software- Understanding Processing Code
Structure, variables and flow control, interfacing to the Real World.
Examination Scheme:
Components CT1 A/C/Q ATTD. EE
Weightage (%) 15 10 5 70
Text Books:
1. Bernd Scholz-Reiter, Florian Michahelles, ―Architecting the Internet of Things‖, ISBN
978-3-642-19156-5 e-ISBN 978-3-642-19157-2, Springer
2. WaltenegusDargie, Christian Poellabauer , ―Fundamentals of Wireless Sensor
Networks, Theory and Practice‖, Wiley Series on wireless Communication and Mobile
Computing, 2011
3. Arnold. S. Berger, ―Embedded Systems Design - An introduction to Processes, Tools
and Techniques‖, Easwer Press, 2001
4. Programming Interactivity, Second Edition By Josha Noble, 2012
SECURE PROTOCOL DESIGN
MODULE I
OSI: ISO Layer Protocols:-Application Layer Protocols-TCP/IP, HTTP, SHTTP, LDAP,
MIME,-POP& POP3-RMON-SNTP-SNMP. Presentation Layer Protocols-Light Weight
Presentation Protocol Session layer protocols.
MODULE II
RPC protocols-transport layer protocols-ITOT, RDP, RUDP, TALI, TCP/UDP, compressed
TCP. Network layer Protocols – routing protocols-border gateway protocol-exterior gateway
protocol-internet protocol IPv4- IPv6- Internet Message Control Protocol- IRDPTransport
Layer Security-TSL-SSL-DTLS.
MODULE III
Data Link layer Protocol – ARP – In ARP – IPCP – IPv6CP – RARP – SLIP .Wide Area and
Network Protocols- ATM protocols – Broadband Protocols – Point to Point Protocols – Other
WAN Protocols- security issues.
MODULE IV
Local Area Network and LAN Protocols – ETHERNET Protocols – VLAN protocols –
Wireless LAN Protocols – Metropolitan Area Network Protocol – Storage Area Network and
SAN
MODULE V
Protocols -FDMA, WIFI and WIMAX Protocols- security issues. Mobile IP – Mobile
Support Protocol for IPv4 and IPv6 – Resource Reservation Protocol. Multicasting Protocol –
VGMP – IGMP – MSDP .Network Security and Technologies and Protocols – AAA
Protocols – Tunneling Protocols – Secured Routing Protocols – GRE- Generic Routing
Encapsulation – IPSEC – Security.
Examination Scheme:
Components CT1 A/C/Q ATTD. EE
Weightage (%) 15 10 5 70
Text Books:
1. Jawin: ―Networks Protocols Handbook‖, 3rd Edition, Jawin Technologies Inc., 2005.
2. Bruce Potter and Bob Fleck : ―802.11 Security‖, 1st Edition, O‟Reilly Publications, 2002.
References:
1. Ralph Oppliger :―SSL and TSL: Theory and Practice‖, 1st Edition, Arttech House, 2009.
2. Lawrence Harte: ―Introduction to CDMA- Network services Technologies and
Operations‖, 1st Edition, Althos Publishing, 2004.
3. Lawrence Harte: ―Introduction to WIMAX‖, 1st Edition, Althos Publishing, 2005.
PROBABILITY AND STATISTICAL STRUCTURE
Course Objective:
The aim of the course is to introduce the probability and statistical of theoretical computer
science and the theory of statistical analysis. Fundamental concepts in statistical analysis with
emphasis on their applications to computer science will be taught.
Course Contents:
Module -I:
Probability: Sample space and events – Probability – The axioms of probability - Some
elementary theorems - Conditional probability – Baye's theorem.
Module -II:
Random variables – Discrete and continuous – Distribution – Distribution
function.Distribution - Binomial, poisson and normal distribution – related properties.
Module -III:
Sampling distribution: Populations and samples - Sampling distributions of mean (known and
unknown) proportions, sums and differences.
Module-IV:
Test of Hypothesis – Means and proportions – Hypothesis concerning one and two means –
Type I and Type II errors. One tail, two-tail tests. Tests of significance – Student's t-test, F-
test, chi-square test, ANOVA test.
Curve fitting: The method of least squares – Inferences based on the least squares estimations
- Curvilinear regression – multiple regressions – correlation for univariate and bivariate
distributions.
Examination Scheme:
Components CT1 A/C/Q ATTD. EE
Weightage (%) 15 10 5 70
TEXT BOOKS:
1. Probability and statistics for engineers:Erwin Miller And John E.Freund. Prentice-Hall of
India / Pearson , Sixth edition.
2. Text book of Probability and Statistics by Dr.ShahnazBathul, V.G.S.Publishers 2003.
REFERENCE BOOKS:
1. Probability, Statistics and Random Processes Dr.K.Murugesan&P.Gurusamy by Anuradha
Agencies, Deepti Publications.
2. Advanced Engineering Mathematics (Eighth edition), Erwin Kreyszig, John Wiley and
Sons (ASIA) Pvt. Ltd., 2001.
3. Probability and Statistics for Engineers: G.S.S.BhishmaRao,sitech., Second edition 2005.
INTERNET OF THINGS LAB
Note: IA –Internal Assessment, EE- External Exam, PR- Performance, LR – Lab Record, V –
Viva.
SECURE PROTOCOL DESIGN LAB
Note: IA –Internal Assessment, EE- External Exam, PR- Performance, LR – Lab Record, V –
Viva.
PROBABILITY AND STATISTICAL STRUCTURE LAB
1. Frequenciesanalysis
2. Descriptiveanalysis
3. Crosstabsanalysis
4. One Sample t – Testanalysis
5. Independent Sample t – Test
6. Paired Sample t – Testanalysis
7. One-Way ANOVAanalysis
8. Chi – Square Testanalysis
9. correlation analysis
10. Multiple Regressionanalysis
Examination Scheme:
IA EE
A PR LR V PR V
5 10 10 5 35 35
Note: IA –Internal Assessment, EE- External Exam, PR- Performance, LR – Lab Record, V –
Viva.
REPORT ON WORKSHOP/ SOCIAL WORK
Objective: Conferences / Seminars / Workshop are good and efficient way to get to know
other researchers through their work and also personally. The educational aspect can expose
the students to new ways of conducting the business and help them to discover how to be
more productive. They provide a great opportunity to network. Collaboration is the way to
approach networking.
Rules and Regulations
2nd Year / 3rd Year Students for which the students and the faculty members can start
preparations well in advance prior to the scheduled conference / seminar / workshop.
The number of students going for any conference / seminar / workshop should be
manageable.
A proposal for the proposed conference / seminar / workshop should be drafted and
presented to the HoI reflecting the following key points:
o Entire activity plan
o Route Map
o What are the objectives for the students?
o What they need to learn, do, and prepare before the conference / seminar /
workshop?
o List of prospective students with Contact Details
o List of Faculty Coordinators with Contact Details
After getting approval from the HoI, a note sheet should be prepared and all necessary
permission and approval from the competent authorities should be obtained.
The attention and co-operation of all students and parents are requested to attend the
conference / seminar / workshop most effectively. Signing of the letter of Indemnity Bond
(Consent‐cum‐Undertaking) is mandatory for all the parents of students going for
conference / seminar / workshop in or outside Jaipur. Duly executed Indemnity Bond
should be submitted to HoI Office at least 2 days prior to the visit, without which the
accompanying Staff coordinator shall not permit the student to participate in the industrial
visit
The list of students participating in conference / seminar / workshop shall be handed over
to the concerned HODs, Staff coordinators.
Students should be present in formals.
Students should carry the College Identity Cards during their journey.
Discipline should be maintained during the conference / seminar / workshop. Any
violation will be viewed very seriously.
A report of the conference / seminar / workshop is to be submitted in 5 days time by
students / faculty coordinators once the students are back.
The report to be prepared should reflect the following:-
What happened at the conference / seminar / workshop the students attend and how
does it relate in the best way to the preparations and the learning objectives.
How do the students will use the outcome of conference / seminar / workshop after it is
over?
What will they gain from it and how can they set up activities that transfer the
experience into learning?
Evaluation parameters for the success of the experience of conference / seminar /
workshop.
The layout guidelines for the Report:
The student will be provided with the Student Assessment Record (SAR) to be placed in front
of the Report File. Each item in the SAR is ticked off when it is completed successfully. The
faculty will also assess each item as it is completed. The SAR will be signed by the student
and by the faculty to indicate that the File is the student‘s own work. It will also ensure
regularity and meeting the delaines.
Examination Scheme:
Components V S R FP
Weightage (%) 20 20 20 40
Course Objective:
The Course is designed to give an overview of the four broad categories of English
Communication thereby enhance the learners‘ communicative competence.
Course Contents:
Module V: Activities
News reading
Picture reading
Movie magic
Announcements
Examination Scheme:
Course Objective:
This course aims at imparting an understanding of:
Self and the process of self exploration
Learning strategies for development of a healthy self esteem
Importance of attitudes and their effect on work behaviour
Effective management of emotions and building interpersonal competence.
Course Contents:
Examination Scheme:
Components SAP A Mid Term VIVA Journal for
Test (CT) Success
(JOS)
Weightage (%) 20 05 20 30 25
Course Objective:
To familiarize the students with the French language
with the phonetic system
with the syntax
with the manners
with the cultural aspects
Course Contents:
Examination Scheme:
C – Project + Presentation
I – Interaction/Conversation Practice
Text & References:
Course Objective:
To enable the students to converse, read and write in the language with the help of the basic
rules of grammar, which will later help them to strengthen their language.
To give the students an insight into the culture, geography, political situation and economic
opportunities available in Germany
Course Contents:
Module I: Introduction
Self introduction: heissen, kommen, wohnwn, lernen, arbeiten, trinken, etc.
All personal pronouns in relation to the verbs taught so far.
Greetings: Guten Morgen!, Guten Tag!, Guten Abend!, Gute Nacht!, Danke sehr!, Danke!,
Vielen Dank!, (es tut mir Leid!),
Hallo, wie geht‘s?: Danke gut!, sehr gut!, prima!, ausgezeichnet!,
Es geht!, nicht so gut!, so la la!, miserabel!
Module V: Articles
The definite and indefinite articles in masculine, feminine and neuter gender. All Vegetables,
Fruits, Animals, Furniture, Eatables, modes of Transport
Examination Scheme:
C – Project + Presentation
I – Interaction/Conversation Practice
Course Objective:
To enable students acquire the relevance of the Spanish language in today‘s global context,
how to greet each other, how to present / introduce each other using basic verbs and
vocabulary
Course Contents:
Module I
A brief history of Spain, Latin America, the language, the culture…and the relevance of
Spanish language in today‘s global context.
Introduction to alphabets
Module II
Introduction to ‗Saludos‘ (How to greet each other. How to present / introduce each other).
Goodbyes (despedidas)
The verb llamarse and practice of it.
Module III
Concept of Gender and Number
Months of the years, days of the week, seasons. Introduction to numbers 1-100, Colors,
Revision of numbers and introduction to ordinal numbers.
Module IV
Introduction to SER and ESTAR (both of which mean To Be).Revision of ‗Saludos‘ and
‗Llamarse‘. Some adjectives, nationalities, professions, physical/geographical location, the
fact that spanish adjectives have to agree with gender and number of their nouns. Exercises
highlighting usage of Ser and Estar.
Module V
Time, demonstrative pronoun (Este/esta, Aquel/aquella etc)
Module VI
Introduction to some key AR /ER/IR ending regular verbs.
Examination Scheme:
C – Project + Presentation
I – Interaction/Conversation Practice
Course Objective:
There are many dialects spoken in China, but the language which will help you through
wherever you go is Mandarin, or Putonghua, as it is called in Chinese. The most widely
spoken forms of Chinese are Mandarin, Cantonese, Gan, Hakka, Min, Wu and Xiang. The
course aims at familiarizing the student with the basic aspects of speaking ability of
Mandarin, the language of Mainland China. The course aims at training students in practical
skills and nurturing them to interact with a Chinese person.
Course Contents:
Module I
Show pictures, dialogue and retell.
Getting to know each other.
Practicing chart with Initials and Finals. (CHART – The Chinese Phonetic Alphabet Called
―Hanyu Pinyin‖ in Mandarin Chinese.)
Practicing of Tones as it is a tonal language.
Changes in 3rd tone and Neutral Tone.
Module II
Greetings
Let me Introduce
The modal particle ―ne‖.
Use of Please ‗qing‖ – sit, have tea ………….. etc.
A brief self introduction – Ni hao ma? Zaijian!
Use of ―bu‖ negative.
Module III
Attributives showing possession
How is your Health? Thank you
Where are you from?
A few Professions like – Engineer, Businessman, Doctor, Teacher, Worker.
Are you busy with your work?
May I know your name?
Module IV
Use of ―How many‖ – People in your family?
Use of ―zhe‖ and ―na‖.
Use of interrogative particle ―shenme‖, ―shui‖, ―ma‖ and ―nar‖.
How to make interrogative sentences ending with ―ma‖.
Structural particle ―de‖.
Use of ―Nin‖ when and where to use and with whom. Use of guixing.
Use of verb ―zuo‖ and how to make sentences with it.
Module V
Family structure and Relations.
Use of ―you‖ – ―mei you‖.
Measure words
Days and Weekdays.
Numbers.
Maps, different languages and Countries.
Examination Scheme:
Course Contents:
Module I: Computer Forensics Fundamentals
Introduction to Computer Forensics, Use of Computer Forensics in Law Enforcement, Stages
of forensic investigation: Types of Computer Forensic Technology, Military, Law
Enforcement, Business, Specialized Forensic Techniques; Types of Computer Forensics
Systems: Internet Security, Intrusion Detection, Firewall Security , Public Key Infrastructure,
Net Privacy, Identity Theft, Biometric Security Systems; .Data Recovery :Data Backup,-
Recovery and Solution, Hiding and Recovering Hidden Data, Evidence Collection and Data
Seizure, Types of Evidence: General Procedure, Collection and Archiving,
Module II: Mobile Forensics
Crime and mobile phones, evidences, forensic procedures, files present in SIM card, device
data, external memory dump and evidences in memory card, operators systems Android
forensics: Procedures for handling an android device, imaging android USB mass storage
devices, logical and physical techniques.
Examination Scheme:
Components CT1 CT2 A/C/Q Attd EE
Weightage (%) 10 10 05 5 70
Cyber Security Principles, Data Security Consideration, Firewalls, Types of Firewalls, Basics
of Virtual Private Network, Basics of Intrusion Detection, Access Control, Digital Signature
and Types of Digital Signature.
Introduction to Security Policies, Need for Security Policy, Stakeholders of Policy Makers,
Security Policy Audit, Security Policy Enforcement, Security Policy Awareness, Importance
of Security Standards, ISO/IEC 27001 and 27002, NIST Cyber Security Framework,
Common Criteria.
Examination Scheme:
Text Books:
Charles J. Brooks, Christopher Grow, Philip Craig, "Cybersecurity Essentials", John Wiley
and Sons, 2018.
Paul A. Watters, Cyber Security: Concepts and Cases, CreateSpace Independent Publishing
Platform, 2012.
Peter W. Singer, Allan Friedman, Cybersecurity: What Everyone Needs to Know, Oxford
University Press.
David Sutton, Cyber Security: A Practitioner's Guide, BCS Learning & Development
Limited, 2017.
INTRUSION DETECTION SYSTEMS
MODULE-I
History of Intrusion detection, Audit, Concept and definition , Internaland external threats to
data, attacks, Need and types of IDS, Informationsources Host based information sources,
Network based informationsources.
MODULE-II
Intrusion Prevention Systems, Network IDs protocol based IDs ,HybridIDs, Analysis
schemes,
thinking about intrusion. A model for intrusion analysis , techniquesResponses requirement
of responses, types of responses mappingresponses to policy Vulnerability analysis,
credential analysis noncredential analysis
MODULE-III
Introduction to Snort, Snort Installation Scenarios, Installing Snort,Running Snort on
MultipleNetwork Interfaces, Snort Command Line Options. Step-By-StepProcedure to
Compile andInstall Snort Location of Snort Files, Snort Modes Snort Alert Modes
MODULE-IV
Working with Snort Rules, Rule Headers, Rule Options, The SnortConfiguration File etc.
Plugins, Preprocessors and Output Modules,Using Snort with MySQL
MODULE-V
Using ACID and Snort Snarf with Snort, Agent development forintrusion detection,
Architecture models of IDs and IPs.
Examination Scheme:
Components CT1 CT2 A/C/Q Attd EE
Weightage (%) 10 10 05 5 70
TEXT BOOKS:
1. RafeeqRehman : ― Intrusion Detection with SNORT, Apache,MySQL, PHP and ACID,‖
1st Edition, Prentice Hall , 2003.
REFERENCES:
1. Christopher Kruegel,FredrikValeur, Giovanni Vigna: ―IntrusionDetection and Correlation
Challenges and Solutions‖, 1st Edition,Springer, 2005.
2. Carl Endorf, Eugene Schultz and Jim Mellander ― IntrusionDetection & Prevention‖, 1st
Edition, Tata McGraw-Hill, 2004.
3. Stephen Northcutt, Judy Novak : ―Network Intrusion Detection‖, 3rdEdition, New Riders
Publishing, 2002.
4. T. Fahringer, R. Prodan, ―A Text book on Grid ApplicationDevelopment and Computing
Environment‖. 6th Edition,KhannaPublihsers, 2012.
CYBER SECURITY- II LAB
Experiments
4. Implementation of Intrusion Detection and Presentation System using any tool in Windows
/ Linux Operating System
8. Evaluate Risk using Qualitative Risk Analysis tool through Kali Linux
Examination Scheme:
IA EE
A PR LR V PR V
5 10 10 5 35 35
Note: IA –Internal Assessment, EE- External Exam, PR- Performance, LR – Lab Record, V –
Viva.
INTRUSION DETECTION SYSTEMS LAB
1. Working with Trojans, Backdoors and sniffer for monitoring network communication
2. Denial of Service and Session Hijacking using Tear Drop, DDOS attack.
Examination Scheme:
IA EE
A PR LR V PR V
5 10 10 5 35 35
Note: IA –Internal Assessment, EE- External Exam, PR- Performance, LR – Lab Record, V –
Viva.
MINOR PROJECT
Report Layout
The report should contain the following components
Table of Contents
Titles and subtitles are to correspond exactly with those in the text.
Acknowledgement
Acknowledgment to any advisory or financial assistance received in the course of work may
be given.
Student Certificate
Given by the Institute.
Introduction
Here a brief introduction to the problem that is central to the project and an outline of the
structure of the rest of the report should be provided. The introduction should aim to catch the
imagination of the reader, so excessive details should be avoided.
Chapters
All chapters and sections must be appropriately numbered, titled and should neither be too
long nor too short in length.
The first chapter should be introductory in nature and should outline the background of the
project, the problem being solved, the importance, other related works and literature survey.
The other chapters would form the body of the report. The last chapter should be concluding
in nature and should also discuss the future prospect of the project.
Appendices
The Appendix contains material which is of interest to the reader but not an integral part of
the thesis and any problem that have arisen that may be useful to document for future
reference.
References / Bibliography
This should include papers and books referred to in the body of the report. These should be
ordered alphabetically on the author's surname. The titles of journals preferably should not
be abbreviated; if they are, abbreviations must comply with an internationally recognised
system.
5. Bibliography
This refer to the books, Journals and other documents consulting while
working on the project
Examination Scheme:
Components MRP V S FP R
Weightage (%) 20 20 20 20 20
Module I
Introduction to Online Social Networks, data collection from social networks, challenges,
opportunities, and pitfalls in online social networks, APIs.
Module II
Collecting data from Online Social Media, Trust, and credibility.
Module III
Reputations in social systems, Online social Media and Policing.
Module IV
Information privacy disclosure, revelation and its effects in OSM and online social networks.
Module V
Phishing in OSM & Identifying fraudulent entities in online social networks.
Examination Scheme:
MODULE-I
Biometrics- Introduction- benefits of biometrics over traditionalauthentication systems –
benefitsof biometrics in identification systems-selecting a biometric for a system–
Applications – Keybiometric terms and processes - biometric matching methods –Accuracyin
biometric systems.
MODULE-II
Physiological Biometric Technologies: Fingerprints – Technicaldescription –characteristics -
Competing technologies - strengths –weaknesses – deployment - Facial scan - Technical
description -characteristics - weaknesses-deployment - Iris scan – Technicaldescription –
characteristics - strengths – weaknesses – deployment- Retina vascular pattern
MODULE-III
Technical description – characteristics - strengths – weaknesses –deployment - Hand scan -
Technical description-characteristics -strengths – weaknesses deployment – DNA
biometrics.Behavioral Biometric Technologies: Handprint Biometrics – DNABiometrics.
MODULE-IV
signature and handwriting technology - Technical description –classification – keyboard /
keystroke dynamics- Voice – dataacquisition - feature extraction - characteristics - strengths –
weaknesses-deployment.
MODULE-V
Multi biometrics and multi factor biometrics - two-factor authenticationwith passwords -
tickets and tokens – executive decision -implementation plan.
Examination Scheme:
Components CT1 A/C/Q ATTD. EE
Weightage (%) 15 10 5 70
TEXT BOOKS:
1. Samir Nanavathi, Michel Thieme, and Raj Nanavathi : ―Biometrics-Identity verification
in a network‖, 1st Edition, Wiley Eastern, 2002.
2. John Chirillo and Scott Blaul : ―Implementing BiometricSecurity‖, 1st Edition, Wiley
Eastern Publication, 2005.
REFERENCES:
1. John Berger: ―Biometrics for Network Security‖, 1st Edition,Prentice Hall, 2004.
MATLAB
Course Objective:
The availability of technical computing environment such as MATLAB is now reshaping the
role and applications of computer laboratory projects to involve students in more intense
problem-solving experience. This availability also provides an opportunity to easily conduct
numerical experiments and to tackle realistic and more complicated problems.
Course Contents:
Module I: Introduction
Basic Features, Starting MAT Lab, Using MAT Lab, Quitting Mat lab, Creating MATLAB
variables, Overwriting variable, Error messages, Making corrections, Managing the
workspace, Keeping track of your work session, Entering multiple statements per line.
Examination Scheme:
Components CT1 A/C/Q ATTD. EE
Weightage (%) 15 10 5 70
WIRELESS NETWORKS
Module I:
Module II:
Wireless LAN: Infrared Vs radio transmission, Infrastructure and Ad-hoc Network, IEEE
802.11:System Architecture, Protocol Architecture, 802.11b, 802.11a, Bluetooth: User
Scenarios, Architecture.
Module III:
Global System for Mobile Communications (GSM): Mobile Services, System Architecture,
Protocols, Localization & Calling, Handover, Security. GPRS: GPRS System, Architecture,
UMTS: UMTS System Architecture. LTE: Long Term Evolution.
Module IV
Module V
Implementation of wireless network through cisco packet tracer, create network topologies
,IP addressing type and subnet mask, address management , routing and switching
configuration, wired and wireless network configuration, VLAN configuration, wireless
router and AP configuration, Security implementation.
Examination Scheme:
Components CT1 A/C/Q ATTD. EE
Weightage (%) 15 10 5 70
TEXT BOOKS:
1. Schiller, J. 2008. Mobile Communications. 2nd ed. India: Pearson Education.
2. Kumar,S. and Kakkasageri, M. S. ―Wireless and Mobile Networks: Concepts and
Protocols‖, Wiley India.
3. Kamal R. 2011. ―Mobile Computing‖, 2nd Ed.Oxford University Press.
REFERENCES:
1. Talukder, A. K., Ahmed, H. andYavagal,R. R. 2010.Mobile Computing: Technology,
Applications and Service Creation, 2 nd Ed. Tata McGraw Hill.
2. Gast, M. S. ―802.11 Wireless Networks: The Definitive Guide‖, O'Reilly Media.
MATLAB LAB
Learning outcomes :
After completion of the course the student will be able to :
Course Contents:
1. Characteristics of MATLAB
2. Introduction to MATLAB
3. Understand the graphical interface to the MATLAB workspace.
4. Gettingstartedwith MATLAB by creating variables, Arithmeticoperations etc.,
5. Executing the Mathematical expressions.
6. Creating simple plots.
7. Matrix Generation.
8. Array Operations and linearequationwith MATLAB
9. Basic Programmingwith MATLAB
10. Debugging M- Files
Examination Scheme:
IA EE
A PR LR V PR V
5 10 10 5 35 35
Note: IA –Internal Assessment, EE- External Exam, PR- Performance, LR – Lab Record, V –
Viva.
WIRELESS NETWORKS LAB
List of Experiments
Examine each of the values in the tables above and verify that this topology meets all
requirements and specifications. Are any of the given values incorrect? ___________
If yes, correct the values in the table above and write the corrected values below:
__________________________________________________________________________
___________________________________________________________________________
Create a configuration table similar to the one below using your corrected values:
Addressing Table
Addressing Table
Default
Device Hostname Interface IP Address Subnet Mask Gateway
PC1 Host-A NIC 172.17.99.21 255.255.255.0 172.17.99.1
S1 ALSwitch VLAN99 172.17.99.11 255.255.255.0 172.17.99.1
Learning Objectives
Create and save a basic switch configuration
Set up a TFTP server on the network
Back up the switch Cisco IOS software to a TFTP server and then restore it
Back up the switch configuration to a TFTP server
Configure a switch to load a configuration from a TFTP server
Upgrade the Cisco IOS software from a TFTP server
Topology Diagram
Addressing Table
Device
Interface IP Address Subnet Mask Default Gateway
(Hostname)
S1 VLAN 99 172.17.99.11 255.255.255.0 N/A
S2 VLAN 99 172.17.99.12 255.255.255.0 N/A
S3 VLAN 99 172.17.99.13 255.255.255.0 N/A
PC1 NIC 172.17.10.21 255.255.255.0 172.17.10.1
PC2 NIC 172.17.20.22 255.255.255.0 172.17.20.1
PC3 NIC 172.17.30.23 255.255.255.0 172.17.30.1
PC4 NIC 172.17.10.24 255.255.255.0 172.17.10.1
PC5 NIC 172.17.20.25 255.255.255.0 172.17.20.1
PC6 NIC 172.17.30.26 255.255.255.0 172.17.30.1
Learning Objectives
Cable a network according to the topology diagram
Erase the startup configuration and reload a switch to the default state
Perform basic configuration tasks on a switch
Create VLANs
Assign switch ports to a VLAN
Add, move, and change ports
Verify VLAN configuration
Enable trunking on inter-switch connections
Verify trunk configuration
Save the VLAN configuration
Addressing Table
Device Interface IP Address Default Gateway
(Hostname) Subnet Mask
S1 VLAN 56 192.168.56.11 255.255.255.0 N/A
S2 VLAN 56 192.168.56.12 255.255.255.0 N/A
S3 VLAN 56 192.168.56.13 255.255.255.0 N/A
PC1 NIC 192.168.10.21 255.255.255.0 192.168.10.1
PC2 NIC 192.168.20.22 255.255.255.0 192.168.20.1
PC3 NIC 192.168.30.23 255.255.255.0 192.168.30.1
PC4 NIC 192.168.10.24 255.255.255.0 192.168.10.1
PC5 NIC 192.168.20.25 255.255.255.0 192.168.20.1
PC6 NIC 192.168.30.26 255.255.255.0 192.168.30.1
In this lab, you will practice troubleshooting a misconfigured VLAN environment. Load or
have your instructor load the configurations below into your lab gear. Your objective is to
locate and correct any and all errors in the configurations and establish end-to-end
connectivity. Your final configuration should match the topology diagram and addressing
table. All passwords are set to cisco, except the enable secret password, which is set to class.
Task 1: Prepare the Network
Step 1: Cable a network that is similar to the one in the topology diagram.
Step 2: Clear any existing configurations on the switches, and initialize all ports in the
shutdown state.
Step 3: Import the configurations below.
Switch 1
hostname S1
no ip domain-lookup
enable secret class
!
!
interface range FastEthernet0/1-5
switchport mode trunk
!
interface range FastEthernet0/6-24
shutdown
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan56
ip address 192.168.56.11 255.255.255.0
no ip route-cache
!
line con 0
logging synchronous
line vty 0 4
no login
line vty 5 15
password cisco
login
!
end
Switch 2
hostname S2
no ip domain-lookup
enable secret class
!
vlan 10,20,30,56
!
interface range FastEthernet0/1-5
switchport trunk native vlan 56
switchport mode access
!
interface range FastEthernet0/6-10
switchport access vlan 30
switchport mode access
!
interface range FastEthernet0/11-17
switchport access vlan 10
switchport mode access
!
interface range FastEthernet0/18-24
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.56.12 255.255.255.0
no ip route-cache
shutdown
!
line con 0
password cisco
login
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
end
Switch 3
hostname S3
no ip domain-lookup
enable secret class
!
vlan 10,20,30
!
interface range FastEthernet0/1-5
switchport trunk native vlan 56
switchport mode trunk
!
interface range FastEthernet0/6-10
switchport mode access
!
interface range FastEthernet0/11-17
switchport mode access
!
interface range FastEthernet0/18-24
switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan56
no ip route-cache
!
line con 0
password cisco
login
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
End
Task 2: Troubleshoot and Repair the VLAN Configuration
Task 4: Clean Up
Erase the configurations and reload the switches. Disconnect and store the cabling. For PC
hosts that are normally connected to other networks (such as the school LAN or to the
Internet), reconnect the appropriate cabling and restore the TCP/IP settings.
Addressing Table
Learning Objectives
Cable a network according to the topology diagram
Erase the startup configuration and reload a switch to the default state
Perform basic configuration tasks on a switch
Configure VLAN Trunking Protocol (VTP) on all switches
Enable trunking on inter-switch connections
Verify trunk configuration
Modify VTP modes and observe the impact
Create VLANs on the VTP server, and distribute this VLAN information to switches in
the network
Explain the differences in operation between VTP transparent mode, server mode, and
client mode
Assign switch ports to the VLANs
Save the VLAN configuration
Enable VTP pruning on the network
Explain how pruning reduces unnecessary broadcast traffic on the LAN
Addressing Table
Device Interface IP Address Subnet Mask
(Hostname)
S1 VLAN 99 172.17.99.11 255.255.255.0
S2 VLAN 99 172.17.99.12 255.255.255.0
S3 VLAN 99 172.17.99.13 255.255.255.0
PC1 NIC 172.17.10.21 255.255.255.0
PC2 NIC 172.17.20.22 255.255.255.0
PC3 NIC 172.17.30.23 255.255.255.0
PC4 NIC 172.17.10.24 255.255.255.0
PC5 NIC 172.17.20.25 255.255.255.0
PC6 NIC 172.17.30.26 255.255.255.0
Objectives
Upon completion of this lab, you will be able to:
Cable a network according to the topology diagram
Erase the startup configuration and vlan.dat files and reload switches to the default state
Load the switches with supplied scripts
Find and correct all configuration errors
Document the corrected network
Addressing Table
Device Interface IP Address Subnet Mask Default Gateway
(Hostname)
S1 VLAN 1 172.17.10.1 255.255.255.0 N/A
S2 VLAN 1 172.17.10.2 255.255.255.0 N/A
S3 VLAN 1 172.17.10.3 255.255.255.0 N/A
PC1 NIC 172.17.10.21 255.255.255.0 172.17.10.254
PC2 NIC 172.17.10.22 255.255.255.0 172.17.10.254
PC3 NIC 172.17.10.23 255.255.255.0 172.17.10.254
PC4 NIC 172.17.10.27 255.255.255.0 172.17.10.254
Learning Objectives
Cable a network according to the topology diagram
Erase the startup configuration and reload the default configuration, setting a switch to the
default state
Perform basic configuration tasks on a switch
Observe and explain the default behavior of Spanning Tree Protocol (STP, 802.1D)
Observe the response to a change in the spanning tree topology
Addressing Table
Device Interface IP Address Subnet Mask Default Gateway
(Hostname)
S1 VLAN 99 172.17.99.11 255.255.255.0 N/A
S2 VLAN 99 172.17.99.12 255.255.255.0 N/A
S3 VLAN 99 172.17.99.13 255.255.255.0 N/A
PC1 NIC 172.17.10.21 255.255.255.0 172.17.10.1
PC2 NIC 172.17.20.22 255.255.255.0 172.17.20.1
PC3 NIC 172.17.30.23 255.255.255.0 172.17.30.1
Learning Objectives
Analyze a congestion problem in a redundant, switched LAN network.
Recognize the capabilities for per-VLAN load balancing with PVST.
Modify the default STP configuration to optimize available bandwidth.
Verify that modifications have had the intended effect.
You are responsible for the operation of the redundant switched LAN shown in the topology
diagram. You and your users have been observing increased latency during peak usage times,
and your analysis points to congested trunks. You recognize that of the six trunks configured,
only two are forwarding packets in the default STP configuration currently running. The
solution to this problem requires more effective use of the available trunks. The PVST+
feature of Cisco switches provides the required flexibility to distribute the inter-switch traffic
using all six trunks.
This lab is complete when all wired trunks are carrying traffic, and all three switches are
participating in per-VLAN load balancing for the three user VLANs.
Learning Objectives
Upon completion of this lab, you will be able to to:
Cable a network according to the topology diagram
Clear configurations and reload a switch and a router to the default state
Perform basic configuration tasks on a switched LAN and a router
Configure VLANs and VLAN Trunking Protocol (VTP) on all switches
Configure a router to support 802.1q trunking on a Fast Ethernet interface
Configure a router with subinterfaces corresponding to the configured VLANs
Demonstrate inter-VLAN routing
Lab XII: Troubleshooting Inter-VLAN Routing
Topology Diagram
Addressing Table
Device
Interface IP Address Subnet Mask Default Gateway
(Hostname)
S1 VLAN 99 192.168.99.11 255.255.255.0 192.168.99.1
S2 VLAN 99 192.168.99.12 255.255.255.0 192.168.99.1
S3 VLAN 99 192.168.99.13 255.255.255.0 192.168.99.1
R1 Fa 0/0 192.168.50.1 255.255.255.0 N/A
R1 Fa 0/1 See Subinterface Configuration Table N/A
PC1 NIC 192.168.10.21 255.255.255.0 192.168.10.1
PC2 NIC 192.168.20.22 255.255.255.0 192.168.20.1
PC3 NIC 192.168.30.23 255.255.255.0 192.168.30.1
Server NIC 192.168.50.254 255.255.255.0 192.168.50.1
Learning Objectives
Configure options in the Linksys Setup tab.
Configure options in the Linksys Wireless tab.
Configure options in the Linksys Administration tab.
Configure options in the Linksys Security tab.
Add wireless connectivity to a PC.
Test connectivity.
Course Objective:
To enrich the understanding of English language and communication, structure, style, usage,
and vocabulary for global business purposes.
Course Contents:
Examination Scheme:
Course Objective:
To enable the students to overcome the fear of speaking a foreign language and take
position as a foreigner speaking French.
To make them learn the basic rules of French Grammar.
Course Contents:
Module A: pp.38 – 47: Unité 3: Objectif 3, 4, 5. 6
Course Objective:
To enable the students to converse, read and write in the language with the help of the basic
rules of grammar, which will later help them to strengthen their language.
To give the students an insight into the culture, geography, political situation and economic
opportunities available in Germany
Introduction to Grammar to consolidate the language base learnt in Semester I
Course Contents:
Module I: Everything about Time and Time periods
Time and times of the day.
Weekdays, months, seasons.
Adverbs of time and time related prepositions
Course Objective:
To enable students acquire more vocabulary, grammar, verbal phrases to understand simple
texts and start describing any person or object in Simple Present Tense.
Course Contents:
Module I
Revision of earlier modules.
Module II
Some more AR/ER/IR verbs. Introduction to root changing and irregular AR/ER/IR ending
verbs
Module III
More verbal phrases (eg, Dios Mio, Que lastima etc), adverbs (bueno/malo, muy, mucho,
bastante, poco).
Simple texts based on grammar and vocabulary done in earlier modules.
Module IV
Possessive pronouns
Module V
Writing/speaking essays like my friend, my house, my school/institution,
myself….descriptions of people, objects etc, computer/internet related vocabulary
Examination Scheme:
C – Project + Presentation
I – Interaction/Conversation Practice
Español, En Directo I A
Español Sin Fronteras
CHINESE
Course Objective:
Chinese is a tonal language where each syllable in isolation has its definite tone (flat, falling,
rising and rising/falling), and same syllables with different tones mean different things. When
you say, ―ma‖ with a third tone, it mean horse and ―ma‖ with the first tone is Mother. The
course aims at familiarizing the student with the basic aspects of speaking ability of
Mandarin, the language of Mainland China. The course aims at training students in practical
skills and nurturing them to interact with a Chinese person.
Course Contents:
Module I
Drills
Practice reading aloud
Observe Picture and answer the question.
Tone practice.
Practice using the language both by speaking and by taking notes.
Introduction of basic sentence patterns.
Measure words.
Glad to meet you.
Module II
Where do you live?
Learning different colors.
Tones of ―bu‖
Buying things and how muchit costs?
Dialogue on change of Money.
More sentence patterns on Days and Weekdays.
How to tell time. Saying the units of time in Chinese. Learning to say useful phrases like –
8:00, 11:25, 10:30 P.M. everyday, afternoon, evening, night, morning 3:58, one hour, to
begin, to end ….. etc.
Morning, Afternoon, Evening, Night.
Module III
Use of words of location like-li, wais hang, xia
Furniture – table, chair, bed, bookshelf,.. etc.
Description of room, house or hostel room.. eg what is placed where and how many things
are there in it?
Review Lessons – Preview Lessons.
Expression ‗yao‖, ―xiang‖ and ―yaoshi‖ (if).
Days of week, months in a year etc.
I am learning Chinese. Is Chinese difficult?
Module IV
Counting from 1-1000
Use of ―chang-chang‖.
Making an Inquiry – What time is it now? Where is the Post Office?
Days of the week. Months in a year.
Use of Preposition – ―zai‖, ―gen‖.
Use of interrogative pronoun – ―duoshao‖ and ―ji‖.
―Whose‖??? Sweater etc is it?
Different Games and going out for exercise in the morning.
Module V
The verb ―qu‖
Going to the library issuing a book from the library
Going to the cinema hall, buying tickets
Going to the post office, buying stamps
Going to the market to buy things.. etc
Going to the buy clothes …. Etc.
Hobby. I also like swimming.
Comprehension and answer questions based on it.
Examination Scheme:
C – Project + Presentation
I – Interaction/Conversation Practice
Module- I:
Database security – Introduction includes threats, vulnerabilities and breaches,Basics of
database design,DB security – concepts, approaches and challenges, types of access controls,
Oracle VPD,Discretionary and Mandatory access control – Principles, applications and
polyinstantiation
Module- II:
Database inference problem, types of inference attacks, distributed database, security levels,
SQL-injection: types and advanced concepts.Security in relational data model, concurrency
controls and locking,SQL extensions to security (oracle as an example), System R concepts,
Context and control based access control, Hippocraticdatabases, Databasewatermarking,
Databaseintrusion, Secure data outsourcing
Module- III:
Web application security,Basic principles and concepts,Authentication,Authorization,
Browser security principles; XSS and CSRF, same origin policies,File security
principles,Secure development and deployment methodologies,Web DB principles, OWASP
– Top 10 - Detailed treatment,IoT security – OWASP Top 10 – Detailed treatment,Mobile
device security – Introduction, attack vector and models, hardware centric security aspects,
SMS / MMS vulnerabilities, software centric security aspects
Module- IV:
Mobile web browser security,Application security – Concepts, CIA Triad, Hexad, types of
cyber attacks,Introduction to software development vulnerabilities, code analyzers – Static
and dynamic analyzers,Security testing / Penetration testing – Principles and concepts, PT
work flows and examples, blind tests, ethical hacking techniques, synthetic transactions,
interface testing and fuzzing,SDLC phases and security mandates
Examination Scheme:
Components CT1 A/C/Q Attd EE
Weightage (%) 15 10 5 70
TEXTBOOKS/ REFERENCES:
1.Michael Gertz and SushilJajodia, ―Handbook of Database Security— Applications and
Trends‖, Springer, 2008.
2. Bryan and Vincent, ―Web Application Security, A Beginners Guide ‖,McGraw-Hill, 2011
3. BhavaniThuraisingham, ―Database and Applications Security‖, Integrating Information
Security and Data Management, Auerbach Publications, 2005.
4. Alfred Basta, Melissa Zgola, ―Database Security‖, Course Technology, 2012
Course Objective:
Evaluate secure software engineering problems, including the specification,design,
implementation, and testing of software systems. Elicit, analyze and specify security
requirements through SRS. Design and Plan software solutions to security problems using
variousparadigms.Model the secure software systems using Unified Modeling
LanguageSec(UMLSec). Develop and apply testing strategies for Secure software
applications
Course Contents:
Examination Scheme:
Components CT HA/V/Q ATTD. EE
Weightage (%) 15 10 5 70
References:
Howard, M. and LeBlanc, D., Writing Secure Code, 2nd Edition, Microsoft Press, 2003
ETHICAL HACKING AND DIGITAL FORENSIC TOOLS
COURSE CODE L T P/FW CREDIT UNITS
MCS303 2 1 0 3
Module- I:
Hacking windows – Network hacking – Web hacking – Password hacking. A study on
various attacks – Input validation attacks – SQL injection attacks – Buffer overflow attacks -
Privacy attacks.
Module- II:
TCP / IP – Checksums – IP Spoofing port scanning, DNS Spoofing. Dos attacks – SYN
attacks, Smurf attacks, UDP flooding, DDOS – Models. Firewalls – Packet filter firewalls,
Packet Inspection firewalls – Application Proxy Firewalls. Batch File Programming.
Module- III:
Fundamentals of Computer Fraud – Threat concepts – Framework for predicting inside
attacks – Managing the threat – Strategic Planning Process. Architecture strategies for
computer fraud prevention – Protection of Web sites – Intrusion detection system – NIDS,
HIDS – Penetrating testing process – Web Services – Reducing transaction risks.
Module- IV:
Key Fraud Indicator selection process customized taxonomies – Key fraud signature selection
process –Accounting Forensics – Computer Forensics – Journaling and it requirements –
Standardized logging criteria – Journal risk and control matrix – Neural networks – Misuse
detection and Novelty detection.
Examination Scheme:
References:
1. Kenneth C.Brancik ―Insider Computer Fraud‖ Auerbach Publications Taylor & Francis
Group, 2008. 2. 2. AnkitFadia― Ethical Hacking‖ 2nd Edition Macmillan India Ltd, 2006
ETHICAL HACKING AND DIGITAL FORENSIC TOOLS LAB
List of Experiments
3. Privacy attacks.
Examination Scheme:
IA EE
A PR LR V PR V
5 10 10 5 35 35
MINOR PROJECT
Report Layout
The report should contain the following components
Table of Contents
Titles and subtitles are to correspond exactly with those in the text.
Acknowledgement
Acknowledgment to any advisory or financial assistance received in the course of work may
be given.
Student Certificate
Given by the Institute.
Introduction
Here a brief introduction to the problem that is central to the project and an outline of the
structure of the rest of the report should be provided. The introduction should aim to catch the
imagination of the reader, so excessive details should be avoided.
Chapters
All chapters and sections must be appropriately numbered, titled and should neither be too
long nor too short in length.
The first chapter should be introductory in nature and should outline the background of the
project, the problem being solved, the importance, other related works and literature survey.
The other chapters would form the body of the report. The last chapter should be concluding
in nature and should also discuss the future prospect of the project.
Appendices
The Appendix contains material which is of interest to the reader but not an integral part of
the thesis and any problem that have arisen that may be useful to document for future
reference.
References / Bibliography
This should include papers and books referred to in the body of the report. These should be
ordered alphabetically on the author's surname. The titles of journals preferably should not
be abbreviated; if they are, abbreviations must comply with an internationally recognised
system.
5. Bibliography
This refer to the books, Journals and other documents consulting while
working on the project
Examination Scheme:
Components MRP V S FP R
Weightage (%) 20 20 20 20 20
GUIDELINES:
There are certain phases of every Intern‘s professional development that cannot be effectively
taught in the academic environment. These facets can only be learned through direct, on-the-
job experience working with successful professionals and experts in the field. The internship
program can best be described as an attempt to institutionalize efforts to bridge the gap
between the professional world and the academic institutions. Entire effort in internship is in
terms of extending the program of education and evaluation beyond the classroom of a
university or institution. The educational process in the internship course seeks out and
focuses attention on many latent attributes, which do not surface in the normal classroom
situations. These attributes are intellectual ability, professional judgment and decision-
making ability, inter-disciplinary approach, skills for data handling, ability in written and oral
presentation, sense of responsibility etc.
In order to achieve these objectives, each student will maintain a file (Internship File). The
Internship File aims to encourage students to keep a personal record of their learning and
achievement throughout the Programme. It can be used as the basis for lifelong learning and
for job applications. Items can be drawn from activities completed in the course modules and
from the workplace to demonstrate learning and personal development.
The File will assess the student‘s analytical skills and ability to present supportive evidence,
whilst demonstrating understanding of their organization, its needs and their own personal
contribution to the organization.
1. The Title Page--Title - An Internship Experience Report For (Your Name), name of
internship organization, name of the Supervisor/Guide and his/her designation, date
started and completed, and number of credits for which the report is submitted.
2. Table of Content--an outline of the contents by topics and subtopics with the page number
and location of each section.
3. Introduction--short, but should include how and why you obtained the internship
experience position and the relationship it has to your professional and career goals.
4. Main Body--should include but not be limited to daily tasks performed. Major projects
contributed to, dates, hours on task, observations and feelings, meetings attended and
their purposes, listing of tools and materials and their suppliers, and photographs if
possible of projects, buildings and co-workers.
5. References / Bibliography --This should include papers and books referred to in the body
of the report. These should be ordered alphabetically on the author's surname. The titles
of journals preferably should not be abbreviated; if they are, abbreviations must comply
with an internationally recognised system
The student will be provided with the Student Assessment Record (SAR) to be placed in front
of the Internship File. Each item in the SAR is ticked off when it is completed successfully.
The faculty will also assess each item as it is completed. The SAR will be signed by the
student and by the faculty to indicate that the File is the student‘s own work. It will also
ensure regularity and meeting the delaines.
2. Execution of Research
3. Data Analysis
Analyse Quantitative/ Qualitative information
Control Quality
4. Draw Conclusions
Examination Scheme:
Components V S R FP
Weightage (%) 20 20 20 40
Course Objective:
The primary objective of this course is to provide an introduction to the basic principles,
techniques, and applications of Artificial Intelligence. The emphasis of the course is on
teaching the fundamentals and not on providing a mastery of specific commercially available
software tools or programming environments. Upon successful completion of the course, you
will have an understanding of the basic areas of artificial intelligence search, knowledge
representation, learning and their applications in design and implementation of intelligent
agents for a variety of tasks in analysis, design, and problem-solving. You will also be able to
design and implement key components of intelligent agents of moderate complexity in Java
and/or Lisp or Prolog and evaluate their performance. Graduate students are expected to
develop some familiarity with current research problems and research methods in AI by
working on a research or design project.
Course Contents:
Module I: Introduction
AI and its importance, AI Problem, Application area.
Module II: Problem Representations
State space representation, problem-reduction representation, production system, production
system characteristics, and types of production system.
Module III: Heuristic Search Techniques
AI and search process, brute force search, depth-first search, breadth-first search, time and
space complexities, heuristics search, hill climbing, best first search, A*, AO* algorithm,
constraint satisfaction, and beam search.
Module IV: Knowledge Representation issues using predicate logic
Representation and mapping, knowledge representation mechanism, inheritable knowledge,
Prepositional logic: syntax and semantics, First Order Predicate Logic (FOPL).
Module V: Expert System
Basic understanding of Fuzzy Logic, Artificial Neural Network, Perceptron, Natural
Language Processing, Pattern Recognition, Robotics, LISP and Prolog.The role of Artificial
intelligence in Biotechnology.Introduction to Bio-inspired computing.
Examination Scheme:
References:
Foundations of Artificial Intelligence and Expert Systems, V S Janakiraman, K Sarukesi,
P Gopalakrishan, Macmillan India Ltd.
Introduction to AI and Expert System, Dan W. Patterson, PHI.
HUMAN COMPUTER INTERACTION
COURSE CODE L T P/FW CREDIT UNITS
MCS332 2 1 - 3
Course Objective:
Human-computer interaction is the study of how people interact with computers and to what
extent computers are or are not developed for successful interaction with human beings. The
goals of HCI are to produce usable and safe systems, as well as functional systems. This
course provides the concepts of HCI and user interfaces, focusing on user interface design,
evaluation, and technologies.
Course Contents:
Module: I: Introduction
Importance of user Interface-definition, importance of 8good design. Benefits of good design.
A brief history of Screen design.The graphical user interface-popularity of graphics, the
concept of direct manipulation, graphical system, Characteristics, Web user-Interface
popularity, characteristics-Principles of user interface
ModuleIV:Windows
New and Navigation schemes selection of window, 8 selection of devices based and screen
based controls. Components-text and messages, Icons and increases-Multimedia, colors, uses
problems, choosing colors.
Examination Scheme:
Components CT1 PR. ATTD. EE
Weightage (%) 10 15 5 70
Course Objective:
The primary objective of this course is to provide the fundamentals concepts of Design &
analysis of Algorithms. To provides knowledge of Time and space complexity of algorithms.
This course is to including Mathematical foundations, Sorting & searching Order Statistics,
Data Structures, Advanced Design & Analysis techniques such as Divide & Conquer, greedy
method, graph theory & Dynamic Programming approaches.
Course Contents:
Module I: Algorithm Analysis
Introduction Algorithms Complexity measures, Best, worst and average-case complexity
functions,problem complexity, quick review of basic data structures and algorithm design
principles.
Module II: Sorting and searching Order statistics
Sorting by selection, insertion and bubble, Divide & Conquer Strategy, Heap Sort, Quick
SortData Sorting in Linear time. other sorting algorithms— radix sort, merge sort, sternsons
Matrix Multiplication.
Searching in static table— binary search, path lengths in binary trees and applications,
optimality of binary search in worst cast and average-case Binary search trees, construction
of optimal weighted binary search trees; Searching in dynamic table -randomly grown binary
search trees, AVL and (a, b) trees. Hashing: Basic ingredients, analysis of hashing with
chaining and with open addressing.
Module III: Advanced Design and Analysis Techniques
Dynamic programming- Elements of dynamic programming, Chain-matrix multiplication, All
pair shortest path (Flayed -algorithm), Optimal Binary Search Tree.
Greedy algorlthms- Elements of the greedy strategy, Huffman codes, Single-source shortest
path in a directed graph, Knapsack problem.
Module IV: Graph Algorithms
Elementary graphs Algorithms, Minimum spanning Trees minimum spanning trees—
Kruskal‘s and Prim‘s algorithms— Johnson‘s implementation of Prim‘s algorithm using
priority queue data structures, Single source Shortest paths, All Pair Shortest Paths. String
processing: String searching and Pattern matching, Knuth-Morris-Pratt algorithm and its
analysis.
Module V : NP-completeness
Informal concepts of deterministic and nondeterministic algorithms, P and NP,NP-
completeness, statement of Cook‘s theorem, some standard NP-complete problems,
approximation algorithms.
Examination Scheme:
References Books:
Course Objective:
Virtualization is the single most effective way to reduce IT expenses while boosting efficiency
and agility in organizations.
This unit explores the implementation and usage of VMWare Virtualization, its installation
process and the working of Windows Server hyper V.
Course Contents:
Module I: Basics of Virtualization
Introduction to Unit, Need of Virtualization and Virtualization Technologies: Server
Virtualization, Storage Virtualization, I/O Virtualization, Network Virtualization, Client
Virtualization, Application virtualization, Desktop virtualization , Understanding Virtualization
Uses: Studying Server Consolidation, Development and Test Environments , Helping with
Disaster Recovery , Conclusion of the Unit
Module III: Deploying and Managing a Presentation Virtualization Environment I
Introduction to Unit , Prepare and manage remote applications - Configuring application sharing ;
Package applications for deployment by using RemoteApp, installing and configuring the RD
Session Host Role Service on the server. - Conclusion of the Unit
Examination Scheme:
Course Objective:
Evaluate python problems, Elicit, analyze and specify python through programming. Design
and Plan software solutions to various problems using python paradigms.
Course Contents:
Examination Scheme:
Text:
Kenneth A. Lambert, The Fundamentals of Python: First Programs, 2011, Cengage
Learning, ISBN: 978-1111822705.
References:
The Python Tutorial (https://docs.python.org/3/tutorial/): This is the official tutorial
from the Python website. No more authoritative source is available.
Code Academy Python Track (http://www.codecademy.com/tracks/python): Often
cited as a great resource, this site offers an entertaining and engaging approach and
in-browser work.
PRINCIPLES OF VIRTUALIZATION LAB
List of experiments
10. Clone a VM – I
11. Clone a VM - II
Examination Scheme:
IA EE
A PR LR V PR V
5 10 10 5 35 35
Note: IA –Internal Assessment, EE- External Exam, PR- Performance, LR – Lab Record, V –
Viva.
PYTHON LAB
Course Objective:
Evaluate python problems, Elicit, analyze and specify python through programming. Design
and Plan software solutions to various problems using python paradigms.
List of experiments
References:
The Python Tutorial (https://docs.python.org/3/tutorial/): This is the official tutorial
from the Python website. No more authoritative source is available.
Code Academy Python Track (http://www.codecademy.com/tracks/python): Often cited as a
great resource, this site offers an entertaining and engaging approach and in-browser work.
Examination Scheme:
IA EE
A PR LR V PR V
5 10 10 5 35 35
Note: IA –Internal Assessment, EE- External Exam, PR- Performance, LR – Lab Record, V –
Viva.
REPORT ON PAPER PRESENTATION IN CONFERENCE
Objective: Conferences / Seminars / Workshop are good and efficient way to get to know
other researchers through their work and also personally. The educational aspect can expose
the students to new ways of conducting the business and help them to discover how to be
more productive. They provide a great opportunity to network. Collaboration is the way to
approach networking.
Rules and Regulations
2nd Year / 3rd Year Students for which the students and the faculty members can start
preparations well in advance prior to the scheduled conference / seminar / workshop.
The number of students going for any conference / seminar / workshop should be
manageable.
A proposal for the proposed conference / seminar / workshop should be drafted and
presented to the HoI reflecting the following key points:
o Entire activity plan
o Route Map
o What are the objectives for the students?
o What they need to learn, do, and prepare before the conference / seminar /
workshop?
o List of prospective students with Contact Details
o List of Faculty Coordinators with Contact Details
After getting approval from the HoI, a note sheet should be prepared and all necessary
permission and approval from the competent authorities should be obtained.
The attention and co-operation of all students and parents are requested to attend the
conference / seminar / workshop most effectively. Signing of the letter of Indemnity Bond
(Consent‐cum‐Undertaking) is mandatory for all the parents of students going for
conference / seminar / workshop in or outside Jaipur. Duly executed Indemnity Bond
should be submitted to HoI Office at least 2 days prior to the visit, without which the
accompanying Staff coordinator shall not permit the student to participate in the industrial
visit
The list of students participating in conference / seminar / workshop shall be handed over
to the concerned HODs, Staff coordinators.
Students should be present in formals.
Students should carry the College Identity Cards during their journey.
Discipline should be maintained during the conference / seminar / workshop. Any
violation will be viewed very seriously.
A report of the conference / seminar / workshop is to be submitted in 5 days time by
students / faculty coordinators once the students are back.
The report to be prepared should reflect the following:-
What happened at the conference / seminar / workshop the students attend and how
does it relate in the best way to the preparations and the learning objectives.
How do the students will use the outcome of conference / seminar / workshop after it is
over?
What will they gain from it and how can they set up activities that transfer the
experience into learning?
Evaluation parameters for the success of the experience of conference / seminar /
workshop.
The student will be provided with the Student Assessment Record (SAR) to be placed in front
of the Report File. Each item in the SAR is ticked off when it is completed successfully. The
faculty will also assess each item as it is completed. The SAR will be signed by the student
and by the faculty to indicate that the File is the student‘s own work. It will also ensure
regularity and meeting the delaines.
Examination Scheme:
Components V S R FP
Weightage (%) 20 20 20 40
Course Objective:
To initiate the learners with the basic mechanics of writing skills and facilitate them with the
core skills required for communication in the professional world.
Course Contents:
Examination Scheme:
Course Objective:
To provide the students with the know-how
To master the current social communication skills in oral and in written.
To enrich the formulations, the linguistic tools and vary the sentence construction
without repetition.
Course Contents:
Module B: pp. 76 – 88 Unité 6
C – Project + Presentation
I – Interaction/Conversation Practice
Text & References:
Examination Scheme:
C – Project + Presentation
I – Interaction/Conversation Practice
Course Objective:
To enable students acquire knowledge of the Set/definite expressions (idiomatic expressions)
in Spanish language and to handle some Spanish situations with ease.
Course Contents:
Module I
Revision of earlier semester modules
Set expressions (idiomatic expressions) with the verb Tener, Poner, Ir….
Weather
Module II
Introduction to Gustar…and all its forms. Revision of Gustar and usage of it
Module III
Translation of Spanish-English; English-Spanish. Practice sentences.
How to ask for directions (using estar)
Introduction to IR + A + INFINITIVE FORM OF A VERB
Module IV
Simple conversation with help of texts and vocabulary
En el restaurante
En el instituto
En el aeropuerto
Module V
Reflexives
Examination Scheme:
C – Project + Presentation
I – Interaction/Conversation Practice
Español, En Directo I A
Español Sin Fronteras -Nivel Elemental
CHINESE
Course Objective:
Foreign words are usually imported by translating the concept into Chinese, the emphasis is on
the meaning rather than the sound. But the system runs into a problem because the underlying
name of personal name is often obscure so they are almost always transcribed according to their
pronciation alone. The course aims at familiarizing the student with the basic aspects of speaking
ability of Mandarin, the language of Mainland China. The course aims at training students in
practical skills and nurturing them to interact with a Chinese person.
Course Contents:
Module I
Drills
Dialogue practice
Observe picture and answer the question.
Introduction of written characters.
Practice reading aloud
Practice using the language both by speaking and by taking notes.
Character writing and stroke order
Module II
Measure words
Position words e.g. inside, outside, middle, in front, behind, top, bottom, side, left, right, straight.
Directional words – beibian, xibian, nanbian, dongbian, zhongjian.
Our school and its different building locations.
What game do you like?
Difference between ―hii‖ and ―neng‖, ―keyi‖.
Module III
Changing affirmative sentences to negative ones and vice versa
Human body parts.
Not feeling well words e.g.; fever, cold, stomach ache, head ache.
Use of the modal particle ―le‖
Making a telephone call
Use of ―jiu‖ and ―cal‖ (Grammar portion)
Automobiles e.g. Bus, train, boat, car, bike etc.
Traveling, by train, by airplane, by bus, on the bike, by boat.. etc.
Module IV
The ordinal number ―di‖
―Mei‖ the demonstrative pronoun e.g. mei tian, mei nian etc.
use of to enter to exit
Structural particle ―de‖ (Compliment of degree).
Going to the Park.
Description about class schedule during a week in school.
Grammar use of ―li‖ and ―cong‖.
Comprehension reading followed by questions.
Module V
Persuasion-Please don‘t smoke.
Please speak slowly
Praise – This pictorial is very beautiful
Opposites e.g. Clean-Dirty, Little-More, Old-New, Young-Old, Easy-Difficult, Boy-Girl, Black-
White, Big-Small, Slow-Fast … etc.
Talking about studies and classmates
Use of ―it doesn‘t matter‖
Enquiring about a student, description about study method.
Grammar: Negation of a sentence with a verbal predicate.
Examination Scheme:
C – Project + Presentation
I – Interaction/Conversation Practice
References:
1. HosseinBidgoli, Information Security, Volume 3, Threats, Vulnerabilities, Prevention,
Detection,
and Management, Wiley, 2006
2. Lawrence J Fennelly, Loss Prevention and Crime Prevention , Elsevier, 2004
3. Tipton RuthbeRg, Information Security Management, Auerbach, 1997
INFORMATION & NETWORK SECURITY
Course Objective:
This course will focus on concepts and methods for providing and evaluating security in
information processing systems. This course will explore ideas from the viewpoint of
security of information in terms of business risk, individual privacy and role of public
policy.
Module I: Introduction
History, What is Information Security?, Critical Characteristics of Information, NSTISSC
Security Model, Components of an Information System, Securing the Components,Balancing
Security and Access, The Security SDLC.
Examination Scheme:
Report Layout
The report should contain the following components
Table of Contents
Titles and subtitles are to correspond exactly with those in the text.
Acknowledgement
Acknowledgment to any advisory or financial assistance received in the course of work may be
given.
Student Certificate
Given by the Institute.
Introduction
Here a brief introduction to the problem that is central to the project and an outline of the
structure of the rest of the report should be provided. The introduction should aim to catch the
imagination of the reader, so excessive details should be avoided.
Chapters
All chapters and sections must be appropriately numbered, titled and should neither be too long
nor too short in length.
The first chapter should be introductory in nature and should outline the background of the
project, the problem being solved, the importance, other related works and literature survey. The
other chapters would form the body of the report. The last chapter should be concluding in nature
and should also discuss the future prospect of the project.
Appendices
The Appendix contains material which is of interest to the reader but not an integral part of the
thesis and any problem that have arisen that may be useful to document for future reference.
References / Bibliography
This should include papers and books referred to in the body of the report. These should be
ordered alphabetically on the author's surname. The titles of journals preferably should not be
abbreviated; if they are, abbreviations must comply with an internationally recognised system.
Essentially, marking will be based as per the examination Scheme given below :
Examination Scheme:
Components MRP V S FP R
Weightage (%) 20 20 20 20 20
MRP – Mid Report Presentation, V – Viva, S – Synopsis, FP – Final Presentation, R - Report
PROJECT WORK
Report Layout
The report should contain the following components
Table of Contents
Titles and subtitles are to correspond exactly with those in the text.
Acknowledgement
Acknowledgment to any advisory or financial assistance received in the course of work may be
given.
Student Certificate
Given by the Institute.
Introduction
Here a brief introduction to the problem that is central to the project and an outline of the
structure of the rest of the report should be provided. The introduction should aim to catch the
imagination of the reader, so excessive details should be avoided.
Chapters
All chapters and sections must be appropriately numbered, titled and should neither be too long
nor too short in length.
The first chapter should be introductory in nature and should outline the background of the
project, the problem being solved, the importance, other related works and literature survey. The
other chapters would form the body of the report. The last chapter should be concluding in nature
and should also discuss the future prospect of the project.
Appendices
The Appendix contains material which is of interest to the reader but not an integral part of the
thesis and any problem that have arisen that may be useful to document for future reference.
References / Bibliography
This should include papers and books referred to in the body of the report. These should be
ordered alphabetically on the author's surname. The titles of journals preferably should not be
abbreviated; if they are, abbreviations must comply with an internationally recognised system.
ASSESSMENT OF THE PROJECT FILE
Essentially, marking will be based as per the examination Scheme given below :
Examination Scheme:
Components MRP V S FP R
Weightage (%) 20 20 20 20 20
MRP – Mid Report Presentation, V – Viva, S – Synopsis, FP – Final Presentation, R - Report