VXLAN With Multicast Underlay
VXLAN With Multicast Underlay
VXLAN With Multicast Underlay
PNETLAB Store
PNETLab.com
Lab Topology:
Please use the following topology to complete this lab exercise:
https://user.pnetlab.com/store/labs/detail?id=16017035165831
1
Download PNETLab Platform
PNETLAB Store
PNETLab.com
Lab Objective:
The objective of this lab exercise is for you to learn and understand how can you configure
VXLAN with Multicast Underlay.
Task list:
Task 1: Configure the hostname and IP address for the interface for Routers (CSR2-4, R4, R5)
as topo. Check the reachability between Routers CSR after configuration OSPF between CSRs.
Task 2: Configure Multicast bi-directional PIM in all CSRs Routers.
Task 3: Config VXLAN Part on VTEP Routers (CSR, CSR2).
Task 4: Check VXLAN State on 2 VTEP Router (CSR, CSR2).
//This lab will use Router CSR 1000v as VTEP and Core Router. Please download and install it to
PNETLAB before practice.
SOLUTION:
Task 1: Configure the hostname and IP address for the interface for Routers (CSR2-4, R4, R5)
as topo. Check the reachability between Routers CSR after configuration OSPF between CSRs.
On CSR
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.1.12.1 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
!
On CSR1
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.1.12.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 10.1.23.2 255.255.255.0
ip ospf network point-to-point
2
Download PNETLab Platform
PNETLAB Store
PNETLab.com
ip ospf 1 area 0
!
On CSR2
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 10.1.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
!
On R4
!
interface Ethernet0/0
ip address 192.168.45.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
!
On R5
!
interface Ethernet0/0
ip address 192.168.45.5 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
!
Verification:
CSR#ping 3.3.3.3 source l0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/4 ms
ip pim sparse-mode
!
interface GigabitEthernet1
ip pim sparse-mode
!
On CSR1
!
ip multicast-routing distributed
!
ip pim bidir-enable
ip pim rp-address 2.2.2.2 bidir
!
interface Loopback0
ip pim sparse-mode
!
interface GigabitEthernet1
ip pim sparse-mode
!
interface GigabitEthernet2
ip pim sparse-mode
!
On CSR2
!
ip multicast-routing distributed
!
ip pim bidir-enable
ip pim rp-address 2.2.2.2 bidir
!
interface Loopback0
ip pim sparse-mode
!
interface GigabitEthernet2
ip pim sparse-mode
!
4
Download PNETLab Platform
PNETLAB Store
PNETLab.com
encapsulation untagged
!
!
bridge-domain 1
member vni 310595
member GigabitEthernet3 service-instance 1
!
On CSR2
!
interface nve1
no ip address
source-interface Loopback0
member vni 310595 mcast-group 239.0.150.220
!
interface GigabitEthernet3
service instance 1 ethernet
encapsulation untagged
!
!
bridge-domain 1
member vni 310595
member GigabitEthernet3 service-instance 1
!
//VNI in 2 VTEP Router must be matched.
// Multicast Group 239.0.150.220 is group for Multcast Underlay, used to transport packet
between 2 VTEP Routers.
//Configure Service Instance Ethernet on interface towards to R4 and R5, specify the
encapsulation is untagged.
//Configure Bridge-Domain on 2 VTEP.
CSR#show bridge-domain 1
Bridge-domain 1 (2 ports in all)
State: UP Mac learning: Enabled
Aging-Timer: 300 second(s)
GigabitEthernet3 service instance 1
vni 310595
AED MAC address Policy Tag Age Pseudoport
0 AABB.CC00.0200 forward dynamic 297 GigabitEthernet3.EFP1
0 AABB.CC00.0100 forward dynamic 299 nve1.VNI310595, VxLAN
src: 1.1.1.1 dst: 3.3.3.3
//Bridge-domain on VTEP Router will learn MAC address of Router R4 and R5.
R4#ping 192.168.45.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.45.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
//VxLAN will connect 2 Router R4 and R5. Now R4 could reach to R5 and could establish OSPF
neighbor with R5.