Location via proxy:   [ UP ]  
[Report a bug]   [Manage cookies]                

Day 3 - IP Services - OSPF

Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 8

********************************

1. IP Services
2. OSPF
********************************

********************************
1. IP Services
********************************

==================
SLA
==================

--------------------------------------------------------
! 1. Enable routing betwwen the ISP and the Backbone
--------------------------------------------------------

-----
R1
-----

router eigrp 111


network 192.1.10.0
network 192.1.14.0
passive-interface E 0/1

-----
R2
-----

router eigrp 111


network 192.1.20.0
network 192.1.24.0
passive-interface E 0/1

-----
R4
-----

router eigrp 111


network 192.1.24.0
network 192.1.14.0
network 4.0.0.0

---------------------------------------------------------------------
! 2. Create a Host route via the Primary Link on the Customer Router
---------------------------------------------------------------------

-----
R3
-----

ip route 4.2.2.2 255.255.255.255 192.1.10.1

---------------------------------------------------------------------
! 3. Configure the SLA for a destination of 4.2.2.2 via R1
---------------------------------------------------------------------

ip sla 11
icmp-echo 4.2.2.2 source-ip 192.1.10.3
frequency 20

---------------------------------------------------------------------
! 4. Enable the SLA
---------------------------------------------------------------------

ip sla schedule 11 start-time now life forever

---------------------------------------------------------------------
! 5. Link the SLA to a Track Object
---------------------------------------------------------------------

track 55 ip sla 11

---------------------------------------------------------------------
! 6. Create the route thru the primary link using the Track object
---------------------------------------------------------------------

ip route 0.0.0.0 0.0.0.0 192.1.10.1 track 55

---------------------------------------------------------------------
! 7. Configure a backup default route using the Secondary ISP with a higher Admin
Distance
---------------------------------------------------------------------

ip route 0.0.0.0 0.0.0.0 192.1.20.2 11

==================
NAT
==================

-------------------
Base Static Routing
-------------------

----
R3
----

ip route 0.0.0.0 0.0.0.0 192.168.1.2

----
R2
----

ip route 0.0.0.0 0.0.0.0 192.1.12.1


ip route 192.168.2.0 255.255.255.0 192.168.1.3
ip route 192.168.3.0 255.255.255.0 192.168.1.3
ip route 192.168.4.0 255.255.255.0 192.168.1.3

----
R1
----

ip route 192.1.10.0 255.255.255.0 192.1.12.2

++++++++++++++++++++++++++++
Dynamic NAT
++++++++++++++++++++++++++++

Requirement: Allow the 192.168.2.0/24 Segment to out to the Internet using a Pool
of Public addresses ( 192.1.10.51 - 192.1.10.250)

-----------------------------------------
1. Configure a Pool of Public Addresses
-----------------------------------------

ip nat pool POOL-A 192.1.10.51 192.1.10.250 netmask 255.255.255.0

---------------------------------------------
2. Configure a NAT Interesting traffic ACL
---------------------------------------------

access-list 101 permit ip 192.168.2.0 0.0.0.255 any

---------------------------------------------
3. Link the ACL to the Pool
---------------------------------------------

ip nat inside source list 101 pool POOL-A

----------------------------------------------------------------------
4. Specify the Interfaces that represent the outside network versus the inside
network
----------------------------------------------------------------------

Interface E 0/0
ip nat outside
Interface E 0/1
ip nat inside

++++++++++++++++++++++++++++
Static NAT
++++++++++++++++++++++++++++

Requirement: Translate the following devices statically on R2

192.168.3.1 - 192.1.10.21
192.168.3.2 - 192.1.10.22
192.168.3.3 - 192.1.10.23

-----
R2
-----

ip nat inside source static 192.168.3.1 192.1.10.21


ip nat inside source static 192.168.3.2 192.1.10.22
ip nat inside source static 192.168.3.3 192.1.10.23

++++++++++++++++++++++++++++
Dynamic PAT
++++++++++++++++++++++++++++

Requirement: Allow the 192.168.1.0/24 Segment to out to the Internet using a Single
Address (192.1.10.4)

-----------------------------------------
1. Configure a Pool with a single Address
-----------------------------------------

ip nat pool POOL-B 192.1.10.4 192.1.10.4 netmask 255.255.255.0

---------------------------------------------
2. Configure a NAT Interesting traffic ACL
---------------------------------------------

access-list 102 permit ip 192.168.1.0 0.0.0.255 any

---------------------------------------------
3. Link the ACL to the Pool
---------------------------------------------

ip nat inside source list 102 pool POOL-B overload

----------------------------------------------------------------------
4. Specify the Interfaces that represent the outside network versus the inside
network
----------------------------------------------------------------------

Interface E 0/0
ip nat outside
Interface E 0/1
ip nat inside

++++++++++++++++++++++++++++
Static PAT
++++++++++++++++++++++++++++

Requirement: Translate the following devices statically on R2

192.168.4.1 - 192.1.10.5 - WWW


192.168.4.2 - 192.1.10.5 - DNS
192.168.4.3 - 192.1.10.5 - TELNET

-----
R2
-----
ip nat inside source static tcp 192.168.4.3 23 192.1.10.5 23 extendable
ip nat inside source static udp 192.168.4.2 53 192.1.10.5 53 extendable
ip nat inside source static tcp 192.168.4.1 80 192.1.10.5 80 extendable

----------------------------------------------------------------------
Specify the Interfaces that represent the outside network versus the inside network
----------------------------------------------------------------------

Interface E 0/0
ip nat outside
Interface E 0/1
ip nat inside

********************************
2. OSPF
********************************
========================================================
OSPF on a Broadcast Multi-Access Segment (Ethernet)
========================================================

-----
R1
-----

router ospf 1
router-id 0.0.0.1
network 192.1.100.0 0.0.0.255 area 10
network 1.0.0.0 0.255.255.255 area 10

-----
R2
-----

router ospf 1
router-id 0.0.0.2
network 192.1.100.0 0.0.0.255 area 10
network 2.0.0.0 0.255.255.255 area 10

-----
R3
-----

router ospf 1
router-id 0.0.0.3
network 192.1.100.0 0.0.0.255 area 10
network 3.0.0.0 0.255.255.255 area 10
network 192.1.103.0 0.0.0.255 area 10
!
Interface E 0/0
ip ospf priority 50

-----
R4
-----

router ospf 1
router-id 0.0.0.4
network 192.1.103.0 0.0.0.255 area 10
network 4.0.0.0 0.255.255.255 area 10

-----
R6
-----

router ospf 1
router-id 0.0.0.6
network 192.1.103.0 0.0.0.255 area 10
network 6.0.0.0 0.255.255.255 area 10
network 192.1.67.0 0.0.0.255 area 10
!
Interface E 0/1
ip ospf network point-to-point

-----
R7
-----

router ospf 1
router-id 0.0.0.7
network 7.0.0.0 0.255.255.255 area 10
network 192.1.67.0 0.0.0.255 area 10
!
Interface E 0/0
ip ospf network point-to-point

-----
R11
-----

router ospf 1
router-id 0.0.0.11
network 192.1.100.0 0.0.0.255 area 10
network 11.0.0.0 0.255.255.255 area 10
!
Interface E 0/0
ip ospf priority 25

========================================================
OSPF on a Point-To-Point Segment (HDLC/PPP)
========================================================

-----
R2
-----

router ospf 1
network 192.1.101.0 0.0.0.255 area 10

-----
R5
-----

router ospf 1
router-id 0.0.0.5
network 192.1.101.0 0.0.0.255 area 10
network 192.1.102.0 0.0.0.255 area 10
network 5.0.0.0 0.255.255.255 area 10

-----
R4
-----

router ospf 1
network 192.1.102.0 0.0.0.255 area 10

==============================================================
OSPF on a Non-Broadcast Multi-Access Segment - Unicast OSPF
==============================================================

Requirement: Area Neighbors in Area 0 need to be unicast

-----
R7
-----
router ospf 1
network 192.1.78.0 0.0.0.255 area 0
neighbor 192.1.78.8
!
Interface E 0/1
ip ospf network non-broadcast

-----
R8
-----

Interface E 0/0
ip ospf network non-broadcast
!
Interface E 0/1
ip ospf network non-broadcast
!
router ospf 1
router-id 0.0.0.8
network 192.1.78.0 0.0.0.255 area 0
network 192.1.89.0 0.0.0.255 area 0
network 8.0.0.0 0.255.255.255 area 0
neighbor 192.1.78.7
neighbor 192.1.89.9

-----
R9
-----

Interface E 0/0
ip ospf network non-broadcast
!
router ospf 1
router-id 0.0.0.9
network 192.1.89.0 0.0.0.255 area 0
neighbor 192.1.89.8

==============================================================
Advertise the Loopbacks based on the Interface Mask
==============================================================

Requirement: Loopbacks should be advertised using their Interface Mask rather than
a Host

-----
R1
-----

Interface Loopback 0
ip ospf network point-to-point

-----
R2
-----

Interface Loopback 0
ip ospf network point-to-point
-----
R3
-----

Interface Loopback 0
ip ospf network point-to-point

-----
R4
-----

Interface Loopback 0
ip ospf network point-to-point

-----
R5
-----

Interface Loopback 0
ip ospf network point-to-point

-----
R6
-----

Interface Loopback 0
ip ospf network point-to-point

-----
R7
-----

Interface Loopback 0
ip ospf network point-to-point

-----
R8
-----

Interface Loopback 0
ip ospf network point-to-point

-----
R9
-----

Interface Loopback 0
ip ospf network point-to-point

-----
R11
-----

Interface Loopback 0
ip ospf network point-to-point

You might also like