Location via proxy:   [ UP ]  
[Report a bug]   [Manage cookies]                
0% found this document useful (0 votes)
5 views

opsd configuration using Packet Tracer

opsd configuration using Packet Tracer

Uploaded by

Riyad Alelwany
Copyright
© © All Rights Reserved
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
5 views

opsd configuration using Packet Tracer

opsd configuration using Packet Tracer

Uploaded by

Riyad Alelwany
Copyright
© © All Rights Reserved
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
You are on page 1/ 3

OSPF configuration using Packet Tracer

In Packet Tracer, you can configure an Open Shortest Path First (OSPF) dynamic
routing protocol to allow routers to exchange routing information. Here's how to
configure OSPF in a simple topology.

Scenario

 Three routers (Router2, Router3, Router4, Router5)


 Router2: 192.168.2.0/24 (Directly connected)
 Router3: 192.168.3.0/24 (Directly connected)
 Router4: 192.168.4.0/24 (Directly connected)
 Router5: 192.168.5.0/24 (Directly connected)
 Use OSPF Area 0 for routing.

Steps to Configure OSPF

1. Assign IP Addresses

Configure IP addresses for each router's interfaces.

Router2:

interface GigabitEthernet0/0
ip address 192.168.2.1 255.255.255.0
no shutdown

interface Serial0/0/0
ip address 11.0.0.1 255.0.0.0
no shutdown

Router3:

interface GigabitEthernet0/0
ip address 192.168.3.1 255.255.255.0
no shutdown

interface Serial0/0/0
ip address 11.0.0.2 255.0.0.0
no shutdown

interface Serial0/0/1
ip address 12.0.0.1 255.0.0.0
no shutdown
Router4:

interface GigabitEthernet0/0
ip address 192.168.4.1 255.255.255.0
no shutdown

interface Serial0/0/0
ip address 12.0.0.2 255.0.0.0
no shutdown

interface Serial0/0/1
ip address 13.0.0.1 255.0.0.0
no shutdown

Router5:

interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.0
no shutdown

interface Serial0/0/1
ip address 13.0.0.2 255.0.0.0
no shutdown

2. Enable OSPF on Each Router

Activate OSPF routing and specify the networks.

Router2:

router ospf 1
network 192.168.2.0 0.0.0.255 area 1
network 11.0.0.0 0.255.255.255 area 1

Router3:

router ospf 1
network 192.168.3.0 0.0.0.255 area 1
network 11.0.0.0 0.255.255.255 area 1
network 12.0.0.0 0.255.255.255 area 1

Router4:

router ospf 1

network 192.168.4.0 0.0.0.255 area 1


network 12.0.0.0 0.255.255.255 area 1
network 13.0.0.0 0.255.255.255 area 1
Router5:

router ospf 1
network 192.168.5.0 0.0.0.255 area 1
network 13.0.0.0 0.255.255.255 area 1

3. Verify OSPF Neighbors

After configuring OSPF, verify that neighboring routers form OSPF adjacencies.

Use the following command:

show ip ospf neighbor

4. Verify the Routing Table

Check if the routers have learned routes dynamically.

Command:

show ip route

You should see OSPF routes with an "O" flag in the routing table.

5. Test Connectivity

 Ping devices in other networks from any router to confirm reachability.

Notes

 The wildcard mask (e.g., 0.0.0.255) represents the range of IPs for a given
subnet.
 OSPF Area 0 is the backbone area and is required for all OSPF implementations.
 Ensure all interfaces are up using no shutdown

You might also like