Configuring The Cpe As The Pppoe or Pppoa Client: Teleworker Connectivity
Configuring The Cpe As The Pppoe or Pppoa Client: Teleworker Connectivity
Configuring The Cpe As The Pppoe or Pppoa Client: Teleworker Connectivity
router(config)#
interface ethernet number
router(config-if)#
pppoe enable
router(config-if)#
pppoe-client dial-pool-number number
router(config)#
interface dialer number
router(config-if)#
encapsulation ppp
router(config-if)#
ip address negotiated
router(config-if)#
dialer pool pool_number
router(config-if)#
ip mtu mtu_size
router(config)#
access-list ACL_num {permit | deny} protocol source_network
source_wildcard destination_network destination_wildcard
router(config)#
ip nat inside source list ACL_num interface interface number
[overload]
router(config-if)#
ip nat {inside | outside}
router(config)#
ip dhcp pool pool_name
• Enables a DHCP pool for use by hosts and enters DHCP pool configuration mode.
router(dhcp-config)#
import all
router(config)#
ip route 0.0.0.0 0.0.0.0 interface number
• The CPE can use a static default route to reach all remote
destinations.
Example: Static Default Route
Verifying a PPPoE
Configuration
Verifying a PPPoE Configuration
router#
debug pppoe events
router#
show ip dhcp binding
router#
show ip nat translations
hostname CPE
!
ip dhcp pool MyPool
network 10.0.0.0 255.0.0.0
default-router 10.0.0.1
!
interface Ethernet0/1
no ip address
pppoe enable
pppoe-client dial-pool-number 1
!
interface Ethernet0/0
ip address 10.0.0.1 255.0.0.0
ip nat inside
!
interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
ip mtu 1492
ip nat outside
ppp authentication chap callin
ppp chap password mysecret
!
ip nat inside source list 101 interface Dialer0 overload
access-list 101 permit ip 10.0.0.0 0.255.255.255 any
!
ip route 0.0.0.0 0.0.0.0 Dialer0
Configuration of a
PPPoA DSL
Connection
DSL Configuration Overview
• The CPE device encapsulates the PPP session based on RFC 1483 for transport
across the DSLAM.
• The virtual access interface associates each PPP connection with an ATM VC.
• The virtual access interface obtains its configuration from a virtual interface
template when the VC is created.
• The PPP subsystem starts and the router attempts to send a PPP configure
request to the remote peer.
• The virtual access interface remains associated with a VC as long as the VC is
configured.
• Three types of PPP over ATM connections are supported:
– IETF-compliant MUX encapsulated PPPoA
– IETF-compliant LLC encapsulated PPPoA
– Cisco-proprietary PPPoA
PPPoE vs. PPPoA
PPPoE PPPoA
interface Ethernet0/1 interface ATM0/0
no ip address no ip address
pppoe enable dsl operating-mode auto
pppoe-client dial-pool-number 1 pvc 1/32
! encapsulation aal5mux ppp dialer
interface Dialer0 dialer pool-member 1
ip mtu 1492
Configuration of the
DSL ATM Interface
Configuring the DSL ATM Interface
• Configure a static default route on the Cisco router to allow the router
to reach all unknown destinations toward the dialer interface.
• To verify proper PPPoE configuration, use debug ppp authentication,
show pppoe session, show ip dhcp binding, show ip nat translations, and
ipconfig /all commands.
• Configuring a PPPoA connection requires configuration of ATM and
dialer interfaces, PAT, DHCP, and static default route.
• Use the dsl operating-mode auto interface configuration command to
specify that the router will automatically detect the DSL modulation
that the service provider is using, and will set the DSL modulation to
match.
• An ATM VCI/VPI pair must be configured to communicate with the
service provider.