Location via proxy:   [ UP ]  
[Report a bug]   [Manage cookies]                

Q# 01 Introduction To Network Devices

Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 17

Q#01 INTRODUCTION TO NETWORK DEVICES

Hub
A hub is a common connection point for devices in a network. Hubs are
commonly used to connect segments of a LAN. A hub contains multiple
ports. When a packet arrives at one port, it is copied to the other ports so
that all segments of the LAN can see all packets.

Every computer connected to the hub sees everything that every other
computer on the hub sees. The computers themselves decide if they are the
targeted recipient of the message and when a message should be paid
attention to or not.

The hub itself is blissfully ignorant of the data being transmitted. For years,
simple hubs have been quick and easy ways to connect computers in small
networks

Switch
A network switch is a computer networking device that
connects network segments.
Populates MAC address table on the basis of source MAC
address of a Frame.
Network switches are capable of inspecting data frames
as they are received, determining the source and
destination device of that frame, and forwarding it
appropriately
Data Link Layer or Layer 3 Device.
Multiple collision Domain but single Broadcast Domain.
A vital difference between a hub and a switch is that all
the nodes connected to a hub share the bandwidth among
themselves, while a device connected to a switch port has
the full bandwidth all to itself.

Router
Routers are highly intelligent devices that connect multiple
network types and determine the best path for sending data.
Routers are normally used to connect one LAN to another.

These devices examine incoming packets to determine the


destination address of the data. It then examines its internal
routing table to choose the best path for the packet through
the network, and switches them to the proper outgoing port.

However, they are slower than bridges because they are


more intelligent devices; as such, they analyze every packet,
causing packet-forwarding delays. Because of this
intelligence, they are also more expensive.

Routers are OSI network layer 3 devices

Typically, when a WAN is set up, there will be at least two


routers used.

Cables and connectors


Coaxial Cables

First invented in the 1880s, "coax" was best known as the kind of cable that
connected television sets to home antennas. Coaxial cable is also a standard
for 10 Mbps Ethernet cables.

When 10 Mbps Ethernet was most popular, during the 1980s and early
1990s, networks typically utilized one of two kinds of coax cable
- thinnet (10BASE2 standard) or thicknet (10BASE5). These cables consist of
an inner copper wire of varying thickness surrounded by insulation and other
shielding. Their stiffness caused network administrators difficulty in installing
and maintaining thinnet and thicket.

Twisted Pair Cables

Twisted pair eventually emerged during the 1990s as the leading cabling
standard for Ethernet, starting with 10 Mbps (10BASE-T, also known as
Category 3 or Cat3), later followed by improved versions for 100 Mbps
(100BASE-TX, Cat5 and Cat5e) and successively higher speeds up to 10 Gbps
(10GBASE-T). Ethernet twisted pair cables contain up to 8 wires wound
together in pairs to minimize electromagnetic interference.

Two primary types of twisted pair cable industry standards are defined
Unshielded Twisted Pair (UTP) and Shielded Twisted Pair (STP).

Crossover Cables

Null modem cables are one example of the category of crossover cables. A
crossover cable joins two network devices of the same type, such as two PCs
or two network switches.

The use of Ethernet crossover cables was especially common on older home
networks years ago when connecting two PCs directly together. Externally,
Ethernet crossover cables appear nearly identical to ordinary (sometimes
also called straight-through), the only visible difference being the order of
color-coded wires appearing on the cable's end connector. Manufacturers
typically applied special distinguishing marks to their crossover cables for
this reason. Nowadays, though, most home networks utilize routers that
have built-in crossover capability, eliminating the need for these special
cables.

Q #02 Design of Ethernet cable


A structured cabling design that uses a physical hierarchical star topology
offers a communications transport system that can efficiently support all
logical topologies (star, bus, point-to-point, and ring). The guidelines
presented here follow the general recommendations set forth by the tia/eia-
568a Commercial Building Telecommunications Cabling Standard. The term
"logical topology" refers to the method by which different nodes in a network
communicate with one another. It involves protocols, access, and standards-
based applications at the electronic circuit level. "Physical topology" simply
refers to the physical arrangement of the cabling or cabling system by which
nodes are attached.
To be universal for all applications, a structured cabling plan must support all
logical topologies. These topologies define the electronic connection of the
system`s nodes. Fiber applications can support point-to-point, star, ring, and
bus logical topologies.

All of the logical topologies are easily implemented with a physical star
cabling scheme as recommended by the TIA/EIA-568A standard.
Implementing logical point-to-point and star topologies on a physical star is
straightforward.

While data networks that use bus or ring topology dominate the market--for
example, Ethernet, Token Ring, and Fiber Distributed Data Interface (FDDI)--
the benefits of physical star cabling have led electronics vendors and
standards bodies to develop electronic solutions designed to interface with a
star network. These applications are typically implemented with an
"intelligent hub" or concentrator. This device establishes the bus or ring in
the backplane of the device, and the connections are made from one or more
central locations. Therefore, from the standpoint of a physical connection,
these networks appear to be a star topology and are best supported by a
physical star cabling system.

Q #03 Basic configuration of switch


Topology designed for switch
Commands:

Switch>enable

Switch>Config t

Setting hostname

Switch # hostname S-1

Setting enable password & enable secet

S-1# enable password 123

S-1# enable secret 1234

Setting console password

S-1# line console 0

S-1# password 123

S-1# login

Setting banner

S-1# banner motd


S-1# configuration terminal

S-1(confif)# banner motd c welcome c

Removing above parameters

No before every command e.g

S-1(config)#no hostname

Q #04 Basic configuration of router

router>enable
router#configure terminal
router(config)#hostname R1
R1(config)#banner motd #No unauthorized access allowed!"#
R1(config)#enable secret class
R1(config)#service password-encryption

R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
Q #05 Basic configuration of Hub and switch
Hub:
Hub always broad cast the information .It has a central point through this
point all the hosts are connected .if there become fault in central point than
whole network will destroy.

Network using switch

Switch:
Switch also broadcast the information only at first time when its switching
table is completed than it cannot broadcast information.
Q #06 Setting gateway of network enabling the interfaces of router

Router#conf t
Router(Config) #line vty 0 4
Router(Config-if) #password password
Router(Config-if) #login
R1(config)# interface fa0/0

R1(config-if)# ip address 192.168.10.1 255.255.255.0

R1(config-if)# no shutdown

R1(config-if)# exit

R1(config)# interface fa0/1


R1(config-if)# ip address 192.168.11.1 255.255.255.0

R1(config-if)# no shutdown

R1(config-if)# exit

R1(config)# interface se0/0/0

R1(config-if)# ip address 209.165.200.225 255.255.255.252

R1(config-if)# clock rate 64000

R1(config-if)# no shutdown

R1(config)#exit

Q #07 Configuration of Encapsulation & clock


rate on router serial interface DTE/DCE
terminal

In Router 1
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 2/0

R1(config-if)#ip address 20.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#encapsulation ppp

R1(config-if)#no shutdown

R1(config-if)#exit

Router 2

R2(config)#interface fastethernet 0/0

R2(config-if)#ip address 30.0.0.1 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#interface serial 2/0

R2(config-if)#ip address 20.0.0.2 255.0.0.0

R2(config-if)#encapsulation ppp

R2(config-if)#no shutdown

R2(config-if)#exit
Q #08 Configration of static routing

Router>enable

Router#config terminal

Router(config)#int fa0/0

Router(config-if)#ip address 10.0.0.1 255.0.0.0

Router(config-if)#no shut

Router(config-if)#exit

Router(config)#int Se2/0

Router(config-if)#ip address 20.0.0.1 255.0.0.0

Router(config-if)#no shut

Router>enable

Router#config terminal
Router(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2

Q #09Configuration of dynamic routing


protocol Rip

Commands:

Router>

Router > enable

Router #conf t

For rip

Router (config)#router rip

Router (config-if)#network 11.0.0.0 255.0.0.0

Q #10 CDP (cisco discovery protocol)


CDP
CDP ( Cisco Discovery Protocol) is a proprietary protocol designed by Cisco
System for Cisco devices. CDP helps administrators in collecting information
about cisco devices.
CDP is a data link layer protocol. It is available in IOS from version 10.3.
Routers and catalyst switches support CDP. CDP is enabled by default on all
supporting devices. Supporting device can receive and send CDP messages.
CDP messages are not forwarded. It means you can get CDP information only
about the directly connected devices.
CDP messages are generated as layer two frames and distributed as
multicasts. CDP uses SNAP (Sub network Access Protocol) frame
type. SNAP is not supported by all media types. Media types supported by
SNAP are Ethernet, Token Ring, fibre distributed data interface (FDDI),
Asynchronous Transfer Mode (ATM), Point-to-Point Protocol (PPP), High- Level
Data Link Control (HDLC), and Frame Relay. With SNAP, CDP is also limited
with these media types only.

Router1#conf t
Router1(config)#cdp run
Router1(config)#exit
Router1#show cdp neighbor

Q #11 dynamic routing protocol rip v2


Q #12Configuration of dynamic routing
protocol EIGRP

Q #13 Configuration of dynamic routing


protocol OSPF
Commands :

For configuration of ospf

R1#conf t

R1(config)#router ospf 100

R1(config-router)# network 10.0.0.0 0.255.255.255 area0

Q #14 VLANS
INTRODECTION OF VLANS

In a layer 2 switched networks, each network segment has its own collision
domain and all segments are in same broadcast domain. Every broadcast is
seen by every device on the network. A layer 3 device (typically a Router) is
used to segment (divide) a broadcast domain to multiple broadcast domains.

ADVANTAGES OF VLANS:
Broadcast Control:

Broadcasts are required for the normal function of a network. Many protocols
and applications depend on broadcast communication to function properly. A
layer 2 switched network is in a single broadcast domain and
the broadcasts can reach the network segments which are so far where a
particular broadcast has no scope and consume available network bandwidth

Security:

VLANs provide enhanced network security. In a VLAN network environment,


with multiple broadcast domains, network administrators have control over
each port and user. A malicious user can no longer just

HOW TO CREAT THE STATIC VLANS AND SHOW THEM:

You might also like