Location via proxy:   [ UP ]  
[Report a bug]   [Manage cookies]                

Networking Project

Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 21

CHAPTER 1: INTRODUCTION

1.1 Networking
A network is a set of devices connected by media links. A node can be computer, printer, or
any other device capable of sending and/or receiving data generated by other nodes on the
network. The links connecting the device are often called communication channels. In other
words it is the interconnection of two or more computers for sharing data and resources.

Fig. 1.1.1 Networking Area

1.1.2 Modes Of Networking:

 Point-to-Point Line Configuration – It provides a dedicated link between two devices.


The entire capacity of the channel is reserved for transmission between those two devices
These configurations use an actual length of wire or cable to connect the two ends. For e.g.
when you change t.v. channels by infrared remote control, you are establishing point-to-point
line configuration.

Fig 1.1.2 Point to Point Line Configuration

1|Page
 Multipoint Line Configuration - In this multiple devices are attached to a single link.
The entire capacity of the link is shared for the transmission between all the devices
connected to a link.

Fig 1.1.3 Multipoint Line Configuration

1.2 Switch
 A switch is a multiport bridge with a buffer and a design that can boost its efficiency (a
large number of ports imply less traffic) and performance. A switch is a data link layer
device. The switch can perform error checking before forwarding data, which makes it very
efficient as it does not forward packets that have errors and forward good packets
selectively to the correct port only.  In other words, the switch divides the collision domain
of hosts, but broadcast domain remains the same. 

Fig 1.2.1 Switch

1.3 Router
A router is a device like a switch that routes data packets based on their IP addresses. The
router is mainly a Network Layer device. Routers normally connect LANs and WANs
together and have a dynamically updating routing table based on which they make decisions
on routing the data packets. Router divide broadcast domains of hosts connected through it.

2|Page
Fig 1.3.1 Router

1.4 Cables
Cable is the medium through which information usually moves from one network device to
another. There are several types of cable which are commonly used with LANs. In some
cases, a network will utilize only one type of cable, other networks will use a variety of cable
types. The type of cable chosen for a network is related to the network's topology, protocol,
and size. Understanding the characteristics of different types of cable and how they relate to
other aspects of a network is necessary for the development of a successful network.

 Ethernet Cable : Ethernet is the traditional technology for connecting devices in a


wired local area network (LAN) or wide area network (WAN). It enables devices to
communicate with each other via a protocol, which is a set of rules or common
network language. Ethernet describes how network devices format and transmit data
so other devices on the same LAN or campus network can recognize, receive and
process the information. An Ethernet cable is the physical, encased wiring over which
the data travels.

Fig 1.4.1 Ethernet

 Console Cable : The Console Cable is used for the serial connection between your
computer’s serial port and the console port on your TP-Link switch or router to access
the CLI (Command Line Interface) of the device.

3|Page
Fig 1.4.2 Console Cable

 Serial Cable : A serial cable is a cable used to transfer information between two


devices using a serial communication protocol. The form of connectors depends on the
particular serial port used. A cable wired for connecting two DTEs directly is known
as a null modem cable.

Fig 1.4.3 Serial Cable

4|Page
CHAPTER 2 : CISCO PACKET TRACER
2.1 Cisco packet Tracer
Cisco Packet Tracer is Cisco's simulation software. It can be used to create complicated
network typologies, as well as to test and simulate abstract networking concepts. It acts as a
playground for you to explore networking and the experience is very close to what you see
in computer networks. They also provide their service in languages such as Russian,
German, Spanish and French. Packet Tracer enables students to create complicated and huge
networks, which is frequently impossible with physical hardware due to cost considerations.
Packet Tracer is available for Linux, Windows, MacOS, Android, and iOS. Packet Tracer
allows users to drag and drop routers, switches, and other network devices to create
simulated network topologies. If you have a Netacad account, you can download it for free.
The best way to learn about networking, according to Cisco, is to do it. This programme
cannot replace hardware routers or switches because the protocols are implemented solely in
software. This tool, however, does not just contain Cisco hardware but also a wide range of
other networking
devices. Cisco Packet Tracer supports a multi-user system that allows many users to connect
various topologies across a computer network. Instructors can also build exercises for students to
perform using Packet Tracer. Supports feature expansion via additional programmes that use
an API to improve Cisco Packet Tracer's capabilities in areas including curriculum and
assessment delivery, gaming, accessibility, and interacting with real-world equipment.

Fig 2.1.1 Interface of Cisco Packet Tracer

5|Page
CHAPTER 3: PROJECT WORK
3.1 Project Work

 This project consist of 5 routers.


 The main router is the Delhi Router which is further connected to Nirman Vihar and
Vaishali router which are connected to Dwarka and Ghaziabad router respectively.
 The main Delhi Router is Password protected and it is assumed that headquarter of
the company is located there.
 It is assumed that the other offices of company are located at different places like:
Dwarka, Nirman Vihar, Ghaziabad and Vaishali.

3.2 Project Layout

6|Page
CHAPTER 4: IMPLEMENTATION
4.1 Internet Protocol

Internet Protocol (IP) is the principal set (or communications protocol) of digital message
formats and rules for exchanging messages between computers across a single network or a
series of interconnected networks, using the Internet Protocol Suite (often referred to as
TCP/IP). Messages are exchanged as datagram, also known as data packets or just packets.
The main purpose and task of IP is the delivery of datagram from the source host (source
computer) to the destination host (receiving computer) based on their addresses. IP is similar
to the Postal System in that it allows a package (a datagram) to be addressed (encapsulation)
and put into the system (the Internet) by the sender (source host).Internet Protocol version 4
(IPv4) was the first major version of IP. This is the dominant protocol of the Internet.
However, iPv6 is active, its deployment is increasing all over the world.
4.1.1 IP Addressing in Networks :
There are two kinds of addresses used in networks:

Physical Address

 It is also called hardware address or MAC address.MAC stands for media access
control.

 It is present in the chip of a NIC card.

 It is unique for every NIC card and cannot be changed.

 It is 48 bits. Out of 48 bits, 24 bits of address is given by the manufacturer of NIC card
and the remaining 24 bits of address is defined as per instructions given by IEEE.

 IEEE stands for Institute of Electronics and Electrical Engineers.

Logical Address

 It is also called software address.

 It is given by the user and can be changed anytime.

 Several schemes or protocols are used to define logical address in a computer.

These protocols are:

7|Page
TCP/IP (Transmission Control Protocol/Internet Protocol)

IPX/SPX (Internetwork Packet Exchange/Sequential Packet Exchange)

DLC (Data Link Control)

AppleTalk

Protocol

Protocol is a set of rules which in communication between computers.

TCP/IP

1. It has become industry-standard


2. It was developed by DOD (Department of Defence) of USA.
3. It is used both in Internet (public network) and Intranet (private network).
4. It is of 32 bits.
5. Currently used version is IP v4.
6. IP v6 is also available.
7. It has four fields or octets.
8. Each octet is of 8 bits.
9. It can be represented by w.x.y.z
10. Minimum value of octet is 0 and maximum is 255
11. Each octet or field can have decimal values ranging from 0 to 255.
12. According to the value of w or first field, we have five classes of TCP/IP Addresses.

The first three classes are only used for computer addressing in a network.
IP Address Ranges
Early network design, when global end to end connectivity was envisioned for all internet
hosts, intended that IP addresses be uniquely assigned to a particular computer or device.
However, it was found that it was not always necessary as private networks developed and
addresses space needed to be conserved (IPv4 address exhaustion).
Computer not connected to the internet, such as factory machines that communicate only with
each other via TCP/IP, need not have globally – unique IP addresses. Three ranges of IPv4
addresses for private networks, one range for each class (A,B,C) were reserved. These
addresses are not routed on the Internet, and thus their use need not be coordinated with an IP
address registry.

IP Addresses are divided into two parts:

8|Page
 Private IP address

 Public (live) IP address.

Public IP – It is used on public network i.e. internet and recognized on network. It is given
by the service provider IANA. Public IP is globally unique.
Private IP – It is used within the LAN or within the organization. But it is not recognized on
internet. It is given by the administrator. It is unique within the network or organization. We
don’t need to pay to service provider i.e. free and it is an unregistered IP.

There are certain addresses in each class of IP address that are reserved for Private networks.
These are called private addresses.
Range for Private ip address

 Class A 10.0.0.0 to 10.255.255.255


 Class B 172.16.0.0 to 172.31.255.255

 Class C 192.168.0.0 to 192.168.255.255

Range of Public IP Address:

 1.0.0.0 to 9.255.255.255
 11.0.0.0 to 126.255.255.255
 128.0.0.0 to 172.15.255.255

 172.32.0.0 to 192.167.255.255
 192.169.0.0 to 223.255.255.255

Subnet Mask:
Subnet Mask is also 32 bit address,which tell us how many bits are used for network and how
many bits are used for host address. In subnet mask network bits are always 1 and host bits
are always 0.

Ping – Packet Internet Groper

9|Page
This command is used to check the connectivity with other computer. Ping is performed with
in network or outside the network. In this process four packets are send to destination address
and four packets received from the destination address. Internet control massage protocol is
used for this process. Used for testing connectivity between two devices.

Subnetting

It is the process of dividing a single network into multiple smaller networks. It helps in
minimizing the wastage of IP address.

DHCP Configuration
DHCP pool for 10 Network
R1(config)#ip dhcp pool 10network
R1(dhcp-config)#network 10.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 10.0.0.1
DHCP pool for 20 Network
R1(config)#ip dhcp pool 20network
R1(dhcp-config)#network 20.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 20.0.0.1

4.2 Routing Protocols


Routing is a process which is performed by layer 3 (or network layer) devices in order to
deliver the packet by choosing an optimal path from one network to another. There are 3 types
of routing:

 Static routing –Static routing is a process in which we have to manually add routes in
routing table. No routing overhead for router CPU which means a cheaper router can
be used to do routing. It adds security because only administrator can allow routing to
particular networks only.
 Default Routing –This is the method where the router is configured to send all packets
towards a single router (next hop). It doesn’t matter to which network the packet belongs, it
is forwarded out to router which is configured for default routing. It is generally used with stub
routers. A stub router is a router which has only one route to reach all other networks. Easy to
configure.More effective at selecting the best route to a destination remote network
and also for discovering remote network.

10 | P a g e
Routing Information Protocol:
Routing Information Protocol (RIP) is a dynamic routing protocol which uses hop count as
a routing metric to find the best path between the source and the destination network. It is a
distance vector routing protocol.
Hop  
Hop count is the number of routers occurring in between the source and destination network.
The path with the lowest hop count is considered as the best route to reach a network and
therefore placed in the routing table. RIP prevents routing loops by limiting the number of
hopes allowed in a path from source and destination. The maximum hop count allowed for
RIP is 15 and hop count of 16 is considered as network unreachable.
Features of RIP :
 Updates of the network are exchanged periodically.
 Updates (routing information) are always broadcast.
 Full routing tables are sent in updates.
 Routers always trust on routing information received from neighbor routers. This is
also known as Routing on rumours.
RIP versions : 
There are three versions of routing information protocol – RIP Version1, RIP Version2 
 RIP v1 is known as Classful Routing Protocol because it doesn’t send information
of subnet mask in its routing update.
 RIP v2 is known as Classless Routing Protocol because it sends information of
subnet mask in its routing update.

Fig 4.2.1 Routing Information Protocol


EIGRP:
Enhanced Interior Gateway Routing Protocol (EIGRP) is a dynamic routing Protocol which is
used to find the best path between any two layer 3 device to deliver the packet. EIGRP works
on network layer Protocol of OSI model and uses the protocol number 88.It uses metric to

11 | P a g e
find out best path between two layer 3 device (router or layer 3 switch) operating EIGRP.
EIGRP has the following characteristics:

 Advanced operational efficiency


 Capabilities of both link state and distance vector
 A classless routing protocol
 Unique features including use of Reliable Transport Protocol (RTP), a diffusing
update algorithm (DUAL), updates and updated information about neighbors

The EIGRP composite metric calculation can use up to 5 variables, but only 2 are used by
default (K1 and K3). The composite metric values are:

 K1 (bandwidth)
 K2 (load)
 K3 (delay)
 K4 (reliability)
 K5 (MTU)
The lowest bandwidth, load, delay, reliability, MTU along the path between the source and
the destination is considered in the composite matrix in order to calculate the cost.
Configuration:

Router(config)# router eigrp autonomous_system_#


Router(config-router)# network IP_network_# [subnet_mask]

Fig 4.2.2 Enhanced Interior Gateway Routing Protocol

Open Shortest Path First


Open shortest path first (OSPF) is a link-state routing protocol which is used to find the best
path between the source and the destination router using its own shortest path first (SPF)

12 | P a g e
algorithm. A link-state routing protocol is a protocol which uses the concept of triggered
updates, i.e., if there is a change observed in the learned routing table then the updates are
triggered only, not like the distance-vector routing protocol where the routing table are
exchanged at a period of time. An area is a group of contiguous network and routers. Routers
belonging to same area shares a common topology table and area I’d. The area I’d is
associated with router’s interface as a router can belong to more than one area.

Fig 4.2.3 Open Shortest Path First Routing Protocol

Fig 4.2.4 Open Shortest Path First Routing Protocol Configuration

4.3 Tools And Techniques Used


4.3.1 SSH and Telnet
Telnet was one of the first internet application protocols -- the other is the FTP -- and Telnet is
used for initiating and maintaining a terminal emulation session on a remote host. SSH and
Telnet are functionally similar, with the primary difference between them being that the SSH
protocol uses public key cryptography to authenticate end points when setting up a terminal
session as well as for encrypting session commands and output. SSH, also known as Secure

13 | P a g e
Shell or Secure Socket Shell, is a network protocol that gives users, particularly system
administrators, a secure way to access a computer over an unsecured network. SSH also refers
to the suite of utilities that implement the SSH protocol. Secure Shell provides
strong authentication and encrypted data communications between two computers connecting
over an open network such as the internet. SSH is widely used by network administrators for
managing systems and applications remotely, allowing them to log into another computer over
a network, execute commands and move files from one computer to another. SSH refers both
to the cryptographic network protocol and to the suite of utilities that implement that
protocol. 

Fig 4.3.1.1 Secure Socket Shell

Now SSH configuration:


We can configure SSH on Cisco router by following these simple steps:
Step1: set up a hostname and a domain name. 
Router>enable 
Router#config t
Enter configuration commands, one per line.
Step2: configure local username and password.
Step3: generate RSA public and private keys.
Router(config)#transport input SSH

14 | P a g e
Fig 4.3.1.2 SSH Configuration

4.3.2 VOIP
Voice over Internet Protocol (VoIP), is a technology that allowing you to make voice calls
over a broadband Internet connection instead of a analog (regular) phone line. Some VoIP
services allow you to call people using the same service, but others may allow you to call
anyone. They can have a telephone number – including local, long distance, mobile, and
international numbers or not. Some VoIP services only work over your computer or a special
VoIP phone while other services allow you to use a traditional phone connected to a VoIP
adapter using option 150 IP.

Fig 4.3.2.1 VoIP Configuration

15 | P a g e
Fig 4.3.2.2 IP Phone GUI

4.3.3 Port Security


Attackers’ task is comparatively very easy when they can enter the network they want to
attack. Ethernet LANs are very much vulnerable to attack as the switch ports are open to use
by default. Various attacks such as Dos attack at layer 2, address spoofing can take place. If
the administrator has control over the network then obviously the network is safe. To take
total control over the switch ports, user can use feature called port-security.User can secure a
port in two steps:

 Limiting the number of MAC addresses to a single switch port, i.e. if more than the
limit, Mac addresses are learned from a single port then appropriate action will be
taken.
 If an unauthorized access is observed, the traffic should be discarded by using any of
the options or more appropriate, user should generate a log message so that
unauthorized access can be easily observed.
Configuration
Applying port-security on fa0/1 interface of switch .first, convert the port to an access port
and will enable port-security.
S1(config)#int fa0/1
S1(config-if)#switchport mode access
S1(config-if)#switchport port-security
Use sticky command so that it will learn the Mac address dynamically and will provide the
limit and the appropriate action that should be taken.
S1(config-if)#switchport port-security Mac-address sticky
S1(config-if)#switchport port-security
maximum 2

16 | P a g e
S1(config-if)#switchport port-security violation shutdown
If user wants to provide a static entry, then configure that by stating its Mac address.
S1(config-if)#switchport port-security
S1(config-if)#switchport port-security violation shutdown
S1(config-if)#switchport port-security Mac-address aa.bb.cc.dd.ee.ff

Fig 4.3.3.1 Port Security

4.3.4 VTP

To carry traffic of a VLAN, it must be first configured on the switch. Suppose, if user wants
to send a frame from source to destination and the shortest path between them contains 1000
switches. To process a frame of any VLAN, VLANs should be configured first so, have to
configure the same VLANs on all the 1000 switches manually. It will not be possible for the
administrator to do that. Here comes VTP to the rescue.VTP is CISCO proprietary protocol
used to maintain consistency throughout the network or user can say that synchronizing the
VLAN information in same VTP domain. VTP allows you to add, delete and rename VLANs
which is then propagated to other switches in the VTP domain. VTP advertisements can be
sent over 802.1Q, and ISL trunks. VTP has the following 3 different modes:

Switch(config)#vtp mode ?
ServerClient
Transparent
Switch(config)#vtp domain alpha
Switch(config)#vtp password pass

17 | P a g e
Fig 4.3.4.1 VLAN Trunk Protocol
CHAPTER 5: RESULT AND DISCUSSION
5.1 Snapshots

Fig 5.1.1 Project Configuration Interface

5.2 Results

Fig 5.2.1 Communication using IP phones

18 | P a g e
Fig 5.2.2 In Progress

Fig 5.2.3 Communication Done

19 | P a g e
Fig 5.2.4 Communication started

Fig 5.2.5 In progress

Fig 5.2.6 Communication Done

20 | P a g e
CHAPTER 6: Conclusion And Future Scope
6.1 Conclusion:

 Creating a company network have best routing protocol for the given scenario.
 Creating a better communication at different branches of the company at different
locations.
 The network is secured.
 It is easy to understand the whole network.
 Networking is done by areas.
 Easy to troubleshoot.
 We can extend the range of slots in routers.

6.2 Future Scope:


The only varying parameter in our analysis, other than routing protocol of course, was the size
of the network topology. Improvement or future works for this project can include adding
metrics on interfaces such as cost, bandwidth, distance, Bit Error Rate (BER), and delay.
Furthermore, various network topologies (in terms of size, routers and links used) can be
implemented for comparison of performance between these routing protocols. Since OSPF is
the most complex routing protocol, more time could be spent on analysing it to find the value
of parameters that need to be set in order for it to perform optimally. Another possibility is to
implement real network topologies used, perhaps in a university campus a company office, or
a larger network size while also modifying the network parameters, such as interfaces, to
those of the actual scenario being analysed.

21 | P a g e

You might also like