Location via proxy:   [ UP ]  
[Report a bug]   [Manage cookies]                

Eveng Dockers Ip File 280523

Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 7

FOR Static (GNS3 DOCKER):

...........

#
# This is a sample network config uncomment lines to configure the network
#

# Static config for eth0


auto eth0
iface eth0 inet static
address 10.1.1.2
netmask 255.255.255.0
gateway 10.1.1.254
up echo nameserver 8.8.8.8 > /etc/resolv.conf

# DHCP config for eth0


# auto eth0
# iface eth0 inet dhcp

============================
FOR DHCP:
.........

#
# This is a sample network config uncomment lines to configure the network
#

# Static config for eth0


auto eth0
#iface eth0 inet static
# address 10.1.1.1
# netmask 255.255.255.0
# gateway 10.1.1.254
# up echo nameserver 8.8.8.8 > /etc/resolv.conf

# DHCP config for eth0


auto eth0
iface eth0 inet dhcp

============================

# This the configuration for PC1


#
# Uncomment the following line to enable DHCP
# dhcp
# or the line below to manually setup an IP address and subnet mask
ip 10.4.4.1 255.255.255.0
set pcname PC1-INS

==========================

FOR ROUTER (telnet/ssh/ftp/http/https/dns):


---------

enable secret cisco123


line vty 0 4
login local
transport input telnet ssh

ip http server

ip http secure-server

ip http authentication local

username admin privilege 15 password 0 adm123


username kamran password 0 kam123

ip ftp username ftp


ip ftp password ftp123

ip dns server

ip scp server enable

ip domain-name cisns.com

crypto key generate rsa modulus 2048

snmp-server host 10.2.2.200 version 2c snmp123


snmp-server community snmp123 RO
snmp-server community snmp123 RW
snmp-server trap-source Gi1
snmp-server source-interface informs Gi1
snmp-server enable traps
snmp-server enable traps config

logging 10.2.2.100

.......
enable secret cisco123

line vty 0 4
login local
transport input telnet ssh

ip http server

ip http secure-server

ip http authentication local

username admin privilege 15 password 0 adm123


username kamran password 0 kam123

ip ftp username ftp


ip ftp password ftp123

ip dns server

ip scp server enable


ip domain-name cisns.com

restconf
!
ip http server
ip http authentication local
ip http secure-server

crypto key generate rsa modulus 2048

.....

restconf
!
ip http server
ip http authentication local
ip http secure-server

.....................

snmp-server engineID remote 10.2.2.200 800000090300AABBCC000500


#8000000903000002FD79C
snmp-server view configfile iso included
snmp-server view configfile mib-2 included
snmp-server view configfile system included
snmp-server view configfile cisco included
snmp-server group writeuser v3 auth write configfile
snmp-server user writemanager writeuser v3 auth md5 authpassword123

ip flow-export source FastEthernet0/0


ip flow-export version 9 peer-as
ip flow-export destination 10.2.2.200 2055
ip flow-top-talkers
match source address 10.1.1.0 255.255.255.0
match destination address 10.1.1.0 255.255.255.0
match protocol tcp

interface fastEthernet0/0
ip flow ingress
ip flow egress

crypto key generate rsa general-keys modulus 1024

crypto key generate rsa general-keys label cisco-1 modulus 1024 exportable
crypto key export rsa cisco-1 pem url nvram:startup-config 3des cisco123

aaa new-model
aaa authentication login default local
aaa authorization exec default local

login on-failure log


loging on-success log

crypto pki server cisco


database level minimum
database url nvram: issuer-name cn=lab.nb.com l=gr c=in
lifetime certificate 365
grant auto
no shutdown

give 9 alphabet password

-----------------

access-list 101 permit tcp any any eq telnet


access-list 102 permit tcp any any eq 22
access-list 103 permit tcp any any eq www
access-list 104 permit tcp any any eq 443
access-list 111 permit tcp any any eq www
access-list 111 permit tcp any any eq 443
access-list 111 permit tcp any any eq telnet
access-list 111 permit tcp any any eq 22

=======================

more flash:ping.tcl
foreach address {
1.1.1.1
1.1.1.5
1.1.1.10
1.1.1.100
1.1.1.254
} { ping $address}

============================
Linux ifconfig command:

ifconfig eth0 1.1.1.10 netmask 255.255.255.0


ip route add default via 1.1.1.254 dev eth0

===========================

RADIUS users:
- alice
- bob

TACACS+ users:
- gns3 (role: admin)
- readonly

All users, as well as the RADIUS/TACACS+ clients have the password 'gns3' set.

--------------------
SCRIPT FOR TACACS - GNS3:
=======================

aaa new-model
!
!
aaa group server tacacs+ gns3group
server name container
!
aaa authentication login default group gns3group local
aaa authentication enable default enable
!
tacacs server container
address ipv4 10.2.2.2
key gns3
!

line vty 0 15
login authentication default

username admin privilege 15 password 0 adm123


username kamran password 0 kam123

--------------------
SCRIPT FOR RADIUS- GNS3:
=======================

aaa new-model
!
aaa group server radius gns3group
server name container
!
aaa authentication login default group gns3group local
aaa authentication enable default enable
!

radius server container


address ipv4 10.2.2.2 auth-port 1812 acct-port 1813
key gns3
!

line vty 0 15
login authentication default
!

username admin privilege 15 password 0 adm123


username kamran password 0 kam123

...
radius-server host 10.2.2.2
radius-server key gns3

=========

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ (outside-nyk) host 10.2.2.2 tacacs-key timeout 3

aaa authentication serial console TACACS+ LOCAL


aaa authentication enable console TACACS+ LOCAL
aaa authentication http console TACACS+ LOCAL
aaa authentication ssh console TACACS+ LOCAL

aaa authorization command TACACS+ LOCAL

aaa accounting command privilege 15 TACACS+


aaa-server TACACS+ max-failed-attempts 3
reactivation-mode timed
++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Script for Router AAA - ISE:


............................
aaa new-model
tacacs server ISE
address ipv4 10.1.1.200
key cisco123
!
<OR>
aaa new-model
aaa authentication login default group tacacs+ local
aaa authentication enable default group tacacs+ enable

aaa authorization exec default group tacacs+ local


aaa authorization commands 0 default group tacacs+ local
aaa authorization commands 1 default group tacacs+ local
aaa authorization commands 15 default group tacacs+ local
aaa authorization config-commands

aaa accounting exec default start-stop group tacacs+


aaa accounting commands 0 default start-stop group tacacs+
aaa accounting commands 1 default start-stop group tacacs+
aaa accounting commands 15 default start-stop group tacacs+
aaa accounting connection default start-stop group tacacs+

tacacs-server host 10.1.1.200 key cisco123

line vty 0 4
authorization commands 0 default
authorization commands 1 default
authorization commands 15 default
authorization exec default
login authentication default
aaa accounting commmands 0 default
aaa accounting commmands 1 default
aaa accounting commmands 15 default
aaa accounting connection default

---

test aaa group tacacs+ admin1 Admin@12345


test aaa group tacacs+ admin1 Admin@12345 new-code

debug aaa authentication


test aaa group tacacs+ admin1 Admin@12345 legacy

==============

SNMP-SERVER CONFIGS ON CISCO DEVICES - ROUTER:


----------------------------------------------
snmp-server host 10.2.2.200 version 2c snmp123
snmp-server community snmp123 RO
snmp-server trap-source FastEthernet0/0
snmp-server source-interface informs FastEthernet0/0
snmp-server enable traps
snmp-server enable traps config

You might also like