Location via proxy:   [ UP ]  
[Report a bug]   [Manage cookies]                

Hoang BR

Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 7

===========================================================

BR

crypto isakmp policy 10


authentication pre-share
group 2
crypto isakmp key TEST address 101.1.1.254
crypto isakmp key test address 102.1.1.254
!
!
crypto ipsec transform-set MYSET esp-des esp-sha-hmac
!
crypto ipsec profile MYPROFILE
set transform-set MYSET
!
!
!
!
!
!
!
interface Tunnel10
ip address 10.0.0.2 255.255.255.252
tunnel source 103.1.1.254
tunnel mode ipsec ipv4
tunnel destination 102.1.1.254
tunnel protection ipsec profile MYPROFILE
!
interface Tunnel20
ip address 10.0.1.2 255.255.255.252
tunnel source 103.1.1.254
tunnel mode ipsec ipv4
tunnel destination 101.1.1.254
tunnel protection ipsec profile MYPROFILE
!
interface Ethernet0/0
ip address 103.1.1.254 255.255.255.0
!
interface Ethernet0/1
ip address 10.1.1.254 255.255.255.0
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
router ospf 1
network 10.1.1.0 0.0.0.255 area 0
network 103.1.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 103.1.1.1
ip route 172.17.0.0 255.255.255.0 172.17.2.1
ip route 172.17.1.0 255.255.255.0 10.0.1.1 10
ip route 172.17.2.0 255.255.255.0 10.0.0.1 5
!
!
!
!
control-plane
!
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
transport input all
!
!
end

=====================================================
IPS

interface Ethernet0/0
ip address 103.1.1.1 255.255.255.0
!
interface Ethernet0/1
ip address 102.1.1.1 255.255.255.0
!
interface Ethernet0/2
ip address 101.1.1.1 255.255.255.0
!
interface Ethernet0/3
no ip address
shutdown
!
router ospf 1
network 101.1.1.0 0.0.0.255 area 0
network 102.1.1.0 0.0.0.255 area 0
network 103.1.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
transport input all
!
!
end
============================
GW1
crypto isakmp policy 10
authentication pre-share
group 2
crypto isakmp key test address 103.1.1.254
!
!
crypto ipsec transform-set MYSET esp-des esp-sha-hmac
!
crypto ipsec profile MYPROFILE
set transform-set MYSET
!
!
!
!
!
!
!
interface Tunnel10
ip address 10.0.0.1 255.255.255.252
tunnel source 102.1.1.254
tunnel mode ipsec ipv4
tunnel destination 103.1.1.254
tunnel protection ipsec profile MYPROFILE
!
interface Ethernet0/0
ip address 102.1.1.254 255.255.255.0
!
interface Ethernet0/1
ip address 172.17.2.254 255.255.255.0
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
router ospf 1
network 102.1.1.0 0.0.0.255 area 0
network 172.17.2.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 10.1.1.0 255.255.255.0 10.0.0.2
ip route 103.1.1.0 255.255.255.0 102.1.1.1
!
!
!
!
control-plane
!
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
transport input all
!
!
end
===============================================
crypto isakmp policy 10
authentication pre-share
group 2
crypto isakmp key TEST address 103.1.1.254
!
!
crypto ipsec transform-set MYSET esp-des esp-sha-hmac
!
crypto ipsec profile MYPROFILE
set transform-set MYSET
!
!
!
!
!
!
!
interface Tunnel20
ip address 10.0.1.1 255.255.255.252
tunnel source 101.1.1.254
tunnel mode ipsec ipv4
tunnel destination 103.1.1.254
tunnel protection ipsec profile MYPROFILE
!
interface Ethernet0/0
ip address 101.1.1.254 255.255.255.0
!
interface Ethernet0/1
ip address 172.17.1.254 255.255.255.0
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
router ospf 1
network 101.1.1.0 0.0.0.255 area 0
network 172.17.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 10.1.1.0 255.255.255.0 10.0.1.2
ip route 103.1.1.0 255.255.255.0 101.1.1.1
!
!
!
!
control-plane
!
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
transport input all
!
!
end
===============================================
CORE1
interface Ethernet0/0
ip address 172.17.2.1 255.255.255.0
!
interface Ethernet0/1
ip address 172.17.1.1 255.255.255.0
!
interface Ethernet0/2
ip address 172.18.0.1 255.255.255.0
!
interface Ethernet0/3
ip address 172.17.0.1 255.255.255.0
!
router ospf 1
network 172.17.0.0 0.0.0.255 area 0
network 172.17.1.0 0.0.0.255 area 0
network 172.17.2.0 0.0.0.255 area 0
network 172.18.0.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 10.1.1.0 255.255.255.0 103.1.1.254
ip route 103.1.1.0 255.255.255.0 172.17.2.254
!
!
!
!
control-plane
!
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
transport input all
!
!
end
=====================================================
CORE2
interface Ethernet0/0
ip address 172.18.0.254 255.255.255.0
!
interface Ethernet0/1
ip address 172.16.1.254 255.255.255.0
!
interface Ethernet0/2
ip address 172.16.0.254 255.255.255.0
!
interface Ethernet0/3
no ip address
shutdown
!
router ospf 1
network 172.16.0.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.255 area 0
network 172.18.0.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 172.16.2.0 255.255.255.0 172.16.1.1
=====================================================
interface Ethernet0/0
no ip address
shutdown
!
interface Ethernet0/1
ip address 172.16.2.254 255.255.255.0
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 172.16.2.1

You might also like