Module-3 Practical Exercise
Module-3 Practical Exercise
Module-3 Practical Exercise
2024
AAI/ANS/CNS/CATC/2024/CBTA-Non PLI/Data
Communication Networking/Cyber-
सी.ए.टी.सी.,
Security/Linux/Mod-3 /Ver.1.0
प्रयागराज
CATC, PRAYAGRAJ
THIS PAGE IS INTENTIONALLY KEPT BLANK
Module-3
Data Communication Networking, Cyber security and Linux
With pleasure, I authenticate this handout and make it available for imparting NPLI training
course on “Data Communication Networking, Cyber Security and Linux” for ATSEPs in AAI.
The course content has been approved by CHQ of AAI. It is hoped that the trainee ATSEPs
will find it informative, interesting and better in presentation.
I am sure that the trainees will carry a sense of pride in undergoing this CBTA based NPLI
Training course of ICAO standard.
For the development and presentation of this module as per ICAO Doc 10057, I would like
to appreciate the meticulous and excellent work done by the course developers.
Objective: The Objective of this practical exercise is to become familiar with creating
topologies in Packet Tracer.
Single click on each group of devices and connections to display the various choices. The devices you see
may differ slightly.
Move the cursor into the topology area. You will notice that it turns into a plus “+” sign.
Add the hub by moving the plus sign “+” below PC0 and PC1 and click once.
1 2 3 4 5
Repeat the steps above for PC1 connecting it to Port 1 on Hub0. (The actual hub port you choose does not
matter.)
Add the switch by moving the plus sign “+” below PC2 and PC3 and click once.
1 2 3 4 5 6
Repeat the steps mentioned above for PC3 connecting it to port FastEtherent0/2 of switch0. (The actual switch
port you choose does not matter.)
Move the cursor over the green link light to view the port number. Fa means FastEthernet, 100 Mbps Ethernet.
Choose the Config tab and click on Settings. H e r e , you can change the name of PC0. You can also enter
a Gateway IP Address, also known as the default gateway and the DNS Server IP Address. We will discuss
this later, but the value in “default gateway address”, would be the IP address of the local router. If you want,
you can enter the Gateway IP Address 172.16.1.1 and DNS Server IP Address 172.16.1.100, although it will
not be used in this lab.
Also notice, here you can also change the Bandwidth (speed) and Duplex of the Ethernet NIC (Network
Interface Card). The default is Auto (auto-negotiation), which means the NIC will negotiate with the hub or
switch. The bandwidth and/or duplex can be manually set by removing the check from the Auto box and by
choosing the specific option.
Bandwidth - Auto
If the host is connected to a hub or a switch port which can support 100 Mbps, then the Ethernet NIC on
the host will choose 100 Mbps (Fast Ethernet). Otherwise, if the hub or switch port can only support 10
Mbps, then the Ethernet NIC on the host will automatically choose 10 Mbps (Ethernet).
Duplex - Auto
Hub: If the host is connected to a hub, then the Ethernet NIC on the host will choose Half Duplex.
Switch: If the host is connected to a switch, and the switch port is configured as Full Duplex (or
Autonegotiation), then the Ethernet NIC on the host will choose Full Duplex. If the switch port is configured
as Half Duplex, then the Ethernet NIC on the host will choose Half Duplex. (Full Duplex is a much more
efficient option.)
Repeat these steps for the other hosts. Use the information below for IP Addresses and Subnet Masks.
To verify the information that you entered, move the Select tool (arrow) over each host.
To delete a device or link, choose the Delete tool and click on the item you wish to delete.
Click once on Switch0 and choose FastEthernet0/4 (actual port does not matter).
The link light for switch port FastEthernet0/4 will first appear as amber and will eventually change to green as
the Spanning Tree Protocol transitions the port to forwarding.
Select the Add Simple PDU tool which are used to ping devices.
2
Civil Aviation Training College, India Page 16
Module-3 Practical Exercise
Data Communication Networking, Cyber security and Linux
______________________________
Select the Add Simple PDU tool used to ping devices.
Continue clicking Capture/Forward button until the ICMP ping is completed. You should see the ICMP
messages move between the hosts, hubs and switches. The PDU Last Status should show as Successful.
Click on Clear Event List if you do not want to look at the events or click Preview Previous Events, if you
do. For this exercise, it does not matter.
Lab instructions:
A new switch or router purchased from Cisco contains no default
configuration in it. You need to configure the switch or router with setup
mode using the setup mode or from scratch using the command line
interface (CLI) before connecting it in your network environment. It is very
important to know the basic Cisco switch or router configuration
commands to improve the performances and the security of your
internetwork.
This lab exercise will test your ability to configure basic settings on a cisco
switch and router.
Router configuration:
Router >en
Router #config t
Router (config)#hostname CATC
CATC(config)#
CATC(config)#int f0/0
CATC(config-if)#ip add 10.0.0.1 255.0.0.0
CATC(config-if)#no shut
CATC(config)#int f0/1
CATC(config-if)#ip add 20.0.0.1 255.0.0.0
CATCconfig-if)#no shut
Solution:
Configure Router (R1):
R1>en
R1#config t
R1(config)#int f0/0
R1(config-if)#ip add 10.0.0.1 255.0.0.0
R1(config-if)#no shut
R1(config)#int se2/0
R1(config-if)#ip add 20.0.0.1 255.0.0.0
R1(config-if)#no shut
R1(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
R1(config)#ip route 40.0.0.0 255.0.0.0 20.0.0.2
R1(config)#ip route 50.0.0.0 255.0.0.0 20.0.0.2
Solution:
Configure R1:
R1>en
R1#config t
R1(config)#int f0/0
R1(config-if)#ip add 10.0.0.1 255.0.0.0
R1(config-if)#no shut
R1(config)#int se2/0
R1(config-if)#ip add 20.0.0.1 255.0.0.0
R1(config-if)#no shut
R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#ver 2
R1(config-router)#no auto-summary
Configure R3:
R3>en
R3#config t
R3(config)#int se2/0
R3(config-if)#ip add 40.0.0.2 255.0.0.0
R3(config-if)#no shut
R3(config)#int f0/0
R3(config-if)#ip add 50.0.0.1 255.0.0.0
R3(config-if)#no shut
R1
Configure HR Switch:
Switch(config)#vlan 2
Switch(config-vlan)#name CNS
Switch(config)#vlan 3
Switch(config-vlan)#name HR
Switch(config)#vlan 4
Switch(config-vlan)#name FIN
Switch(config)#Int f0
Switch(config-if)#switchport access vlan 3
Switch(config)#Int f1
Switch(config-if)#switchport access vlan 3
Switch(config)#Int f3
Switch(config-if)#switchport mode trunk
Switch(config)#Int f4
Switch(config-if)#switchport access vlan 2
Configure Router:
R1(config)#Int f0/0
R1(config-if)#no shut down
R1(config-if)#int f0/0.1
R1(config-subif)#encapsulation dot1q 2
R1(config-subif)#ip add 10.0.0.1 255.0.0.0
R1(config-if)#int f0/0.2
R1(config-subif)#encapsulation dot1q 3
R1(config-subif)#ip add 11.0.0.1 255.0.0.0
Configuration of Switch:
Switch>
Switch#config t
Switch(config)#VLAN2
Switch(config-VLAN)#name CNS
Switch(config)#VLAN3
Switch(config-VLAN)#name HR
Switch(config)#Int f0/1
Switch(config-if)#switchport access vlan 2
Switch(config)#Int f0/2
Switch(config-if)#switchport access vlan 2
Switch(config)#Int f0/3
Switch(config-if)#switchport access vlan 3
Switch(config)#Int f0/4
Switch(config-if)#switchport access vlan 3
Switch(config-if)#exit
Switch(config)#int vlan2
Switch(config-if)#ip add 10.0.0.3
Switch(config-if)#no shut
Step1: Configure IP Address to all the interfaces of the router and host.
Step2: Configure Routing by RIPV2.
Step3: Configure VRRP
Router R1 Configuration:
R1(Config)#int f0/0
R1(config-if)#vrrp 123 ip 10.0.0.5
R1(config-if)#vrrp 123 preempt
R1(config-if)#vrrp 123 priority 120
R1(config)#track 1 int f1/0 line-control
R1(config)#int f0/0
R1(config-if)#vrrp 123 track 1 decrement 40
Router R2 Configuration:
R2(Config)#int f0/0
R2(config-if)# vrrp 123 ip 10.0.0.5
Router R3 Configuration:
R3(Config)#int f0/0
R3(config-if)#vrrp 124 ip 40.0.0.5
R3(config-if)#vrrp 124 preempt
R3(config-if)#vrrp 124 priority 120
R3(config)#track 1 int f1/0 line-control
R3(config)#int f0/0
R3(config-if)#vrrp 124 track 1 decrement 40
Create above network topology in Cisco Packet tracer and perform following
exercises –
Configure switch port security on interface Fa 0/1 of the switch with the
following settings:
- Port security: enabled
- Mode: restrict
- Allowed mac addresses: 3
- Dynamic mac address learning.
Command used:
#interface FastEthernet0/1
#switchport mode access
#switchport port-security
#switchport port-security maximum 3
Now observe when Intruder laptop is connected to the hub and tries to
communicate with PC0 (192.168.10.1), the number of mac-addresses
learned on fa0/1 interface exceeds 3. The interface drops traffic with the
new mac-address (not learned by the switch because 3 mac addresses
have already been registered on the fa0/1 interface) and increases the
security violation counter based on the 'restrict' port-security
configuration of the interface.
Configure port security on interface Fa 0/2 of the switch with the following
settings:
- Port security enabled
- Mode: shutdown (default)
- Allowed mac addresses: 1 (default)
- Dynamic mac address learning.
Command used:
#interface FastEthernet0/2
#switchport mode access
#switchport port-security
#switchport port-security maximum 1
Configure port security on interface Fa 0/4 of the switch with the following
settings:
- Port security enabled
- Mode: protect
- Static mac address entry: mac address of device connected at Fa0/4
Command
#interface FastEthernet0/4
#switchport mode access
Solution: According to the given task, we are denying access to a single host.
Therefore, we configured a standard access-list.
1. Apply the access-list near the destination, i.e., on R2.
2. Apply it outbound on the F0/0 interface of the R2 router.
Solution: According to the given task, we are denying access to a host icmp protocol
with any one host. Therefore, we configured a Extended access-list.
1. Apply the access-list near the Source, i.e., on R1.
2. Apply it inbound on the F0/0 interface of the R1 router.
Solution: According to the given task, we are denying access to a host for web service.
Therefore, we configured a Extended access-list.
1. Apply the access-list near the Source, i.e., on R1.
2. Apply it inbound on the F0/0 interface of the R1 router.
Solution: According to the given task, we are denying access to a host for web service.
Therefore, we configured a Extended access-list.
1. Apply the access-list near the Source, i.e., on R1.
2. Apply it inbound on the F0/0 interface of the R1 router.
Step 1: First, open the Cisco packet tracer desktop and select the devices
given below:
1. PC PC 3
2. server PT-Server 1
3. switch PT-Switch 1
IP Addressing Table:
Server with
Firewall
Step 2: Configure the PCs (hosts) and server with IPv4 address and Subnet Mask
according to the IP addressing table given above.
To assign an IP address in PC0, click on PC0.
Then, go to desktop and then IP configuration and there you will IPv4 configuration.
Fill IPv4 address and subnet mask.
Repeat the same procedure with the server
Repeat the same procedure with other PCs to configure them thoroughly.
R1>enable
R1#config t
R1(config)#interface F0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shut
R1(config-if)#ip nat inside
R1(config)#interface Serial0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#no shut
R1(config-if)#ip nat outside
R1(config)#ip nat inside source static 10.0.0.2 20.0.0.3
R1(config-if)#exit
R1(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
(Configure static routing in R1 Router only)
R2>en
R2#config t
R2(config)#int se2/0
R2(config-if)#ip add 20.0.0.2 255.0.0.0
R2(config-if)#no shut
R2(config)#int f0/0
R2(config-if)#ip add 30.0.0.1 255.0.0.0
R2(config-if)#no shut
R1>enable
R1#config t
R1(config)#interface F0/0
R1(config-if)#ip address 10.0.0.2 255.0.0.0
R1(config-if)#ip nat inside
R1(config)#interface Se2/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#ip nat outside
R1(config)#ip nat pool CATC 20.0.0.3 20.0.0.4 netmask 255.0.0.0
R1(config)#ip nat inside source list 1 pool CATC
R1(config)#access-list 1 permit 10.0.0.0 0.255.255.255
R1(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
R2>en
R2#config t
R2(config)#int se2/0
R2(config-if)#ip add 20.0.0.2 255.0.0.0
R2(config-if)#no shut
R2(config)#int f0/0
R2(config-if)#ip add 30.0.0.1 255.0.0.0
R2(config-if)#no shut
R1>enable
R1#config t
R1(config)#interface F0/0
R1(config-if)#ip address 10.0.0.2 255.0.0.0
R1(config-if)#ip nat inside
R1(config)#interface Se2/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#ip nat outside
R1(config)#ip nat pool globalnet 20.0.0.3 20.0.0.3 netmask 255.0.0.0
R1(config)# ip nat inside source list 1 pool globalnet overload
R1(config)#access-list 1 permit 10.0.0.0 0.255.255.255
R1(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
R2>en
R2#config t
R2(config)#int se2/0
R2(config-if)#ip add 20.0.0.2 255.0.0.0
R2(config-if)#no shut
R2(config)#int f0/0
R2(config-if)#ip add 30.0.0.1 255.0.0.0
R2(config-if)#no shut
Task 1:
STEPS OF Task 1:
Task 2:
STEPS OF Task 2:
Task 3:
STEPS OF Task 3:
Use date command to set date to 07:30 Hrs 10/03/2024.
Using date command format output as
STEPS OF Task 4:
Use find command to search a file in a given path:
a) By type
#find / -type f -print //To find the files inside ‘/’ directory. ‘f’ means to search by file type.
Similarly, ‘d’ means directory and ‘l’ means link file.
b) By size
#find /home -size +10c //To find files and directories of size greater than 10 bytes inside
home directory.
#find /home -size +1G // To find files and directories of size greater than 1 Gb inside home
directory.
c) By name
#find / -name file1 //To find a file named ‘file1’ inside ‘/’ directory.
Task 5:
STEPS OF Task 5:
Use grep, tail, and head command to:
Task 6:
a) Create a directory with the name CATC1 & CATC2 under/ home
b) Make a file with the name ‘file1’ under under /home/CATC1
c) Write some contents under the file
d) Insert a USB drive in the system
e) Mount it under/mnt
f) Copy ‘file1’ file into pendrive & restore this file in /CATC2
g) Remove the pen drive properly
STEPS OF Task 6:
a) Create a directory with the name CATC1 & CATC2 under/ home
#mkdir /home/CATC1 /home/CATC2 //To make two directories inside home directiory.
b) Make a file with the name ‘file1’ under under /home/CATC1
#fdisk -l //To list the device partition. (output will be like /dev/sdb1 ********)
e) Mount it under/mnt.
#mount /dev/sdb1 /mnt //To mount the external device partition to /mnt directory.
f) Copy ‘file1’ file into pendrive & restore this file in /CATC2
#cp -p /home/CATC1/file1 /mnt //To copy ‘file1’ from CATC1 directory to /mnt directory i.e.
the pendrive..
#cd /mnt
Task 7:
STEPS OF Task 7:
#su – cns //To switch user to ‘cns’ user. Enter the password root1.
e) Create a directory with the name CATC4 under /home/cns
[cns@localhost ~]$mkdir /home/cns /CATC4 //To create a directory named ‘CATC4’ under
/home/cns directory of cns user.
f) Create a file with the name DCN3 under /home/cns/CATC4/ with some contents.
#[cns@localhost ~]$chmod 744 /home/cns/CATC4 //To set the given permission for the
file[CATC4].
a) Create a file named file2 by vi command and write some text in the file
b) Edit the document by inserting & deleting a line, words, & characters
c) Copy another line & undo it
d) Save the file
e) Continue with the same document & put additional information on the same document
f) Now save it & quit
a) Create a file named file2 by vi command and write some text in the file.
#vi /home/file2 //To create file2 under home directory. Use vi commands to write some text
in file.
b) Edit the document by inserting & deleting a line,words & characters
c) Copy another line & undo it
d) Save the file
e) Continue with the same document & put additional information on the same document
f) Now save it & quit.
STEPS OF Task 9:
#touch /home/script //To create a file named script under home directory.
#chmod 777 /home/script //To change the permission of script file so, that it becomes an
executable file.
#vi /home/script //To open script file with vi editor.
Write down following content in the script file:
cd /home/CATC5
tar -zcvf backup_file4.tar.gz file4
mv file4 /tmp
c) Create a program to execute the above task mentioned in point (b) daily at 04:30 IST.
Task 11:
Configuration to bring Radar data from source station to receiving station Example
Radar data from Station A need to be sent to Station B through FTI IP Circuit.
Router_A(config)#int fa0/1
Router_A(config-if)#description Radar_In
Router_A(config-if)#ip address 170.20.1.1 255.255.255.0
Router_A(config-if)#ip pim sparse-mode
Router_A(config-if)#ip igmp static-group 226.23.11.1
Router_A(config-if)#ip pim neighbor-filter 11
Router_A(config-if)#exit
Router_A(config)#int fa0/0
Router_A(config-if)#description Radar WAN FTI to Site B
Router_A(config-if)#ip address 10.15.20.1 255.255.255.252
Router_A(config)#interface loopback1
Router_A(config-if)#description RP_for_Radar
Router_A(config-if)# ip address 10.10.10.1 255.255.255.255
Router_A(config-if)# ip pim sparse-mode
Router_A(config-if)#exit
Router_B(config)#int fa0/1
Router_B(config-if)#description Site_A Radar to Auto_LAN
Router_B(config-if)#ip address 171.10.2.1 255.255.255.0
Router_B(config-if)#ip pim sparse-mode
Router_B(config)#int fa0/0
Router_B(config-if)#description Radar WAN FTI from Site A
Router_B(config-if)#ip address 10.15.20.2 255.255.255.252
Router_B(config-if)#ip pim sparse-mode
Router_B(config-if)#ip igmp static-group 226.23.11.1
Router_B(config-if)#exit
Contents
AAI/ANS/CNS/CATC/2024/NON-PLI
सी.ए.टी.सी., प्रयागराज TRNG/DATA COMMUNICATION
NETWORKING/CYBER-SECURITY/
LINUX/MOD 3/Ver.1.0
C.A.T.C., PRAYAGRAJ