Location via proxy:   [ UP ]  
[Report a bug]   [Manage cookies]                

Static Routing Exercise

Download as ppt, pdf, or txt
Download as ppt, pdf, or txt
You are on page 1of 23
At a glance
Powered by AI
The key takeaways from the document are that static routing involves manually configuring routes on routers and hosts to control traffic flow in a network. Static routing requires configuring IP addresses and default routes on network interfaces, as well as adding static routes between routers to reach different subnets.

The main components involved in static routing are network interface configuration on routers and hosts, adding default routes, and configuring static routes between routers to reach different subnets in the network.

The advantages of static routing include simplicity of configuration, security of only allowing defined routes, and not using bandwidth for routing updates. The disadvantages are that routes need to be manually updated after any network changes and all routes between networks need to be explicitly defined.

Static Routing

Exercise
Isatou Jah/Nishal Goburdhan
What will the exercise
involve?
 Unix network interface configuration

 Cisco network interface configuration

 Static routes

 Default route

 Testing
Routing
 Routing is done based on destination IP
address
 Without routing, interface can only reach
destinations via ARP
 Cannot reach a destination on another
separate network without going through
an intermediate device
 A device with at least 2 interfaces can
route
Routing
 Static routes
 specifically instructs router on which route to
take to a particular destination network
 dynamic routes
 learnt via routing protocols implemented on
routers
 default routes
 route that instructs a machine where to send
packets for destinations that are not on the
routing table
Static Routing
 Advantages
 Simple to configure and maintain
 Secure as only defined routes can be
accessed
 Bandwidth is not used for sending routing
updates
 Disadvantages
 Manual update of routes after changes
 Explicit addition of routes for all networks
Static/default route
example
To Internet 172.16.3.2

172.16.3.1 172.16.2.2 172.16.1.0


255.255.255.0
172.16.2.1

ip route 172.16.1.0 255.255.255.0 172.16.2.1 - STATIC


ip route 0.0.0.0 0.0.0.0 172.16.3.1 - DEFAULT
Classroom Network Layout
SWITCH

HUB HUB
A B
PC Router Router PC

HUB HUB
C D
PC Router Router PC

HUB HUB
E F
PC Router Router PC

HUB HUB
G H
PC Router Router PC

HUB HUB
I J
PC Router Router PC
Address Assignments
SWITCH

.1 .2
A B
196.200.220.16/28 196.200.220.32/28

196.200.220.0/28
.3 .4
C D
196.200.220.48/28 196.200.220.64/28

.5 .6
E F
196.200.220.80/28 196.200.220.96/28

.7 .8
G H
196.200.220.112/2 196.200.220.128/2
8 8
.9 .10
I J
196.200.220.144/2 196.200.220.160/2
8 8
Address Assignment
 You already have an IP address for your
router’s backbone link (A=.1, B=.2, …)
 You have a /28 for your local network (PC
and router connected to hub)
 Assign your own host addresses from your
local /28 network
FreeBSD Network Interface
Configuration
 configure interface on Unix host
 ifconfig xl0 inet n.n.n.n netmask m.m.m.m
 xl0 is interface name
 n.n.n.n is IP address
 m.m.m.m is netmask
Connect PC to router
console port
 Connect cable to console port on router,
serial port on FreeBSD box
 Use the tip command to connect your
keyboard and screen to the serial port
 e.g. bash$ tip com1
 You may have to edit /etc/remote
 See man pages for tip(1) and remote(5)
 HINT: to exit tip, type ~.
Cisco Router Network Interface
Configuration
 configure backbone interface on cisco
router
conf t
interface ethernet0/0
ip address n.n.n.n m.m.m.m
 ethernet0/0 is interface name
 n.n.n.n is IP address
 m.m.m.m is netmask
 configure local interface on cisco router
 ethernet0/1
Cisco Router Network Interface
Configuration
 Cisco global config should always include:
ip classless
ip subnet-zero
no ip domain-lookup
 Cisco interface config should usually
include:
no shutdown
no ip proxy-arp
no ip redirects
no ip directed-broadcast
Test Connectivity
 PC can ping local interface of router
 Router can ping PC
 PC cannot ping backbone interface of
router
 Router can ping other routers
 PC cannot ping other routers or other PCs
Configure a default route
 Add route on PC
route add default g.g.g.g
 g.g.g.g is IP address of gateway (which is on
cisco router)
 Display forwarding table
netstat -rn
Test connectivity
 All PCs can now reach backbone IP
address of own row
 Still can’t reach other rows
 why?
 Do a traceroute to troubleshoot
Configure static routes for the
remaining classroom desks
 On router, add static routes to other rows
 next hop is backbone interface of other row’s router
ip route n.n.n.n m.m.m.m g.g.g.g
 Repeat several times until complete
Test Connectivity
 All routers can reach all PCs
 All PCs can reach all backbone IP addresses
 All PCs can reach PCs in other rows
 Test with traceroute
Address Assignments
E2 Router SWITCH
196.200.220.0/28
.1 .2
A B
196.200.220.16/28 196.200.220.32/28

196.200.220.0/28
.3 .4
C D
196.200.220.48/28 196.200.220.64/28

.5 .6
E F
196.200.220.80/28 196.200.220.96/28

.7 .8
G H
196.200.220.112/2 196.200.220.128/2
8 8
.9 .10
I J
196.200.220.144/2 196.200.220.160/2
8 8
Configure static routes to
classroom router
 On router, remove all static routes
no ip route n.n.n.n m.m.m.m g.g.g.g
 Repeat many times
 Add default route to classroom router
 next hop is backbone router
ip route 0.0.0.0 0.0.0.0 g.g.g.g
Test Connectivity
 All routers can reach all PCs
 All PCs can reach all backbone IP addresses
 All PCs can reach PCs in other rows
 Test with traceroute
 All static routes have now been added on classroom router
 Global:
enable secret e2@fnog
 Interface:
interface ethernet 0/0
ip address n.n.n.n m.m.m.m
 Router:
router ospf 1
network n.n.n.n w.w.w.w area 0
 Line:
line vty 0 4
Edit FreeBSD the
‘/etc/rc.conf’ file
 On production machines, add lines to
/etc/rc.conf to configure network on
reboot
 hostname="porcupine.tomato.example"
 ifconfig_xl0="inet X.X.X.X netmask
Y.Y.Y.Y"
 defaultrouter=”G.G.G.G"
 See /etc/default/rc.conf for more
information
Static Routing
Exercise
The End

You might also like