L2 / L3 Switches Internet Protocol (IP) Configuration Guide: Revision 1.0
L2 / L3 Switches Internet Protocol (IP) Configuration Guide: Revision 1.0
L2 / L3 Switches Internet Protocol (IP) Configuration Guide: Revision 1.0
Revision 1.0
The information in this USERS MANUAL has been carefully reviewed and is believed to be accurate. The vendor
assumes no responsibility for any inaccuracies that may be contained in this document, makes no commitment to
update or to keep current the information in this manual, or to notify any person organization of the updates.
Please Note: For the most up-to-date version of this manual, please see our web site at www.supermicro.com.
Super Micro Computer, Inc. (Supermicro) reserves the right to make changes to the product described in this
manual at any time and without notice. This product, including software, if any, and documentation may not, in
gf67cbbwhole or in part, be copied, photocopied, reproduced, translated or reduced to any medium or machine
without prior written consent.
IN NO EVENT WILL SUPERMICRO BE LIABLE FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL,SPECULATIVE OR
CONSEQUENTIAL DAMAGES ARISING FROM THE USE OR INABILITY TO USETHIS PRODUCT OR DOCUMENTATION,
EVEN IF ADVISED OF THE POSSIBILITY OF SUCHDAMAGES. IN PARTICULAR, SUPERMICRO SHALL NOT HAVE
LIABILITY FOR ANY HARDWARE,SOFTWARE, OR DATA STORED OR USED WITH THE PRODUCT, INCLUDING THE
COSTS OFREPAIRING, REPLACING, INTEGRATING, INSTALLING OR RECOVERING SUCH HARDWARE,SOFTWARE, OR
DATA.
Any disputes arising between manufacturer and customer shall be governed by the laws of Santa Clara County in
the State of California, USA. The State of California, County of Santa Clara shall be the exclusive venue for the
resolution of any such disputes. Super Micro's total liability for all claims will not exceed the price paid for the
hardware product.
FCC Statement: This equipment has been tested and found to comply with the limits for a Class A digital device
pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful
interference when the equipment is operated in a commercial environment. This equipment generates, uses, and
can radiate radio frequency energy and, if not installed and used in accordance with the manufacturers instruction
manual, may cause harmful interference with radio communications. Operation of this equipment in a residential
area is likely to cause harmful interference, in which case you will be required to correct the interference at your
own expense.
California Best Management Practices Regulations for Perchlorate Materials: This Perchlorate warning applies only
to products containing CR (Manganese Dioxide) Lithium coin cells. Perchlorate Material-special handling may
apply. See http://www.dtsc.ca.gov/hazardouswaste/perchlorate/ for further details.
Manual Revision 1.0
Release Date: September 26, 2013
Unless you request and receive written permission from Super Micro Computer, Inc., you may not copy any part of
this document.
Information in this document is subject to change without notice. Other products and companies referred to
herein are trademarks or registered trademarks of their respective companies or mark holders.
Copyright 2013 by Super Micro Computer, Inc.
All rights reserved.
Printed in the United States of America
Contents
1
IP Overview ................................................................................................................................... 4
1.2
1.2.1
1.2.2
1.2.3
Loopback Interface................................................................................................................ 9
1.3
1.4
1.5
ARP .............................................................................................................................................. 14
1.6
DHCP ........................................................................................................................................... 16
1.6.1
1.6.2
1.6.3
1.7
VRRP ............................................................................................................................................ 29
1 IP Configuration Guide
This document describes the system features supported in Supermicro Layer 2 / Layer 3 switch products.
This document covers the system configurations for the below listed Supermicro switch products.
Blade Switches
SBM-GEM-X2C
SBM-GEM-X2C+
SBM-GEM-X3S+
SBM-XEM-X10SM
The majority of this document applies to the above listed Supermicro switch products. In any particular
sub section however, the contents might vary across these product models. In those sections the
differences are clearly identified with reference to a particular model(s). If any particular model is not
referenced, the reader can safely assume that the content is applicable to all the above listed models.
Throughout this document, the common term switch refers to any of the above listed
Supermicro switch models unless a particular model is noted.
1.1IP Overview
Internet Protocol (IP), the foundation of the IP protocol suite, is a packet-based protocol used for the
exchange of data over computer networks. IP is a network layer that contains addressing and control
information to allow routing of data packets. IP handles addressing, fragmentation, reassembly, and
protocol de-multiplexing.
Supermicro switches support both TCP and UDP at the transport layer for maximum flexibility in
services.
Transmission Control Protocol (TCP) is a connection-oriented protocol built upon the IP layer.
TCP specifies the format of data and acknowledgments used in the transfer of data and also the
procedures used to ensure that the data arrives in correct order. With TCP, multiple applications
on a system can communicate concurrently as it handles all de-multiplexing of the incoming
traffic among the application programs.
With UDP, applications can send messages(also called datagrams) to other hosts on an IP
network without prior setup of transmission channels or data paths. UDP is suitable when error
checking and correction is either not necessary or performed in the application, avoiding the
overhead of such processing at the network interface level.
The following features of IP implementation in Supermicro switches are covered in this document.
Layer3 Interface
Inter-VLAN routing
Static Route
ARP
DHCP
VRRP
1.2Layer 3 Interface
The network layer, or Layer 3,handles the routing of data in packets acrosslogical internetwork paths.
The data link layer, or Layer 2,contains protocols that control the physical layer (Layer 1) and data
framing for transmission on the physical medium. The Layer 2 function of filtering and forwarding data
in frames between two segments on a LAN is known as bridging.
Supermicro switches support three types of Layer 3 interfaces.
The Layer 3VLAN Interface combines the functionality of routing and bridging.
The physical Layer 3 interface allows the switch to be configured like a traditional router. It is
also referred as a Routed Interface.
The Loopback Interface is a logical interface that is always up. It is not tied to any physical
interface therefore it does not go down unless it is administratively shut down.
The Layer3 interface is used to:
Step
Command
Description
Step 1
Step 2
configure terminal
interface <interface-type><interface-id>
or
interface range <interface-type><interface-id> .
Step 3
Step 4
no switchport
Configures the router port
ip address [<ip-address> | <ip-address>/prefix- Configures the IP address.
length] [<subnet-mask>] [secondary]
ip-address A valid IPv4 address.
ip-address/prefix-length - A valid IPv4
Supermicro L2/L3 Switches Configuration Guide
end
Step 6
showip interface
Displays the
information.
1.2.7
Layer
IP
interface
The example below shows the commands used to configure a Physical Layer3 Interface.
SMIS# configure terminal
SMIS(config)# interface Gi 0/22
SMIS(config-if)# no switchport
SMIS(config-if)# ip address 20.20.20.1 255.255.255.0
SMIS(config-if)# end
SMIS# show ip interface
Gi0/22 is up, line protocol is up
Internet address is 20.20.20.1/24
Broadcast address is20.20.20.255
mgmt is up, line protocol is down
Internet address is 192.168.100.102/24
Broadcast address is192.168.100.255
Gateway 0.0.0.0
2 switches.It is also called aSwitch Virtual Interface (SVI )and handles processing for all the packets
associated with that VLAN.
Follow the steps below to configure a Logical Layer3 Interface.
Step
Command
Step 1
Step 2
configure terminal
Create a Layer 2 VLAN and add all required ports.
Step 3
Step 4
Description
Step 5
Step 6
end
show ip interface
The no ip address [<ip_addr>] command deletes the Layer 3 VLAN interface and resets it
as a Layer2 VLAN.
The example below shows the commands used to configure a Logical Layer3 interface.
SMIS# configure terminal
SMIS(config)# vlan 10
SMIS(config-vlan)# ports Gi 0/22 untagged
SMIS(config-vlan)# exit
SMIS(config)# interface vlan 10
SMIS(config-if)#ip address 10.10.10.1 255.255.255.0
SMIS(config-if)# end
Step
Command
Step 1
Step 2
configure terminal
interface loopback <interface-id (1-100)>
Step 3
Description
Step 4
Step 5
Step 6
no shutdown
end
show ip interface
the
loopback
interface
configuration.
IP Routing is not supported on loopback interfaces.
The nointerface loopback <interface-id (1-100)> command deletes the loopback
interface.
SMIS# configure terminal
SMIS(config)# interface loopback 1
SMIS(config-if)# ip address 100.1.1.1/32
SMIS(config-if)# no shutdown
SMIS(config-if)# end
SMIS# show interface loopback 1
Interface Status Protocol Description
--------- ------ -------- ----------loopback1upup
SMIS# show ip interface
mgmt is up, line protocol is down
Internet address is 192.168.100.102/24
Broadcast address is 192.168.100.255
Gateway 0.0.0.0
loopback1 is up, line protocol is up
Internet address is 100.1.1.1/32
Broadcast address is 100.1.1.1
1.3Inter-VLAN Routing
VLANs enable splitting traffic across several manageable broadcast domains. Devices within a VLAN can
communicate with one another without requiring routing. Whenever hosts in one VLAN need to
communicate with hosts in another VLAN, the traffic must be routed between them. This is known as
Inter-VLAN Routing.
Supermicro switches use application-specific integrated circuits (ASICs), which are hardware chips that
can route traffic at very high speeds. These ASICs are installed on the switching engine of a Layer 3
switch, which traditionally switches frames at Layer 2. The ASICs allow the switching engine to also
switch frames that contain packets sent between different VLANs. Each ASIC is programmed with the
information required to route traffic from one VLAN to another, without having to pass the traffic
through the CPU of the routing engine.
Advantages of Inter-VLAN routing in L3 switches:
Supermicro L2/L3 Switches Configuration Guide
10
Layer 3 switches are much more cost effective than routers for delivering high-speed inter-VLAN
routing.
Layer 3 switches are enhanced Layer 2 switches, and therefore have the same high port
densities as Layer 2 switches. Routers on the other hand typically have a much lower port
density.
Layer 3 switches can be configured to operate as a normal Layer 2 switch or Layer 3 switch as
required.
VLAN 300
VLAN 100
VLAN 200
Layer3
Switch
Figure IP-1: Inter-VLAN Routing
Follow the steps below to configure Inter-VLAN routing.
1. Create two Layer 3 interface VLANs.
2. Configure an IP address for both interfaces of these Layer 3 VLANs.
3. Execute show ip route to check if the VLAN routes specified by VLAN IP address are displayed as
connected routes. The routing table has an entry for each VLAN interface subnet, therefore,
devices in VLAN 10 can communicate with devices in VLAN 20 and vice versa.
The example below shows the commands used to configure Inter-VLAN routing.
SMIS# configure terminal
Supermicro L2/L3 Switches Configuration Guide
11
SMIS(config)# vlan 10
SMIS(config-vlan)# ports Gi 0/21 untagged
SMIS(config-vlan)# exit
SMIS(config)# interface vlan 10
SMIS(config-if)#ip address 10.10.10.1 255.255.255.0
SMIS(config-if)# exit
SMIS(config)# vlan 20
SMIS(config-vlan)# ports Gi 0/22 untagged
SMIS(config-vlan)# exit
SMIS(config)# interface vlan 20
SMIS(config-if)# ip address 20.20.20.1255.255.255.0
SMIS(config-if)# end
SMIS# show ip interface
mgmt is up, line protocol is down
Internet address is 192.168.100.102/24
Broadcast address is 192.168.100.255
Gateway 0.0.0.0
vlan10 is up, line protocol is up
Internet address is 10.10.10.1/24
Broadcast address is 10.10.10.255
vlan20 is up, line protocol is up
Internet address is 20.20.20.1/8
Broadcast address is 20.255.255.255
SMIS# show ip route
C 10.10.10.0/24 is directly connected, vlan10
C 20.0.0.0/8 is directly connected, vlan20
C 192.168.100.0/24 is directly connected, mgmt
1.4Static Route
A static route defines an explicit path between two routers. Manual reconfiguration of static routes is
required whenever network changes occur. Static routes use less bandwidth than dynamic routes. No
CPU cycles are used to calculate and analyze routing updates.
Routers forward packets using either route information from manually configured route table entries or
by using the route information calculated with dynamic routing algorithms.
Use of Static Routes:
12
Static routes can be used in environments where network traffic is predictable and the network
design is simple.
Static routes are also useful for specifying a gateway of last resort (a default router to which all
non-routable packets are sent).
Step
Command
Description
Step 1
Step 2
configure terminal
Enters the configuration mode
ip route <prefix><mask> {<next-hop> | Vlan<vlan- Configures the static route. The VLAN id
id (1-4069)> | <interface-type><interface-id> | and interface for this static route.
null0 } [<distance (1-255)>] [ private ]
Prefix The destination network IP
address the route leads to.
Mask A valid IP subnet mask
1.4.1
Next-hop specifies the next-hop IP
address.
Null - Specifies a null interface
1.4.2
Distance Specifies the administrative
distance in the range of 1 to 255. The
default is 1.
Step 3
Step 4
When an interface goes down, static routes through that interface are removed from the IP
routing table.
When the next hop for the address is unreachable, the static route is removed from the IP
routing table.
The no ip route <prefix><mask> { <next-hop> | Vlan<vlan-id(1-4069)> | <interface
-type><interface-id> | null0 } [private] command deletes the static route.
Supermicro L2/L3 Switches Configuration Guide
13
The example below shows the commands used to configure a static route.
SMIS# configure terminal
SMIS(config)# vlan 10
SMIS(config-vlan)# ports Gi 0/21 untagged
SMIS(config-vlan)# exit
SMIS(config)# interface vlan 10
SMIS(config-if)# ip address 10.10.10.1
SMIS(config-if)# exit
SMIS(config)# ip route 200.200.200.0 255.255.255.0 10.10.10.2
SMIS(config)# end
SMIS# show ip route static
S 200.200.200.0/24 [1] via 10.10.10.2
1.5ARP
The Address Resolution Protocol (ARP) feature finds the hardware address, also known as the Media
Access Control (MAC) address, of a host from its known IP address. This mapping of MAC addresses to IP
addresses is stored in a table called the ARP cache.
ARP is part of all Supermicro switches systems that run IP. Though Supermicro switches are Layer 3
switches that forward packets based on IP address, ARP is required for certain cases like default
gateways or for pinging within the same subnet.
14
Defaults
Parameter
Default Value
3
300
None
Step
Command
Description
Step 1
Step 2
configure terminal
arp timeout <seconds (30-86400)>
Step 3
data-link
Step 4
Step 5
Step 6
end
show iparp
15
The example below shows the commands used to configure the ARP.
SMIS# configure terminal
SMIS(config)# arp timeout 800
SMIS(config)# iparp max-retries 10
SMIS(config)# arp 10.0.0.0 48:2C:6A:1E:59:3D vlan 1
SMIS(config)# end
SMIS# show iparp
Address
------10.0.0.0
1.6DHCP
The Dynamic Host Configuration Protocol (DHCP) is based on the Bootstrap Protocol (BOOTP), which can
automatically allocate reusable network addresses and configuration options to Internet hosts. DHCP is
built on a client/server model where designated DHCP servers allocate network addresses and deliver
configuration parameters to DHCP clients.
When a DHCP client requests an IP address from a DHCP server, the client sends a DHCPDISCOVER
broadcast message to locate a DHCP server. A relay agent forwards the packets between the DHCP
client and the server. A DHCP server offers configuration parameters (such as an IP address, MAC
address, domain name, and a lease for the IP address) to the client in a DHCPOFFER unicast message.
16
Supermicro switches support Dynamic Host Configuration Protocol (DHCP) server, DHCP client and DHCP
relay agent functionality.
DHCP Discover
DHCP Offer
DHCP Request
DHCP
Server
DHCP Ack
DHCP
Client
17
The default route IP address should be on the same subnet as the client. When a DHCP client requests
an IP address, the DHCP server accesses the default router list to select another router that the DHCP
client is to use as the first hop for forwarding messages.
1.6.1.5 Lease
DHCP supports three mechanisms for IP address allocation:
Automatic allocation: the DHCP server assigns a permanent IP address to a client.
Dynamic allocation: the DHCP server assigns an IP address to a client from the address pool for either a
limited period of time called a lease or until the client relinquishes the address.
Manual allocation: the network administrator assigns an IP address to a client and DHCP is used simply
to convey the assigned address to the client.
Defaults
Parameter
Default Value
Disabled
None
18
None
None
None
None
None
None
None
None
3600
75
None
None
None
None
None
None
5
Step
Command
Description
Step 1
Step 2
Step 3
Step 4
configure terminal
service dhcp-server
end
show ipdhcp server information
The DHCP relay must be disabled before enabling the DHCP server.
The noservice dhcp-server command disables the DHCP server.
Step
Command
Description
Step 1
Step 2
configure terminal
ipdhcp pool <index (1-2147483647)>
19
Step 3
Step 4
Step 5
Step 6
Step 7
Step 8
Step 9
20
lease { <days (0-365)> [<hours (0-23)> [<minutes (Optional) Specifies the duration of the
(0-59)>]] | infinite }
lease. The infinite keyword specifies
that the duration of the lease is
unlimited.
Step 11
Step 12
Step 13
21
end
Step 15
The no ipdhcp pool <index (1-2147483647)> command deletes the DHCP pool
configuration.
These commands delete values or reset to default values, as applicable:
no network
no excluded-address <low-address> [<high-address>]
no domain-name
no dns-server
no netbios-name-server
no netbios-node-type
no default-router
no option <code (1-2147483647)>
no lease
no utilization threshold
no host hardware-type <host-hardware-type (1-2147483647)> client-identifier <clientmac-address> option <code (1-2147483647)>
Step
Command
Description
Supermicro L2/L3 Switches Configuration Guide
22
Step 1
Step 2
configure terminal
ipdhcpbootfile<bootfile (63)>
Step 3
Step 4
Step 5
Step 6
Step 7
end
show ipdhcp server information
The example below shows the commands used to configure DHCP Server.
SMIS# configure terminal
SMIS(config)# service dhcp-server
SMIS(config)# ipdhcp server 100.100.100.1
SMIS(config)# ipdhcp pool 1
SMIS(dhcp-config)# network 200.200.0.0 255.255.0.0
SMIS(dhcp-config)# excluded-address 200.200.20.20 200.200.20.30
SMIS(dhcp-config)# dns-server 10.10.10.1
SMIS(dhcp-config)# domain-name supermicro.com
SMIS(dhcp-config)# netbios-name-server 172.16.1.3
SMIS(dhcp-config)# netbios-node-type h-node
SMIS(dhcp-config)# option 19 hex 1
Supermicro L2/L3 Switches Configuration Guide
23
24
Hardware type: 1
Client identifier: 00:a0:23:c9:12:ff
Code: 10, Value: 10.10.10.1
SMIS# show ipdhcp server statistics
Address pools: 1
Message
------DHCPDISCOVER
DHCPREQUEST
DHCPDECLINE
DHCPRELEASE
DHCPINFORM
Received
-------0
0
0
0
0
Message
------DHCPOFFER
DHCPACK
DHCPNAK
Sent
---0
0
0
DHCP Discover
DHCP Offer
DHCP Request
DHCP
Client
DHCP Ack
DHCP
Server
25
Step
Command
Step 1
Step 2
configure terminal
interface vlan<vlan-id (1-4069)>|
loopback <interface-id (1-100)>
Step 3
Step 3
Step 4
Step 5
Step 6
Step 7
Step 8
Description
The VLAN should be created before configuring the VLAN client on that particular VLAN.
The no ip address dhcp command deletes the DHCP client configuration.
The example below shows the commands used to configure a DHCP Client.
SMIS(config)# interface Gi 0/22
SMIS(config-if)# no switchport
SMIS(config-if)# ip address dhcp
26
SMIS(config-if)# end
DHCP Discover
DHCP Offer
DHCP Offer
DHCP Request
DHCP Request
DHCP Ack
DHCP
Client
DHCP Ack
DHCP
Server
27
Defaults
Parameter
Default Value
Disabled
Disabled
None
None
Step
Command
Description
Step 1
Step 2
Step 3
Step 4
configure terminal
service dhcp-relay
ipdhcp server <ucast_addr>
ipdhcp relay information option
Step 5
Step 6
Step 7
Step 8
end
show ipdhcp relay information
The DHCP Server must be disabled before enabling the DHCP relay.
These commands delete values or reset default values, as applicable:
noservice dhcp-relay
28
The example below shows the commands used to configure the DHCP relay.
SMIS# configure terminal
SMIS(config)# service dhcp-relay
SMIS(config)# ipdhcp server 172.1.3.15
SMIS(config)#ipdhcp relay information option
SMIS(config)# end
SMIS# show ipdhcp relay information
DHCP Relay: Enabled
DHCP Relay Servers only: Enabled
DHCP server 1: 172.1.3.15
DHCP Relay RAI option: Enabled
Debug Level: 0x0
No of Packets inserted RAI option: 0
No of Packets inserted circuit ID suboption: 0
No of Packets inserted remote ID suboption: 0
No of Packets inserted subnet mask suboption: 0
No of Packets dropped: 0
No of Packets which did not have an RAI option inserted: 0
1.7VRRP
There are several ways a LAN client can determine which router should be the first hop to a particular
remote destination. The client can use a dynamic process or a static configuration.
Examples of dynamic router discovery are Proxy ARP, routing protocol(s), and ICMP Router Discovery
Protocol (IRDP) client. The drawback to dynamic discovery protocols is that they incur some
configuration and processing overhead on the LAN client. Also, in the event of a router failure, the
process of switching to another router can be slow.
29
Switch A (SW-A)
VR1 - Backup, VR2 - Master
Client1
Gateway = SW-A
Client2
Gateway = SW-B
Switch B (SW-B)
VR1 Master, VR2 - Backup
Client3
Gateway = SW-A
Client4
Gateway = SW-B
1.7.1.1 Priority
The VRRP priority determines the role of each VRRP router. If a VRRP router owns the virtual IP address
and the IP address of the physical interface, this router functions as the master. The priority of the
30
master is 255.Priority also determines the backup router in case the master fails;the backup router with
next highest priority is elected as the master.
For example, if Router A, the master in a LAN topology, fails, VRRP must determine if backups B or C
should take over. If Router B has priority 101 and Router C has default priority of100, VRRP selects
Router B to become the master because it has the higher priority. If routers B and C have default priority
of 100, VRRP selects the backup with the higher IP address to become the master.
1.7.1.2 Preemption
VRRP uses preemption to determine what happens after a VRRP backup router becomes the master.
With preemption enabled by default, VRRP switches to a backup if that backup comes online with
ahigher priority than the new master.
For example, if Router A is the master and fails, VRRP selects Router B (next in order of priority). If
Router C comes online with a higher priority than Router B, VRRP selects Router C as the new master
even though Router B has not failed. If preemption is disabled, VRRP switches only if the original master
recovers or the new master fails.
1.7.1.4 Authentication
VRRP supports the following authentication functions:
No authentication
Plain text authentication
VRRP rejects packets in any of the following cases:
The authentication schemes differ on the router and in the incoming packet.
Text authentication strings differ on the router and in the incoming packet.
Defaults
Parameter
Default Value
VRRP Status
VRID
Priority
Disabled
0
100
31
Authentication
None
Pre-empt
Disabled
Advertisement interval
1
Follow the steps below to configure VRRP.
Step
Command
Description
Step 1
Step 2
Step 3
configure terminal
router vrrp
interface [{ vlan<vlan-id (1-4069)> | <interfacetype><interface-id> }]
vrrp<vrid(1-255)> ipv4 <ucast_addr> [secondary]
Step 4
Step 5
Step 6
Step 7
Step 8
Step 9
Step 10
32
33
State is Init
Virtual IP address is 100.100.100.1
Virtual MAC address is 00:00:5e:00:01:64
Master router is 0.0.0.0
Associated IP addresses:
---------------------100.100.100.1
Advertise time is 100 secs
Current priority is 254
Configured priority is 254, may preempt
Configured Authentication
Authentication key is pwd2
vlan10 -vrID 200
--------------State is Init
Virtual IP address is 10.10.10.1
Virtual MAC address is 00:00:5e:00:01:c8
Master router is 0.0.0.0
Associated IP addresses:
---------------------10.10.10.1
Advertise time is 255 secs
Current priority is 100
Configured priority is 100, may preempt
Configured Authentication
Authentication key is pwd1
-END-
34