Location via proxy:   [ UP ]  
[Report a bug]   [Manage cookies]                

Nat Port - Forwarding: Lab Topology

Download as pdf or txt
Download as pdf or txt
You are on page 1of 5

Download PNETLab Platform

PNETLAB Store
PNETLab.com

NAT PORT - FORWARDING

Lab Topology:
Please use the following topology to complete this lab exercise:

Lab Objective:
The objective of this lab exercise is for you to learn and understand how can you configure NAT
Port - Forwarding

Task list:
Task 1: Configure the hostname and IP address for the interface in INSIDE ZONE for Routers as
topo. Check the reachability between Routers.
Task 2: Configure PPPoE Session between R2 and R3 in OUTSIDE ZONE (R2 is PPPoE Client, R3
is PPPoE Server).
Task 3: Configure NAT Port Forwarding on R2, HTTP Server on R1 and R4 and default route on
R1,R2,R4.
Task 4: Check the connection between R3 and R1,R4 via NAT Port.
1
Download PNETLab Platform
PNETLAB Store
PNETLab.com

SOLUTION:
Task 1: Configure the hostname and IP address for the interface in INSIDE ZONE for Routers as
topo. Check the reachability between Routers.
On R1
!
interface Ethernet0/1
ip address 192.168.1.20 255.255.255.0
!
On R2
!
interface Ethernet0/1
ip address 192.168.1.1 255.255.255.0
!
On R4
!
interface Ethernet0/2
ip address 192.168.1.50 255.255.255.0
!
Verification:
R2#ping 192.168.1.20
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
R2#ping 192.168.1.50
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

Task 2: Configure PPPoE Session between R2 and R3 in OUTSIDE ZONE (R2 is PPPoE Client, R3
is PPPoE Server).
On R2
!
interface Ethernet0/0
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside

2
Download PNETLab Platform
PNETLAB Store
PNETLab.com

encapsulation ppp
dialer pool 1
ppp pap sent-username pppoe password 0 cisco@123
!
On R3
!
username pppoe password 0 cisco@123
!
bba-group pppoe global
virtual-template 1
!
interface Ethernet0/0
no ip address
pppoe enable group global
!
interface Virtual-Template1
mtu 1492
ip address 113.48.240.1 255.255.255.252
peer default ip address pool CLIENT
ppp authentication pap callin
!
ip local pool CLIENT 113.48.240.2
!
Verification:
R2#show ip interface brief | e as
Interface IP-Address OK? Method Status
Protocol
Ethernet0/1 192.168.1.1 YES manual up
up
Dialer1 113.48.240.2 YES IPCP up
up

R3#show ip interface brief | e as|down


Interface IP-Address OK? Method Status
Protocol
Virtual-Access1.1 113.48.240.1 YES manual up
up

R3#ping 113.48.240.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 113.48.240.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

3
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Task 3: Configure NAT Port Forwarding on R2 and HTTP Server on R1 and R4.
On R1
!
ip http server
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
On R4
!
ip http server
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
On R2
!
no ip http server
ip route 0.0.0.0 0.0.0.0 Dialer1
!
interface Ethernet0/1
ip nat inside
!
interface Dialer1
ip nat outside
!
ip nat inside source static tcp 192.168.1.20 80 113.48.240.2 80
extendable
ip nat inside source static tcp 192.168.1.50 80 113.48.240.2 8080
extendable
!

// After configuration, from outside, we could connect to HTTP Server in R1, R4 via IP
113.48.240.2 in port 80 and 8080.

Verification:
R3#telnet 113.48.240.2 80
Trying 113.48.240.2, 80 ... Open

R3#telnet 113.48.240.2 8080


Trying 113.48.240.2, 8080 ... Open

R2#show ip nat translations


Pro Inside global Inside local Outside local Outside
global
tcp 113.48.240.2:80 192.168.1.20:80 113.48.240.1:21670
113.48.240.1:21670
tcp 113.48.240.2:8080 192.168.1.50:80 113.48.240.1:45739
113.48.240.1:45739
4
Download PNETLab Platform
PNETLAB Store
PNETLab.com

You might also like