Location via proxy:   [ UP ]  
[Report a bug]   [Manage cookies]                

The Life of A Packet

Download as pdf or txt
Download as pdf or txt
You are on page 1of 5

Download PNETLab Platform

PNETLAB Store
PNETLab.com

THE LIFE OF A PACKET


Lab Objective:
This lab explores DNS configuration on Cisco routers and the ARP cache.

Lab Topology:
The lab network topology is illustrated below:

Link to download: https://user.pnetlab.com/store/labs/detail?id=16153712658058

1
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Task 1: Basic Configuration.


Configure hostnames and IP addresses on all routers as illustrated in the network topology.

Task 2: Configure the Routers as DNS Clients.


Note that routers cannot be DNS servers in Packet Tracer (it does not support the ‘ip dns server’
command) so we are using a Packet Tracer server device as the DNS server.
The host with IP address 10.10.10.10 has been configured as a DNS server and is able to resolve
DNS requests for ‘R1’, ‘R2’ and ‘R3’.
A domain name is not in use.
• Configure R1, R2 and R3 to use 10.10.10.10 as their DNS server. You do not need to
configure a domain-name or domain-list.
• Verify that you can ping R2 and R3 from R1 using their hostnames ‘R1’ and ‘R3’ (it may take
some time for the DNS server to resolve the DNS request).
• Verify that you can ping R1 and R2 from R3 using their hostnames ‘R1’ and ‘R2’.

Task 3: Examine the ARP Cache on the Routers.


• Do you expect to see an entry for R3 in the ARP cache of R1? Why or why not?
• Verify the ARP cache on R1, R2 and R3. What do you see?

Solution
Task 1: Basic Configuration.
Configure hostnames and IP addresses on all routers as illustrated in the network topology.
R1
Router1>enable
Router1#conf t
Router1(config)#hostname R1
R1(config)#interface e0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

R2
Router2>enable
Router2#conf t
Router2(config)#hostname R2
R2(config)#interface e0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.0
R2(config-if)#no shutdown

2
Download PNETLab Platform
PNETLAB Store
PNETLab.com

R2(config-if)#exit
R2(config)#interface e0/1
R2(config-if)#ip address 10.10.20.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R3
Router3>enable
Router3#conf t
Router3(config)#hostname R3
R3(config)#interface e0/0
R3(config-if)#ip address 10.10.20.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit

DNS-Server
Router>enable
Router#conf t
Router(config)#hostname DNS-Server
DNS-Server(config)#ip dns server
DNS-Server(config)#ip domain-lookup
DNS-Server(config)#ip name-server 8.8.8.8
DNS-Server(config)#int e0/0
DNS-Server(config-if)#ip address 10.10.10.10 255.255.255.0
DNS-Server(config-if)#no shutdown
DNS-Server(config-if)#exit
DNS-Server(config)#ip host R2 10.10.10.2

Task 2: Configure the Routers as DNS Clients.


Note that routers cannot be DNS servers in Packet Tracer (it does not support the ‘ip dns server’
command) so we are using a Packet Tracer server device as the DNS server.
The host with IP address 10.10.10.10 has been configured as a DNS server and is able to resolve
DNS requests for ‘R1’, ‘R2’ and ‘R3’.
A domain name is not in use.
• Configure R1, R2 and R3 to use 10.10.10.10 as their DNS server. You do not need to
configure a domain-name or domain-list.

R1
R1(config)#ip domain-lookup
R1(config)#ip name-server 10.10.10.10

R2
R2(config)#ip domain-lookup

3
Download PNETLab Platform
PNETLAB Store
PNETLab.com

R2(config)#ip name-server 10.10.10.10

R3
R3(config)#ip domain-lookup
R3(config)#ip name-server 10.10.10.10
Routing
o R1
R1(config)#ip route 10.10.20.0 255.255.255.0 10.10.10.2

o R3
R3(config)#ip route 10.10.10.0 255.255.255.0 10.10.20.2

o DNS-Server
DNS-Server(config)#ip route 10.10.20.0 255.255.255.0 10.10.10.2

• Verify that you can ping R2 and R3 from R1 using their hostnames ‘R1’ and ‘R3’ (it may take
some time for the DNS server to resolve the DNS request).

R1#ping R2
Translating "R2"...domain server (10.10.10.10) [OK]
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

R1#ping R3
Translating "R3"...domain server (10.10.10.10) [OK]
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

• Verify that you can ping R1 and R2 from R3 using their hostnames ‘R1’ and ‘R2’.

R3#ping R1
Translating "R1"...domain server (10.10.10.10) [OK]
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

R3#ping R2
Translating "R2"...domain server (10.10.10.10) [OK]

4
Download PNETLab Platform
PNETLAB Store
PNETLab.com

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Task 3: Examine the ARP Cache on the Routers.

• Do you expect to see an entry for R3 in the ARP cache of R1? Why or why not?

ARP requests use broadcast traffic so they are not forwarded by a router. R1 will have entries in
its ARP cache for all hosts it has seen on its directly connected networks (10.10.10.0/24). R1 is not
directly connected to the 10.10.20.0/24 network so it will not have an entry in the ARP cache for
R3 at 10.10.20.1. R1 can reach R3 via R2’s IP address 10.10.10.2 – this IP address is included in the
ARP cache. The DNS server at 10.10.10.10 is also in the same IP subnet as R1 so will also appear in
the ARP cache.

• Verify the ARP cache on R1, R2 and R3. What do you see?

R1#show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.10.10.1 - aabb.cc00.0400 ARPA Ethernet0/0
Internet 10.10.10.2 111 aabb.cc00.0300 ARPA Ethernet0/0
Internet 10.10.10.10 122 aabb.cc00.0600 ARPA Ethernet0/0

R2#show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.10.10.1 122 aabb.cc00.0400 ARPA Ethernet0/0
Internet 10.10.10.2 - aabb.cc00.0300 ARPA Ethernet0/0
Internet 10.10.10.10 112 aabb.cc00.0600 ARPA Ethernet0/0
Internet 10.10.20.1 112 aabb.cc00.0500 ARPA Ethernet0/1
Internet 10.10.20.2 - aabb.cc00.0310 ARPA Ethernet0/1

R3#show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.10.20.1 - aabb.cc00.0500 ARPA Ethernet0/0
Internet 10.10.20.2 112 aabb.cc00.0310 ARPA Ethernet0/0

R2 is directly connected to 10.10.10.0/24 and 10.10.20.0/24 so it has entries in its ARP cache for
both networks. R3 is directly connected to the 10.10.20.0/24 network so it has entries in its ARP
cache for that network only. It does not have any entries for the 10.10.10.0/24 network.

You might also like