Location via proxy:   [ UP ]  
[Report a bug]   [Manage cookies]                

IPv6 Static Routes

Download as pdf or txt
Download as pdf or txt
You are on page 1of 11

IPv6 Routing

IPv6 routing works the same way as IPv4 routing, but the processes are
separate, and there are separate IPv4 and IPv6 routing tables
If a router receives an IPv4 packet, it will route it according to its IPv4
routing table
If a router receives an IPv6 packet, it will route it according to its IPv6
routing table
The routing tables are built in the same way, through static routes or
dynamic routing protocols
IPv6 Routing

IPv4 routing is enabled by default on a Cisco IOS router


IPv6 routing is disabled by default
Enter the command ‘ipv6 unicast-routing’ to enable it
You can still configure IPv6 addresses on a router without ipv6 unicast-
routing enabled and send and receive IPv6 traffic, but the router will not
forward IPv6 traffic to other networks
Connected and Local Routes
The administrator configures IP addresses on the router’s interfaces
R1#show run

interface FastEthernet0/0
ip address 10.10.1.1 255.255.255.0
duplex full
ipv6 address 2001:DB8:0:1::1/64
!
interface FastEthernet2/0
ip address 10.10.0.1 255.255.255.0
duplex full
ipv6 address 2001:DB8::1/64
show ip route – IPv4 Routes
This will automatically enter connected and local routes in the routing table.
Local IPv4 routes always have a /32 mask and show the IP address configured
on the interface
R1#show ip route
C 10.10.0.0/24 is directly connected, FastEthernet2/0
C 10.10.1.0/24 is directly connected, FastEthernet0/0
L 10.10.0.1/32 is directly connected, FastEthernet2/0
L 10.10.1.1/32 is directly connected, FastEthernet0/0
! truncated
show ipv6 route - Connected Routes
Local routes always have a /128 mask and show the IP address
configured on the interface
R1#show ipv6 route
C 2001:DB8::/64 [0/0]
via FastEthernet2/0, directly connected
C 2001:DB8:0:1::/64 [0/0]
via FastEthernet0/0, directly connected
L 2001:DB8::1/128 [0/0]
via FastEthernet2/0, receive
L 2001:DB8:0:1::1/128 [0/0]
via FastEthernet0/0, receive
! truncated
Routing

If a router receives traffic for a network which it is not directly attached


to, it needs to know how to get there in order to forward the traffic
An administrator can manually add a static route to the destination, or
the router can learn it via a routing protocol
IPv4 Static Routes

ip route 10.0.1.0 255.255.255.0 10.0.0.1


ip route 10.0.2.0 255.255.255.0 10.0.0.1
10.0.1.1/24
F1/0
10.1.0.2/24 .2 10.0.0.0/24 .1
R2 R1
F1/0 F0/0 F0/0 10.0.2.1/24
F2/0

ip route 10.1.0.0 255.255.255.0 10.0.0.2


IPv6 Static Routes

ipv6 route 2001:DB8:0:2::/64 2001:DB8:0:1::1


ipv6 route 2001:DB8:0:3::/64 2001:DB8:0:1::1
2001:DB8:0:2::/64
2001:DB8:0:1::/64 F1/0
2001:DB8:0:0::/64 :2 :1
R2 R1
F1/0 F0/0 F0/0 2001:DB8:0:3::/64
F2/0

ipv6 route 2001:DB8::/64 2001:DB8:0:1::2


IPv4 Summary and Default Route
ip route 10.1.0.0 255.255.0.0 10.0.0.2
ip route 10.1.3.0 255.255.255.0 10.0.3.2
ip route 0.0.0.0 0.0.0.0 203.0.113.2
Internet
FE1/0
10.1.1.0/24 10.1.0.0/24 10.0.0.0/24 203.0.113.1 .2

.1 .2 .1 .2 .2 .1
R4 R3 R2 R1
FE1/0 FE0/0 FE0/0 FE1/0 FE1/0 FE0/0 FE0/0
FE2/0
FE2/0 FE3/0 10.0.2.1/24
10.1.3.1/24 10.0.3.1/24

R5
FE2/0 FE3/0
10.1.3.2/24 10.0.3.2/24
IPv6 Summary and Default Route
ipv6 route 2001:DB8:0::/48 2001:DB8:0::2
ipv6 route 2001:DB8:1:1::/64 2001:DB8:1::2 Internet

ipv6 route ::/0 2001:DB8:3::2 :2

FE1/0
2001:DB8:0:2::/64 2001:DB8:0:1::/64 2001:DB8:0:0::/64

:1 :2 :1 2001:DB8:3:0::1/64
:1 :2 :2 R1
R4 R3 R2
FE1/0 FE0/0 FE0/0 FE1/0 FE1/0 FE0/0 FE0/0
FE2/0
FE2/0 FE3/0 2001:DB8:2:0::1/64
2001:DB8:1:1::1/64 2001:DB8:1:0::1/64

R5
FE2/0 FE3/0
2001:DB8:1:1::2/64 2001:DB8:1:0::2/64
Lab

You might also like