Experiment No 3
Experiment No 3
Experiment No 3
Procedure:
Create the topology
In each router configure ospf
Click the router
Type :enable
Type :config T
Type :router ospf <process id> #give an id no
#enter directly connected network address
Type :network <network address >< wildcard address> area <area no>
Type: exit
Type: exit
Type: show ip route
Now you can see all directly connected (C) and indirectly connected through ospf (O) networks
EXAMPLE:
Router>ENABLE
Router#CONFIG T
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 25
Design Topology
ROUTER MECH
System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Copyright (c) 2000 by cisco Systems, Inc.
PT 1001 (PTSC2005) processor (revision 0x200) with 60416K/5120K bytes of memory
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface Serial2/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router>ENABLE
Router#CONFIG T
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 25
01:06:47: %OSPF-5-ADJCHG: Process 25, Nbr 192.168.2.1 on Serial2/0 from LOADING to FULL,
Loading Done
01:06:47: %OSPF-5-ADJCHG: Process 25, Nbr 192.168.3.1 on Serial3/0 from LOADING to FULL,
Loading Done
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Router COMP
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface Serial3/0
Router(config-if)#ip address 20.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
This command applies only to DCE interfaces
Router(config-if)#no shutdown
Router(config-if)#router ospf 50
Router(config-router)#network 192.168.2.0 0.0.0.255 area 561
Router(config-router)#network 10.0.0.0 255.255.255.0 area 561
Router(config-router)#network 20.0.0.0 255.255.255.0 area 561
Router(config-router)#exit
Router(config)#exit
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Router#
%SYS-5-CONFIG_I: Configured from console by console
01:06:41: %OSPF-5-ADJCHG: Process 50, Nbr 192.168.3.1 on Serial3/0 from LOADING to FULL,
Loading Done
01:06:41: %OSPF-5-ADJCHG: Process 50, Nbr 192.168.1.1 on Serial2/0 from LOADING to FULL,
Loading Done
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
ROUTER ETRX
System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Copyright (c) 2000 by cisco Systems, Inc.
PT 1001 (PTSC2005) processor (revision 0x200) with 60416K/5120K bytes of memory
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router(config)#interface Serial2/0
Router(config-if)#ip address 20.0.0.2 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
Router(config-if)#exit
Router(config)#interface Serial3/0
Router(config-if)#ip address 30.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up
Router>enable
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Router(config)#router ospf 75
Router(config-router)#network 192.168.3.0 0.0.0.255 area 561
Router(config-router)#network 20.0.0.0 0.255.255.255 area 561
Router(config-router)#network 30.0.0.0 0.255.255.255 area 561
Router(config-router)#
%SYS-5-CONFIG_I: Configured from console by console
01:06:36: %OSPF-5-ADJCHG: Process 75, Nbr 192.168.2.1 on Serial2/0 from LOADING to FULL,
Loading Done
01:06:36: %OSPF-5-ADJCHG: Process 75, Nbr 192.168.1.1 on Serial3/0 from LOADING to FULL,
Loading Done
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Note :Now ping between PC) ,PC1 And PC2 .it should reply properly
Conclusion:
Thus we have studied OSPF configuration and verified